• Cannot create download package list (metalinks)

    Hi, so I’m trying to install Antergos on my laptop (I’ve done this before twice) and am continuing to run into this metalinks error. I’ve seen that this issue has come up before and some solutions were presented here (https://forum.antergos.com/topic/9751/unable-to-install-cannot-create-download-package-list-metalinks), but none of them worked for me. I am running cnchi 0.14.426 and I have tried killing the process before running as well as every other suggestion listed on that forum and others.

    Here are my latest cnchi logs: https://ptpb.pw/kl8s

    I also created another live USB jt ust this evening with the latest Antergos iso, which has continued to fail. Every time I reach the section where you input your name and choose a user password, the error comes up. There used to be different error numbers, but now there are none.

    Any assistance on this matter would be greatly appreciated. Thanks!

  • 2018-05-29 05:38:24 [ERROR] metalink.py(132) create(): Can’t resolve these dependencies: pacman<5.1


    Same error, and already fixed upstream, so wait a bit and Installation will work again!
    new package needs to be synced to the mirrors to be aviable around the world…

  • @lantean And warmly welcome at Antergos-Forum ✌

  • I got this problem with the very latest antergos-minimal-18.5.

    I tried this several times with the minimal and full iso and once got it to run when in the mirror selection section, I chose mirrors from the same hosting company (It seemed that you had to select at least 2 of them, one from each). My reasoning was that if the mirrors were out of sync, that if I chose the same hosting provider then they would at least be in sync with each other, even if behind the global ones.

    That install however, didn’t have the right options. When I re-ran it, I got a different mirror list and didn’t have 2 of the same host so never got past the metalinks error.

    I solved it by running:

    sudo pacman -S pacman-mirrorlist antergos-mirrorlist
    sudo mv /etc/pacman.d/mirrorlist.pacnew /etc/pacman.d/mirrorlist

    vi /etc/pacman.d/mirrorlist and selecting a few mirrors locally, uncommenting them.

    I then restarted the cnchi installer and selected to leave the mirror list alone. The install continued

  • @jez-mckinley possible you have luck, but if mirrors are out of sync, the workaround is to wait…

  • @joekamprad Sorry to barge in after 20 days. My question is: How long are we usually talking about? Is it hours, days or am I waiting for 18.7 to create a new live USB? I don’t mind waiting, but since I have seen no change after trying an installation a few times over the past few days, a general idea of when to try again would be welcome.
    You guessed right, I’m new to all of this. That’s why I would like to wait for Cnchi to work without my interference.
    Thanks in advance and have a nice day.

  • @mikesch
    I don’t know how fast @developers can fix this. The problem has been around at various times, but there still seems to be some issues left to fix. They have received several reports about this, so they probably are working hard to find all remaining problems.

    But in general, I don’t think waiting for 18.7 will help. Basically most of the latest ISOs should work, as the installer (cnchi) updates itself first to the latest release, and after that starts the install process. Devs need to sort the issues first for any installer ISO to work properly.

  • @manuel Thank you. So if I understand all of this correctly my best bet seems to be to simply try again (let’s say once a day) and/or play around with the mirrors in cnchi and hope that at some point my selection of mirrors will be in sync. Would you say this is correct?
    Thanks in advance and have a nice day.

  • @mikesch
    To be honest, I can’t be certain, but that probably is the way to go. And I suppose either letting cnchi choose the mirrors, or selecting mirrors manually, are the best bets currently.

    And probably you already know, you can manually select mirrors by stopping cnchi right after it has managed to update itself, and then edit /etc/mirrorlist and /etc/antergos-mirrorlist to better match your region. Don’t remember it these paths are the same on the installer though. Then restart the cnchi installer from the icon and leave mirrors as they are.

  • The files are /etc/pacman.d/mirrorlist and /etc/pacman.d/antergos-mirrorlist

    Edit those files and in the mirrors screen choose the option “leave mirrors as they are (default)”.


  • @manuel No luck. Maybe I’ve been missing something obvious, since it doesn’t seem to matter which mirrors I choose. I’m supposed to choose a mirror in each list and disable the rest by putting a ‘#’ in front of them, right?
    I’ve also tried updating the lists with ‘sudo pacman -S /etc/pacman.d/mirrorlist’ and the same for ‘/etc/pacman.d/antergos-mirrorlist’. Then copying ‘.pacnew’ over and so on, choosing the mirrors again like the guide from this forum told me to, lastly telling Cnchi to keep the list at default. Assuming I haven’t been doing something wrong in these steps, all the mirrors I’ve tried don’t work for me, resulting in ‘Cannot create download package list (metalinks)’.
    I’ve tried mirrors from my region and others at random with no change. Am I supposed to be able to tell which mirrors to choose?
    One last thing to mention would be that ‘pacman -Syy’ has always resulted in errors. But I guess we already knew that.
    Once more thank you for your help and your patience.

  • @mikesch
    You can copy the preferred mirrors to the beginning of the file, in preference order (best first). It can be a short list. Others should be commented out, prefixing with #.

    With pacman you should install packages, not files. But that doesn’t help now since you have the mirror list files that you can sort manually.

  • @karasu
    Is there a “master” server to use in case of emergency (which won’t have signature errors)?

  • @manuel I did it at last. For me, simply choosing not to install Libre Office did the trick. A big thank you to every helping hand.

installation326 cnchi161 logs16 Posts 14Views 1997
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.