• Error updating


    installing pacman (5.1.0-1) breaks dependency ‘pacman<5.1’ required by pamac

  • Yeah got the same error

  • Same here, still can’t find a solution

  • Glad just not me

  • After upgrading to 5.1.0-1 libalpm.so.10 was missing from /usr/lib. I copied it from another machine into /usr/lib. Dunno if it’s a proper attitude, but brought back pamac to life. I backed the file up here, feel free to download.

    Take a look at my portfolio

  • @piotr i still have it at /usr/lib, maybe ill try to ignore the pacman update and see if it works

  • @jalr980 If you have not yet updated, it may be a good idea to wait and see what happens.

    Take a look at my portfolio

  • I am having this issue as well, looks like pamac needs update prior to pacman to resolve the <5.1 limit as pacman is trying to update to 5.1.01

  • @piotr well to late the update its finishing, lol the only thin now its the error of pacman update everything else its okay

  • I was wondering why it behaved differently here, and we must be on different pamac versions. I’m on the pamac-aur package, and it only demands pacman>=5.0.

    Take a look at my portfolio

  • @piotr said in Error updating:

    After upgrading to 5.1.0-1 libalpm.so.10 was missing from /usr/lib. I copied it from another machine into /usr/lib. Dunno if it’s a proper attitude, but brought back pamac to life. I backed the file up here, feel free to download.

    Did not work for me.
    I had to ignore pacman update:

    sudo pacman -Syyu --ignore=pacman
    
  • @saitodisse said in Error updating:

    Did not work for me.

    Yes, as said above: it updated for me with no warning, as the pamac version I use has slightly different dependencies. It resulted in breaking pamac. I’m on Arch, and I use the pamac-aur package. It seems the Antergos pamac package prevents pacman from updating, as it demands pacman<5.1, not pacman>5.0, as my package does.

    Take a look at my portfolio

  • Same error here guys (Antergos GNOME); following the thread to see if any possible solution.

  • Same error on my system as well (Antergos XFCE).

  • Same on all three if mine (Antergos MATE) and all already had the ```
    libalpm.so.10

    Is this how time normally passes? Reallly slowly… and in the proper order?

  • @darbydoo To fix the problem, I ran: yaourt -Syyu -d . System updated with no problem after running this.

  • @datapioneer My system updates after this, but now issuing yaourt -Syua returns the error “error: missing ‘pacman<5.1’ dependency for ‘pamac’”

  • a lot of packages just havent been updated to have thier dependencies to be greater than 5.0 so the version bump wont let you update those packages. just have to wait it looks like.

    example the new version of pyalpm’s dependency is still >= pacman 5.0 so it cant resolve it.

  • @jardragon901 I’m also getting the error:

    $ yaourt -Syua

    package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory

    Any idea what this means?

  • pacman didnt update correctly it looks like, or its using a newer version of libalpm that isnt uploaded yet, sigh this update has a lot of features but it doesnt seem the rollout was well thought out…to be fair i have done my fair share of that, forgetting i had used an updated library and then forgetting that i had and then breaking it at work lol.

error285 updating28 Posts 31Views 6298
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.