• Antergos Live Desktop freezes almost immediately on T480


    Hello community!

    I have been using Antergos for more or less 1 year on my old T430 notebook without any issues.
    Now I bought a T480 and tried to start Antergos by copying the antergos-18.5-x86_64.iso to my USB stick using the dd-command as specified in the Antergos Tutorial.

    When I boot Antergos it reaches the desktop, but shortly afterwards the desktop freezes and in all but one try (tried it 5 times) even the mouse freezed and I had to reboot.

    I also tried this Nvidia fallback option in the boot menu as I also have the MX150 graphics card, but a message appears that the EFI boot loader has not been found, it switches to legacy mode and eventually into an Antergos desktop. Though, this one freezes as well.

    I tested the USB image on my old T430 and it all works fine and smooth, but on the T480 I don’t even get to start Chrome before it is freezing.

    Has anyone a T480/T480s and seen this issue or has any idea how to find out what the problem is?

    Would be very thankful for any hint on this!

  • http://antergos.kamprad.net/antergos-rescue/release/

    My rescue ISO has nvidia propritary drivers installed and as boot option… you will find cnchi installer as entry under Rescue inside the menu.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Thank you for the ISO link!

    I downloaded the antergos-rescue-6-5-2018-x86_64.iso and put it on the stick. Though I have troubles to get it to work.
    I tried Live System (usb) and Live System (Nvidia USB), but each time I first get the following error:

    ![0_1527447764572_20180527_204739.jpg](Uploading 100%)

    Then it switches to legacy mode. I select either the Nvidia or the standard one, Antergos starts booting (Logs appear up to when the wpa_supplicant started etc.). Finally I shortly see some batch console for login, but this disappears after a second or so and I am stuck with a black screen (nothing happens). Depending on the selected option, there is a console-like white line on the upper left, but I cannot type anything.

    Did I select a wrong option or do I mount my stick the wrong way?
    I just executed the following which claims to have copied 1509949440 bytes:
    sudo dd bs=4M if=./Downloads/antergos-rescue-6-5-2018-x86_64.iso of=/dev/sdc status=progress && sync

  • No you are doing all right… but seems to be a real issue with your graphics… you picture was may to big to upload… if you mind try with uploading directly to imgur or something and provide the link…

    As it looks like you get an hybryd graphics pad, it should have option inside EFI-Bios-Firmware to select how graphics will be used, may try disable the nvidia gpu (discrete graphics) is possible…

    What you can try too is to modprobe.blacklist=nouveau from boot kernel line to avoid that it can load nvidia card… to make sure only intergrated intel graphics are running

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Sorry, didn’t realize the picture was not uploaded.
    On any of the options I tried, I get the following.

    First it shows the text:
    “Error loading \EFI\archiso\vmlinuz: Not Found
    Failed to execute Antergos Live System (usb) (\ȨFI\archiso\vmlinuz)…”)

    Then an error message shows:
    "Error
    Failed to start loeader.efi: (14) Not Found

    OK"

    This is why I thought that UEFI or anything else might be a problem.

    This “modprobe.blacklist=nouveau” I would just append in this boot up line while I am in legacy mode (this second bootup menu), right? In the NVIDIA fallback option this is already part of the many options shown in the text line below 😕

  • No you will have this on every entry also in EFI Boot menu, by pressing “e” and go to the end of the line by pressing the right arrow key.

    On some reserach i find that the T480 have some issues with EFI/UEFI but i do not sort out what exactly.
    All together this T480 should run with Linux as a happy rabbit 😉

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I would check again what options inside the Bios-Firmware can cause this problem.
    I will research a bit, may i do find something helpfull.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Can you give the exact modelname?

    And also check if it works on change the usb port for the usb stick.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • And do you disable secure boot inside Firmware ? (i do not ask this before)

    (not possible to edit posts at the forum 😞 )

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Thanks for the hints!

    So this error message with “Failed to start loader.efi: (14) Not Found” is normal/ not the problem? But when it does not run in the second option either, it cannot be the only problem… 😕

    In the NVIDIA option also in UEFI mode, the modprobe.blacklist = nouveau is already present when I press e and go to the right.
    I also tried these CD/DVD options instead of USB, but they didn’t work either.

    Secure Boot is Off according to the BIOS.

    Tried a second USB port, but didn’t change anything.

    I have a T480 with Model type 20L6S01U00 according to the BIOS, BIOS version 1.12.

    I searched through the BIOS options, but I cannot identify anything that looks suspicious. Sadly, there does not seem to be an option to disable the NVIDIA card, at least I did not found any.

    I also bought the laptop as I thought, that the Lenovo Thinkpads would not have such compatibility issues with linux:/

  • NVIDIA® GeForce® MX150 mit 2GB
    Your model seems to have only the Nvidia and no intel graphics.

    The error “Failed to start loader.efi: (14) Not Found” is not normal and is what makes it not booting.

    I find some entries over the net from people having problem to boot usb ISO for Archlinux and Ubuntu also…

    but nothing helpfull…

    It is also possible that your usb stick is faulty, or write the iso was corrupted on the stick.
    If you can try to use etcher to write the stick it may work, as i never fail with a stick made by etcher.

    sudo pacman -S etcher
    https://etcher.io/

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I installed Windows 10 to test how this behaves and it shows both an Intel HD Graphics 620 and an Nvidia MX150 card in the taskmanager. Short test confirmed that both are used by Windows according to the taskmanager correctly.

    I bought a brand new USB stick today and first tested a Fedora image as someone claimed in reddit this would work with the MX150. Fedora booted out of the box to the Live Desktop although also showing an error do to some nouveau driver which seems to be the NVIDIA issue. (Only the Touchpad drivers did not seem to be installed or working)

    Then I put the standard (non-rescue) antergos image from the website on the stick and although I got the EFI/archiso/vmlinuz error again, in the next boot menu I was able to boot to the desktop by adding modprobe.blacklist=nouveau and this time the desktop did not freeze.
    After adding modprobe.blacklist=nouveau in the (I suppose) UEFI menu and selecting the Non-Nvidia option this desktop loaded without freezing 😌 .

    I am just a little scared to install arch from the last desktop to the Hard Drive as I fear that it will then freeze as on boot up without the option modprobe.blacklist=nouveau. Or is there a way to set this later (sorry for noob question, I am not that familiar with these boot settings)?

    Ideally I would simply like to install the NVIDIA driver and have the graphics card working under linux, but if this doesn’t work I am also fine with simply disabling it.

    I want to install antergos as dual boot with Windows, which I sadly need for some applications, and UEFI bootup. Weirdly it shows the restriction that I cannot create more than 4 “primary partitions”. I thought this should be irrelevant if UEFI is used or will Antergos install with this MBR boot partition?

  • @clanow said in Antergos Live Desktop freezes almost immediately on T480:

    4 “primary partitions”

    is only present if the drive has a DOS partition table and not if you choose to take a gpt table.

    And if you dualboot read this first:
    https://antergos.com/wiki/install/how-to-dual-boot-antergos-windows-uefi-expanded-by-linuxhat/

    The way to do so is to have windows installed first, and make sure to do not install in legacy mode (BIOS / MBR) to get fully advantage of an EFI system (and to make gpt aviable)

    As your card is supported to work with nvidia driver:
    http://www.nvidia.com/download/driverResults.aspx/134262/en-us
    The driver to choose is then the now legacy driver nvidia-390xx as nvidia do not support your card with latest driver anymore.

    You will be able to get bumblebee working:
    https://antergos.com/wiki/hardware/bumblebee-for-nvidia-optimus/
    But this have to be done after installing the system. Make sure to do not choose to install nvidia drivers at Antergos install!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Thank you again joekamprad for the explanation!
    Furthermore, sorry for the late answer, as just today I got the time to continue the setup and first reinstalled Windows 10 in UEFI mode…

    So I now installed Antergos with Dual Boot next to Windows 10 in UEFI mode.:)

    Antergos installed successfully, but - as expected - only runs stable when I add modeprobe.blacklist=nouveau as a boot parameter.

    Now, I guess first thing to do is installing the nvidia driver and then try to install bumblebee.

    Is it best/possible to run the downloaded NVIDIA driver file directly for installation?
    I also found Nvidia-Installer-2 (sorry, can’t link the antergos guide as I get told, it would be spam…) in which a nvidia-installer package is used, but I don’t see where the specific driver is selected then? Maybe installing it directly is the best way from preventing it updating by itself…

    Do I need to install Bumblebee only in case automatically switching to the integrated graphics does not work or is Bumblebee always necessary in Linux/Antergos?
    I guess for the installation commands I can take the “modern hardware” command line installation option in the guide?

  • Just as a side note / appendix:
    I think in my installer I did not even have the option of installing a proprietary driver even if I wanted to.

  • @clanow said in Antergos Live Desktop freezes almost immediately on T480:

    Maybe installing it directly is the best way from preventing it updating by itself…

    With directly do you mean what?

    the nvidia-installer from Antergos is a script that will detect hardware and install right driver for nvidia card, plus creating nessesarry configs.

    All installed packages where updated manually woth package manager or from commandline.

    You can follow the wiki entry for bumblebee, or use nvidia-installer script to get it installed.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I just meant that the driver is not managed by a package manager in this case, but maybe this was a false assumption. Sorry for the confusion.

    One last question: I also think about just using the Intel card and “permanently disabling” the NVIDIA card. Can I do this by just uninstalling the nouvea driver like in the tutorial (sudo pacman -Rc xf86-video-nouveau) or can this be a problem and I should rather blacklist nouveau permanently?
    Guess for the last thing I would have to edit the grub boot parameters.

  • modprobe.blacklist=nouveau
    

    would be the kernel parameter, but this can cause also problems, as it leaves the driver unhandeld but is not deactivating it…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • ok, this sounds not that good.
    For now, I would just like to use the Intel card only and then I would also not need Bumblebee etc… Therefore, I uninstalled xf86-video-nouveau as above, but sadly it still needs modprobe.blacklist=nouveau to boot.

    Can you tell me what is the best way to handle this permanently? Is there some way to deactivate it permanently so that it is not used by antergos?

  • there is a nouveau driver already inside the kernel (Kernel modsetting driver) the xf86-video-nouveau is the DDX driver (which provides 2D acceleration in Xorg) so blacklisting is needed also.

    This can be done permanently by adding this to kernel boot line:

    edit /etc/default/grub
    sudo nano /etc/default/grub
    and add it like this:

    # GRUB boot loader configuration
    
    GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR="Antergos"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet modprobe.blacklist=nouveau resume=UUID=...
    GRUB_CMDLINE_LINUX=""
    ...
    

    then regenerate the grub.cfg:
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

live51 freezes23 immediately3 t4801 Posts 28Views 891
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.