• Trouble logging in.


    Hi,

    I’m new here.

    After installing antergos-18.5-x86_64 and rebooting i’m taken to the login screen where i’m asked to “Select your user and enter password”, but there seems to be no option to select a user. I have created a user at the relevant screen during installation.

    Any help in this matter will be appreciated. Thanks in advance.

  • can you login with username and given password into CLI?

    press [ctrl+alt+F2] and give username and password?

    What DE (GNOME XFCE e.t.c.) do you choose on install?

  • @joekamprad Yes, i’m able to login using CLI,
    I’m using KDE.

  • first try simple restarting loginmanager: sudo systemctl restart lightdm

  • If you are connected with wired lan you can install kde loginmanager

    sudo pacman -S sddm sddm-kcm
    sudo systemctl -f enable sddm
    

    and sudo reboot

  • @joekamprad I don’t have access to wired LAN at the moment, wi-fi only.

    On running sudo systemctl restart lightdm, im getting the following:

    “Job for lightdm.service failed because the control process exited with error code. see “systemctl status lightdm.service” and “joutnalctl -xe” for details.”

    o/p of systemctl status lightdm.service shows that lightdm is loaded.

    o/p of joutnalctl -xe is:

    "Main process exited, code=exited, status=1/FAILURE
    Failed with result “exit-code”
    Failed to start Light Display Manager

    Start request repeated too quickly
    Failed with result “exit-code”
    Failed to start Light Display Manager"

  • nvidia grafics?

  • so then … do you choose propritary nvidia driver to install on installation?

    As there are some problems at the moment because nvidia move some older cards to legacy and this ones are no longer work with latest drivers…

  • @joekamprad Yes, I chose to install Nvidia drivers. How should I move forward now?

  • You can remove nvidia drivers and startup with integrated into kernel open source drivers:

    sudo pacman -Rsn nvidia
    
    sudo nano /etc/mkinitcpio.conf
    

    Add nouveau to the modules:

    # vim:set ft=sh
    # MODULES
    # The following modules are loaded before any boot hooks are
    # run.  Advanced users may wish to specify all system modules
    # in this array.  For instance:
    #     MODULES=(piix ide_disk reiserfs)
    MODULES="nouveau"
    

    save with [Ctrl+X]

    Rebuild images:

    sudo mkinitcpio -p linux
    
  • ups and do not forget to remove the xorg config for nvidia:

    sudo rm /etc/X11/xorg.conf.d/20-nvidia.conf before rebooting!!!

  • @joekamprad I tried the steps, still facing the same issue. Is this issue specific to KDE? Should i try to install with a different DE?

  • yes, it will be ralated to KDE or also can be a problem with lightdm (Loginmanager + KDE)
    As far as i know the only DE without problems on install is GNOME at the moment…

    They are signature problems nvidia driver problems and also a problem with XFCE that do not login with nouveau… so a lot issues at the moment.

    If you can i would wait some days, if you can`t wai getting Antergos istalled i will need het some logs:

    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    

    and give url to the pastebin it creates (at the very end)

    https://antergos.com/wiki/miscellaneous/how-do-i-include-system-logs-when-asking-for-help/

  • Reading all this and other threads concerning this, I have a feeling Lightdm has problems with all DE’s that don’t rely on gtk3 in combination with nouveau.
    Deepin, XFCE, KDE, there is a pattern in here.

  • @joekamprad I can wait, nothing urgent. But i will do an installation of GNOME for now, and try KDE again in a few weeks time.
    Thanks for helping

  • @bryanpwo i can take a look … if it helps to use another DM…

  • i can not reproduce a problem with lightdm itself…
    With nouveau i can only login to XFCE if i have the package xf86-video-nouveau uininstalled and using the kernel driver itself… same on lightdm GDM SDDM, i get back to loginprompt with xf86-… installed if i uninstall it i can login on all 3 DM’s

  • @joekamprad
    I can’t reproduce it either with KDE, with XFCE I ran into the same problem/solution as you. So maybe we can rule out my theory then.

trouble16 logging5 Posts 19Views 436
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.