• exit_boot() failed and efi_main() failed?


    This didn’t happen when I tested in a VM, but it’s happening when I try to install to my main machine.
    Whether I boot from usb or from a dvd, the initial menu giving me the choice between antergos or the fallbacks does show up. But when I sleect one it just gives me a black screen that says
    exit_boot() failed!
    uefi_main() failed!

    Not sure where to go from here. Googling has lead me to dead ends. 😞

  • secure boot is disabled in EFI-BIOS-Firmware?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Yep, secure boot is off… Well I can’t say that entirely with confidence because I can’t find the option for it in my motherboard at all. Just uefi and uefi+legacy. It’s just set to uefi right now but I’m not sure if legacy would cause it to be installed in legacy or not. 😞

  • @sukid
    I think uefi+legacy might help here. You could install in legacy mode.
    But if you are dual booting and the other systems are in UEFI mode, then it may not work. Depends on your motherboard probably.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL here.

  • You could (in BIOS/firmware) make the installer stick to boot in legacy mode.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL here.

  • I don’t plan on dual booting, though is there any downside to installing in legacy mode? I’ll also have to have another look through my mobo settings when I get back home… It’s an MSI z97 gaming 5.

  • @sukid said in exit_boot() failed and efi_main() failed?:

    MSI z97 gaming 5.

    usually on thouse MSI Boards it is disabled by default, but you may have had windows installed before and it is set to enabled… also possible that the settiungs are hidden und you will need to set bootmode to something like windows and they will appear…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Not much of a downside installing in legacy mode.
    Legacy mode is older than UEFI.
    The only potential issue I can think of is if you have a very large disk, more than 2 TB. In legacy mode, the disk partition table should be msdos instead of gpt. Only gpt will properly support very large disks AFAIK.

    But @joekamprad is right, there may still be settings on the motherboard that should be checked to get UEFI working. In principal UEFI should be better since it is newer and has better support for newer disks.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL here.

  • I checked more thoroughly. Secure Boot is indeed disabled, I just had to temporarily enable Windows 10 features in order to see it. Stuff like fast boot is also disabled. I have a backup drive that’s 5tb so I’m really not sure I want to use legacy mode…

    The only things I haven’t tried yet are writing the antergos iso in dd mode instead of the typical rufus mode (which I’m doing now), or plugging my bluray drive into a sata port instead of the sata to usb 3.0 adapter I have it on right now. I’ll report back what the results of those will be when I can. Been sleeping all day and working all night. :F

  • i had to use the dd mode myself to get the iso to work on my msi laptop so i would suggest trying it at least.

  • ack cant edit my post, i would also recommend using a usb thumb drive to install. i always had problems burning isos but now i have a cheap usb thumb drive that i test distros with.

  • Yep, dd mode worked! … for one boot. I restarted to do something in windows real quick then it started doing that again, but another dd fixed it. So worst case scenario I know I just have to dd again.
    Yeah I am surprised burning a dvd didn’t work! Ah well. Glad I got this working now. 🙂

  • it is all in the details 🕵️‍♀️

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

efimain1 exitboot1 Posts 13Views 402
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.