• How can I prevent bluetooth from turning on at boot?


    What I’m trying to do is prevent bluetooth from turning on at boot. I do not want to disable the bluetooth service. I would just like to have bluetooth turned off and be able to turn it back on when I need it.

    According to the Arch wiki, this should be the default behaviour, but for whatever reason, it turns on whenever I log in. I’ve tried setting AutoEnable to false in /etc/bluetooth/main.conf, but no luck there either. Did I break it somehow?

    Before discovering the problem, I did set Bluetooth ERTM to off using the instructions in post #10 here:
    https://bbs.archlinux.org/viewtopic.php?pid=1726909#p1726909

    This was needed because I was trying to pair my XBONE controller (which worked!). Does disabling ERTM mess with AutoEnable somehow?

  • To make the info complete, please mention your DE also, so we can help you more specifically.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • Sorry about that! My DE is XFCE and I have blueman as my bluetooth manager.

  • Bluetooth is most likely selected automatic at start up. XFCE has this enabled by default, you can disable it in the settingsmenu in start up and session (I don’t know if it’s the correct english name for it, but it’s in the section hardware) Just unselect bluetooth in that menu and you’re good to go.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • Thanks, Bryan. I did find a Session and Startup section in the settings menu, but it does not appear to have a hardware tab:

    https://imgur.com/a/L3ZOD1a

    The only thing bluetooth-related is the blueman manager in the application autostart section. I can disable it, but I imagine all that does is it gets rid of the manager, but bluetooth would still be on. Or am I wrong on this?

    I also took a look at the bluetooth adaptor settings by clicking the bluetooth icon in the taskbar and that didn’t turn up anything helpful either:

    https://imgur.com/a/M5BMYCz

  • If you disable it, it won’t autostart.

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • @onlooker You can also use blueberry bluetooth backend, it will integrate into xfce settings too, and have a switch to put on and of, this setting will be in the state also after reboot.
    0_1527270954990_Bildschirmfoto vom 2018-05-25 19-54-32.png

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Thanks, joekamprad. That did the trick! Marking as solved.

  • good to hear!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

boot255 bluetooth45 turning6 prevent4 Posts 9Views 271
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.