• Installation failure at integrity checck


    yes install still faild again on integry check of a package from pacman cache:

    2018-05-25 18:16:57 [DEBUG] pac.py(556) cb_log(): found cached pkg: /install/var/cache/pacman/pkg/sudo-1.8.23-2-x86_64.pkg.tar.xz
    2018-05-25 18:16:57 [DEBUG] pac.py(556) cb_log(): sha256sum: 1aa83e470852350bdd75e4664765c7f8792a2dbf6667a5713d172d2f3de2f48d
    2018-05-25 18:16:57 [DEBUG] pac.py(556) cb_log(): checking sha256sum for /install/var/cache/pacman/pkg/sudo-1.8.23-2-x86_64.pkg.tar.xz
    2018-05-25 18:16:57 [DEBUG] pac.py(556) cb_log(): returning error 34 from check_validity : Ungültiges oder beschädigtes Paket
    
  • hi everyone, can anybody help me, cant still install the OS in my laptop

  • For what its worth, the clear cache solution worked for me. I was getting the same zero with an error code of ‘0’, like some of the others.

    @joekamprad said in Installation failure at integrity checck:

    Hm as far as i know cnchi is installing packages from pacman cache if they are up to date, and so it do not need to download them again…

    But you can try to do not do trhat by vlosing cnchi and start without the --cache // -c option…

    sudo pacman -Syy
    sudo cnchi -v

    or cleanup the cache before install sounds also as a solution to me:

    sudo paccache -rk 0

    Opened the live cd, closed cnchi, opened terminal. First ran:

    sudo paccache -rk 0
    

    Then, I included the rest to ensure no funny business - I was paranoid at this point that all the cache wasn’t deleted - on no grounds, just paranoid:

    sudo pacman -Syy
    sudo cnchi -v
    

    It worked on a kde install with printer support and AUR. Used automatic mirror option. Tried to install it several times last night but all were unsuccessful. Tried it today without the fix today and it still didn’t work. That’s what compelled me to try the cache solution in the first place. Once I got a successful install I came here, registered, and posted.

    I don’t think it matters, but I jumped between kde and xfce during my install attempts because I like both. I don’t think its tied to DE like some people have suggested.

  • i download the ISO again after the devolper say he found some bug on the early iso and now is working without do anything.

    Thanks everyone

  • I just wanted to try out Antergos and downloaded the latest ISO from the website. I chose deepin desktop environment and it couldn’t install, not even with a manual update of Cnchi.

    Error on the console output: Can’t resolve these dependencies: deepin-wm-switcher.

    Gnome installs just fine, but I was really looking forward to use Deepin. Are these images not tested before they are made available for download?

  • @vogtmh The ISO is not the cause, as cnchi and install is handled outside the ISO, as they will be downloaded and updated from servers.

    But at the moment there was some package and dependency changes needs attention to get fixed and patched package needs to be builded and after testing and automated procedures it reaches the mirrors…

    antergos-deepin-meta is the meta package we are using to get deepin DE installed, and the patched version seems stoill not be aviable on the mirrors, it hangs in the queue https://build.antergos.com/package/antergos-deepin-meta

  • Today I tried many time to install Antergos with XFCE but it fails at the end with the integrity check message and error number = None.

    Here is my output when it break:

    2018-05-26 22:12:51 [ERROR] pac.py(164) finalize_transaction(): Can't finalize alpm transaction: transaction failed, pm_errno 34 (invalid or corrupted package), []
    Traceback (most recent call last):
      File "/usr/share/cnchi/src/pacman/pac.py", line 160, in finalize_transaction
        transaction.commit()
    alpm.error: transaction failed, pm_errno 34 (invalid or corrupted package), []
    2018-05-26 22:12:51 [DEBUG] pac.py(167) finalize_transaction(): Releasing alpm transaction...
    2018-05-26 22:12:51 [DEBUG] pac.py(169) finalize_transaction(): Alpm transaction done.
    2018-05-26 22:12:51 [ERROR] process.py(130) run(): "Can't install necessary packages. Cnchi can't continue."
    2018-05-26 22:12:51 [ERROR] process.py(135) run(): Traceback (most recent call last):
    2018-05-26 22:12:51 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/installation/process.py", line 108, in run
        self.pkg.packages, self.down.metalinks)
    2018-05-26 22:12:51 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/pages/advanced.py", line 2451, in run_install
        self.installation.start()
    2018-05-26 22:12:51 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/misc/extra.py", line 191, in helper
        return func(*args, **kwargs)
    2018-05-26 22:12:51 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/installation/install.py", line 329, in start
        self.install_packages()
    2018-05-26 22:12:51 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/installation/install.py", line 540, in install_packages
        raise InstallError(txt)
    2018-05-26 22:12:51 [ERROR] process.py(135) run(): misc.extra.InstallError: "Can't install necessary packages. Cnchi can't continue."
    2018-05-26 22:12:51 [INFO] slides.py(276) manage_events_from_cb_queue(): Downloading guile-2.2.3-1-x86_64...
    2018-05-26 22:12:51 [INFO] slides.py(276) manage_events_from_cb_queue(): Checking keys in keyring...
    2018-05-26 22:12:51 [INFO] slides.py(276) manage_events_from_cb_queue(): Checking integrity...
    

    Hope it could help a little bit… Thanks!

  • @opitrice You could try something like here: https://forum.antergos.com/topic/9975/cnchi-fails-when-installing-xfce/2
    Or maybe install without DE (install Base) and then use the link advice.

error337 install84 integrity3 checks2 Posts 49Views 2841
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.