• Installation failure at integrity checck


    Hello,
    I have a problem with the installation of antergos on my Lenovo 120s-11iap.
    I use the uefi only bios option because in legacy support the iso won’t boot.
    I use the newest version 18.5 and at one of the last integrity checks, I think just before the grub installation the installer fails with the message “Can’t install necessary packages. Cnchi can’t continue” and the error code ist “none” so it seems that there isn’t actually something wrong. The progress bar also went all the way to 100% and then the message appears. Please help me out. Sick of installing arch the good 'ol way :D .
    Greetings from Germany.
    Josh

  • ![0_1527177418658_1527177403655-1726829218.jpg](Uploading 100%)
    That’s the error if I use the minimal iso. I wanted to try it in legacy only mode but I only get a black screen on boot.
    Greetings

  • @jshamg don’t know why the image link did not work but the error says the same except that it’s error 0 instead of error none.

  • @jshamg
    You can use the following type of a command for your picture:

    cat "your-picture.jpg" | curl -F [email protected] https://ptpb.pw/?u=1
    

    and show the returned URL here.

  • Also logs about the failure are useful:

    cat /tmp/cnchi.log | curl -F [email protected] https://ptpb.pw/?u=1
    
  • @jshamg I’m experiencing the same problem.

    In the logs the following message is reported as the exception:

    can’t finalize alpm transaction

    Can anyone help with resolving this issue?

    Thanks

  • @wayne-f
    The full cnchi log might help solving it, hopefully.

  • @manuel I’m unable to as the machine currently has kubuntu installed as a result of this problem. When the problem is resolved I will revert back to Arch.

  • Same here. Trying to install antergos with aur, cups and xfce4. cnchi log: https://ptpb.pw/8rvy

  • @jshamg @Wayne-F
    without the cnchi logs we can not say anything… and also not possible to fill a BUG report, what devs can use to solve this… ;)

  • @joekamprad My log is the same as @Razen

    Regards.

  • This is rather frustrating…this the second time in as many months that I have had an installation problem. The first time was an outdated cnchi version which was being pulled down from the repo (@joekamprad will remember) and now this.
    Is there any chance that we can have an installer that persistently works? Surely this should have been tested before release.
    What can I do to help, as I am software engineer and have a little spare time?

  • @razen
    Thanks for the log.
    At least there is a worrying line:

    2018-05-24 17:39:05 [ERROR] pac.py(164) finalize_transaction(): Can't finalize alpm transaction: transaction failed, pm_errno 34 (invalid or corrupted package), []
    

    that is not giving much info about which package(s) have failed, so hard to check the log with that.

    @Wayne-F
    If you are familiar with python, you could install cnchi package and look at that python code. I’m not a cnchi developer so I don’t know much about it, but the error line above does not have any useful info about failed packages. It probably would be quite useful to find a reason why cnchi did not report the package names or any other useful info about the failure, and add some more reporting there.

    Maybe @developers could comment more about this?

  • @wayne-f
    And thanks for your offer to help! It is very welcome, as the development team is not very large. Any help is greatly appreciated! :)

  • @manuel I’ve just tried to install a base image on a vm and it now works completely.

  • @wayne-f
    Great! But the Base install naturally is much smaller to download, so that would refer to some networking/downloading issues with a DE install, or some mirror issue.
    Anyway, after the Base install you can install a DE to it.

    Just an off-topic idea: from the VM it might be possible to copy the Base install into a native hardware and try to run it… And if any required drivers are missing, then booting from the installer stick could be used for installing the missing drivers…
    This is not for the faint-hearted though.

  • i get the same error, here is my log link text i’ll try to help debug as much as i can.

  • @manuel

    Temporary solution install base, then manually build arch (plus DE) from there. It only takes 5 minutes from base.

  • okey dokey

  • okay guys i think were all in the same boat. got the same error. I’ll post the logs.
    cnchi.log:

    2018-05-24 22:43:07 [INFO] slides.py(276) manage_events_from_cb_queue(): Checking integrity...
    2018-05-24 22:43:16 [ERROR] pac.py(164) finalize_transaction(): Can't finalize alpm transaction: transaction failed, pm_errno 34 (invalid or corrupted package), []
    2018-05-24 22:43:16 [DEBUG] pac.py(167) finalize_transaction(): Releasing alpm transaction...
    2018-05-24 22:43:16 [DEBUG] pac.py(169) finalize_transaction(): Alpm transaction done.
    2018-05-24 22:43:16 [ERROR] process.py(130) run(): "Can't install necessary packages. Cnchi can't continue."
    2018-05-24 22:43:16 [ERROR] process.py(135) run(): Traceback (most recent call last):
    2018-05-24 22:43:16 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/installation/process.py", line 108, in run
        self.pkg.packages, self.down.metalinks)
    2018-05-24 22:43:16 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/pages/advanced.py", line 2451, in run_install
        self.installation.start()
    2018-05-24 22:43:16 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/misc/extra.py", line 191, in helper
        return func(*args, **kwargs)
    2018-05-24 22:43:16 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/installation/install.py", line 329, in start
        self.install_packages()
    2018-05-24 22:43:16 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/installation/install.py", line 540, in install_packages
        raise InstallError(txt)
    2018-05-24 22:43:16 [ERROR] process.py(135) run(): misc.extra.InstallError: "Can't install necessary packages. Cnchi can't continue."
    
error304 install82 integrity3 checks2 Posts 49Views 2521
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.