• HDA Intel PCH Internal Mic/Internal Mic 1?


    Just installed Antergos Gnome on a MacBookPro Retina and I can’t get the microphone to pic up audio.

    I have investigated with help of Arch Wiki and been looking through the forum here but come to a catch22 of sorts.

    Alsamixer opens up on “default” (PulseAudio) instead of my “HDA Intel PCH” card. All levels are up on both PulseAudio and HDA Intel PCH. I have two posts for the mic: “Internal Mic” and “Internal Mic 1”. If I select “Internal Mic 1” the internal mic gets muted in Gnome Audio Settings. If I unmute it in Gnome Audio Settings and tap the laptop I get readings for about a split second, then it gets muted again. When looking at Alsamixer it seems that as long as “Internal Mic 1” is ON I get sound. But as soon as I unmute the mic from Gnome System Settings it switches back to “Internal Mic” and that’s when the audio-input stops - But during that split-second timewindow before the switch I get audio-input.

    No idea of how to go about this.

  • @joekamprad I’ve been sooo occupied with other stuff I haven’t had time to really dig into this until now.

    I have tried all the tools listed on the link you gave me, but nothing seems to help. Intersting is that when I list my devices with pactl list sinks I see:

    [[email protected] ~]$ pactl list sinks
    Mottagare #4
    	Tillstånd: SUSPENDED
    	Namn: alsa_output.pci-0000_00_1b.0.analog-stereo
    	Beskrivning: Inbyggt ljud Analog stereo
    	Drivrutin: module-alsa-card.c
    	Samplingsspecifikation: s16le 2 kan. 44100 Hz
    	Kanalmappning: front-left,front-right
    	Ägarmodul: 6
    	Tyst: nej
    	Volym: front-left: 30148 /  46% / -20,23 dB,   front-right: 30148 /  46% / -20,23 dB
    	        balans 0,00
    	Basvolym: 52057 /  79% / -6,00 dB
    	Övervakarkälla: alsa_output.pci-0000_00_1b.0.analog-stereo.monitor
    	Latens: 0 µs, anpassad 0 µs
    	Flaggor: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
    	Egenskaper:
    		alsa.resolution_bits = "16"
    		device.api = "alsa"
    		device.class = "sound"
    		alsa.class = "generic"
    		alsa.subclass = "generic-mix"
    		alsa.name = "CS4206 Analog"
    		alsa.id = "CS4206 Analog"
    		alsa.subdevice = "0"
    		alsa.subdevice_name = "subdevice #0"
    		alsa.device = "0"
    		alsa.card = "0"
    		alsa.card_name = "HDA Intel PCH"
    		alsa.long_card_name = "HDA Intel PCH at 0xa0610000 irq 50"
    		alsa.driver_name = "snd_hda_intel"
    		device.bus_path = "pci-0000:00:1b.0"
    		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
    		device.bus = "pci"
    		device.vendor.id = "8086"
    		device.vendor.name = "Intel Corporation"
    		device.product.id = "1e20"
    		device.product.name = "7 Series/C216 Chipset Family High Definition Audio Controller"
    		device.form_factor = "internal"
    		device.string = "front:0"
    		device.buffering.buffer_size = "352800"
    		device.buffering.fragment_size = "176400"
    		device.access_mode = "mmap+timer"
    		device.profile.name = "analog-stereo"
    		device.profile.description = "Analog stereo"
    		device.description = "Inbyggt ljud Analog stereo"
    		alsa.mixer_name = "Cirrus Logic CS4206"
    		alsa.components = "HDA:10134206,106b3b00,00100302 HDA:80862806,80860101,00100000"
    		module-udev-detect.discovered = "1"
    		device.icon_name = "audio-card-pci"
    	Portar:
    		analog-output-speaker: Högtalare (priority: 10000)
    		analog-output-headphones: Hörlurar (priority: 9000, not available)
    	Aktiv port: analog-output-speaker
    	Format:
    		pcm
    
    

    Am I blind or is there no mic/input listed?

  • Ahhh! Finally I got it to work!

    So apparently this was a known issue with the MacBook Pro Retina 10,2.

    Solution was to create /etc/modprobe.d/alsa-base.conf and add the line: options snd-hda-intel model=mbp101

    After I rebooted the mic worked like a charm ✌

    Source: https://wiki.archlinux.org/index.php/MacBookPro10,x#Sound_and_microphone

    Hope it’ll help someone else who might run into the same issue.

intel39 internal7 pch1 hda1 Posts 4Views 449
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.