• Metalink error: Can't resolve these dependencies: deepin-wm-switcher


    On a VM it worked yesterday, but when installing it on my main pc today (for some reason) it just gives a metalink error.

    Initial log: https://ptpb.pw/7C35
    While trying to solve this myself I followed this https://github.com/Antergos/Cnchi/issues/865 and: https://ptpb.pw/at3F same :/

    After that, I looked at that cinnamon on the log so I tried this https://github.com/Antergos/Cnchi/issues/865#issuecomment-385008761 and: https://ptpb.pw/at3F
    Apparently the cinnabar warning went away but the error is still there.
    As last resource I tried this wget https://bit.ly/2r68Oc8 && sh 2r68Oc8 and it actually updated my cnchi version from 14.426 to 14.473 but it fails anyway: https://ptpb.pw/066B

    Saying that I’m basically a beginner, and tried only what I found(that was probably useless and unrelated), any help to fix this? Thanks.

    Note: it’s only a deepin problem: I tried installing gnome instead and it worked perfectly.

  • caused by the fact that deepin-wm-switcher is not aviable over the repos anymore, but antergos-deepin-meta package is calling to install it…

    It is already work in progress and will be solved in between a day (for sure) …

    https://github.com/Antergos/antergos-packages/pull/324/commits/594178aa9ed41b978ebb2698b803912a3c478443

  • https://build.antergos.com/package/antergos-deepin-meta
    New version is on the build queue and will be up soon!

  • Didn’t have the chance to test it but it appears like it’s solved! Thanks!

  • Hey @joekamprad I don’t know if this is related to the same problem but I’m having this error during the system update since a few days ago:

    :: Iniciando actualización completa del sistema...
    :: ¿Remplazar deepin-wm-switcher con community/startdde?  [S/n] s
    resolviendo dependencias...
    buscando conflictos entre paquetes...
    error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
    :: antergos-deepin-meta: quitando «deepin-wm-switcher» se rompe la dependencia con «deepin-wm-switcher»
    

    Every time I want to update the system I have to chose ‘No’ for that question about replacing deepin-wm-switcher with startdde and the dependency.

    The patch you mention is supposed to fix this too?

  • @nandox the reason is only that deepin-wm-switcher is removed and replaced by startdde, and Antergos meta installer package still have had the deepin-wm-switcher as dependency inside, so pacman ommit to uninstall it… and yes if the patch is included the problem will be solved.

    But it is still not reaches the repos…

error304 dependencies18 resolve4 metalink4 Posts 6Views 568
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.