• No shutdown in kernel 4.16.xx

    I installed debian testing with the same kernel, Fedora 28 and now I am with Antergos and I still have the same problem. I can not turn off the pc. It crashes with the message “failed to umount / oldroot …” and remains so until I power down the computer from the power button maintained for 6 sec.
    I have only managed to turn it off with kernel 4.14 (lts of Antergos).

    I have a card Nvidia G96 GT9500 old driver nouveau and motherboard has another graphic card integrated says 8500 but is disabled by bios.

  • @migueldemalaga
    I’m sorry for that, but if the problem is kernel related there is nothing Antergos developers can do to fix it. Kernel is not developed by Arch or Antergos. So you’ll need to downgrade it, use LTS kernel and wait that the next version will have this fixed.

  • Huh.
    What version of what Desktop are you using? Not saying it matters, but I run pure Arch right now (not Antergos) and Gnome 3.28. I get a list of errors (failed unmounts) at turn off but nothing that freezes the machine, it just shuts down anyway.
    As I said, I am running pure Arch, Gnome 3.28 on an old Asus gaming laptop. I only have the default 2D intel drivers installed though; I dual boot for the games in Windows so I haven’t bothered with nouveau nor nvidia.

  • @snailbeard said in No shutdown in kernel 4.16.xx:

    I get a list of errors (failed unmounts) at turn off but nothing that freezes the machine

    Hi! I also have this list of errors, they are related with systemd (this is reported already and will be fixed next systemd release), but i don’t have this problem to shutdown my machine, using antergos here up to date.

  • @fernandomaroto Sorry, I assumed that the list of errors of the type can not be removed / oldroot could be the problem of shutdown. I explain myself better:
    I have Gnome 3.28 with GDM as boot manager instead of lightdm.
    My computer CAN be restarted in all tested kernels, but it can only be turned off with kernel 4.14 LTS and kernel 4.15.3 (in Debian Testing). But in Fedora, Debian Sid and any kernel higher than these indicated (superiroes to 4.15 …) I can never turn off the pc.
    I have come to this conclusion that the three distributions have in common the current kernel, and all with GNOME as a desktop.

  • @migueldemalaga
    Ok, i understand.
    I still believe is kernel-hardware related since you have troubles with all those distros. So you’ll need to stick with LTS and hope that a new kernel release will fix it.
    I don’t know if there is another alternative… :(

  • i remember that some systems get problems to shutdown if you choose wrong settings about power state settings in Bios…
    I do n ot remember exactly but may take a look there…

  • I am already back after several tests in several distros and several teams.
    In all my tests I used an AMD PHENOM x4 9950 (it’s already years old) with 8 Gb of DDR2 667 Mhz RAM and two SSD hard drives (one of 120 Gb and another of 240 GB). In all the distros I use GNOME 3 with the NOVEAU driver that comes installed by default (without changes in the software on my part).
    The result is:
    In Debian, kernel 4.15.0 I can turn off and reset without problems.
    In Debian, Kernel 4.16.3 I can reset but not shut down.
    In Fedora 28 with the kernel 4.16.8 I can reset but not turn off.
    In Fedora 28 with the kernel 4.16.11 I can reset but not turn off.
    In Antergos with kernel 4.14.4x I can turn OFF and RESET.
    In Antergos with kernel 4.16.11 I can not turn off but reset.

    On another computer with the following features I can turn off and reset whatever the software version and the kernel, even with the list that appears before shutting down:
    MiniPC with Intel i5 4 Gb of ram (I suppose it is ddr3) and with bios UEFI I do not have those problems.
    I deduce therefore that for my team with problems, it may be that some instruction or command of the new kernel will not be compatible with my AWARD BIOS more than 10 years ago.
    I’m still looking to see if I see the difference between kernel 4.14.xx and 4.16.xx as soon as it refers to the ACPI system shutdown (or something like that).

  • Similar errors here.

    I see failed to unmount /oldroot during shutdown, but then computer turns off properly (in a second or two)

  • @migueldemalaga, you may want to update kernel to 4.17 to solve this issue. I updated to 4.17 today and it immediately removed this message + dozens of ACPI Error: AE_NOT_FOUND messages during boot. So boot/shutdown screens are error-free now.

  • Well i solved the problem temporally. Is than simpler, only i have to install NVIDIA 340 xx driver ( because my pc have an old graphic card) and the Xorg system ( in wayland doesnt works) and i can do everythings except suspend or sleep mode.

kernel151 shutdown31 4.16.xx1 Posts 11Views 939
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.