• X server throws Segmentation fault


    Hi there.

    Since yesterday, I cannot log in with my XFCE DE.
    I suspect it has to do with my packages update I did on Saturday night.

    The problem is that the login manager (lightdm) launches to the screen with my username to select, and when I select it and enter my password, it just loops back to the page with with my username.

    I can see from journalctl that the “X” process is failing with “dumped core”.
    ( output of journalctl -b -e : https://pastebin.com/PrNhGgZz )

    I tried to shut down the lightdm service, go to a tty and launch “startxfce4” manually.
    I get the same error ( I assume, it’s seg fault here but I think it’s the same )
    output here : https://pastebin.com/hM2dn2Nx

    I tried installing the nvidia drivers, but couldn’t start ( I think my GPU is too old for 340.xx or something. I have a GeForce 9600GT )
    I went back to nouveau and tried “Xorg -configure” to get a default xorg.conf.

    I don’t know if the GPU is the problem, or my xorg conf.
    Any ideas on how to debug this?

    Thank you.

  • I have the same graphics card and the driver still supports your card, just downgrade xorg-server. Read more in the thread below about the problem and the apps you have to downgrade.
    https://forum.antergos.com/topic/9919/xorg-server-update-causes-issues-with-nvidia-propritary-drivers?page=1

  • @bryanpwo Thank you for the reply.
    Do I have to install nvidia 340.xx first and then downgrade?
    And also, how do I downgrade? I mean what’s the command?

  • Install downgrade first (it’s an app) by typing

    sudo pacman -S downgrade
    

    Then downgrade the apps mentioned by piotr in the thread, by typing in the terminal downgrade, followed by the apps. Then you can install nvidia 340xx.

  • @antouank said in X server throws Segmentation fault:

    I went back to nouveau and tried “Xorg -configure” to get a default xorg.conf.

    per default there is no /etc/X11/xorg.conf
    and configs are placed under /etc/X11/xorg.conf.d/

    e.g. 00-keyboard.conf e.t.c

  • and xorg-server needs to be downgraded not the driver

  • So, I downgraded xorg-server, and installed nvidia.
    Now when I boot, lightdm service seems to be running fine, I see no errors in journalctl, but I see a black screen.
    I cannot understand it at all.

    I tried to remove the nvidia drivers, to see if that’s the problem, and now I cannot start X because it says some nvidia modules are missing.
    ( so in this case, lightdm service is also failing, because it tries to startx and it fails )

    :/

  • http://www.nvidia.com/download/driverResults.aspx/130042/en-us

    Your Card is supported only by the now legacy driver nvidia-340xx so as you are not specify what “nvidia” driver you are install i want to make this clear.

    As some other user also have problöems to get login to xfce session, i do some testing on it, and i can see that i can run with nvidia drivers (but latest with a GeForce GT 710B card) and with nouveau only if i uninstall xf86-video-nouveau and do not have any config for the driver under /etc/X11/xorg.conf.d/

    What your issue is may that you uninstall the nvidia driver and still have a conf under /etc/X11/xorg.conf.d/ ?

  • @joekamprad said in X server throws Segmentation fault:

    /etc/X11/xorg.conf.d/

    I used ‘nvidia-installer’ but I can see in it’s logs that it downloaded and installed 340xx.

    So what you are saying is that I have to uninstall xf86-video-nouveau and then delete every config inside /etc/X11/xorg.conf.d/?

  • @antouank only configs for the nvidia card… should be deleted… e.g. 20-nvidia.conf

    But if you where using nvidia-installer it will be removed already with sudo nvidia-installer -n

    So only uninstall

    xf86-video-nouveau
    
  • Seems like the opposite is working for me.
    With the nvidia drivers, even when removing the xf86 packages, I get a black screen.

    I did sudo nvidia-installer -n and it installed nouveau. Now it works fine.

    Still, should I worry that those downgraded packages might cause problems down the road?
    I guess if it happens again, I’ll just buy a cheap gpu and replace the old one…

  • No, it won’t be a problem for now, just wait for a new update for either nouveau or xorg-server. The nvidia 340xx fix can take some time, so it is a wise thing to stay on Nouveau or change DE, as this perticular problem is XFCE related. (Just wait, I’m also doing that 😉 )

  • I personally use i3 and a much newer card.
    That PC is used from my father, and it’s a bit tricky to remotely solve graphics problems :/

    But yeah, I’ll stay with nouveau for now.
    If you do see an update, post here if you can.
    Thanks for all the help.

  • Just look at the thread I refered you earlier on, that is the one that keeps updated with new info on the xorg-server and nvidia issue.

segmentation6 fault6 throws1 Posts 15Views 437
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.