• schon länger keine Updates und "pacman ist z.Z. in Verwendung"


    Hallo,

    irgendwann fiel mit auf das keine Updates mehr eingespielt werden.

    yaourt -Syua
    sagt mir es ist pacman zur Zeit in Verwendung

    pacman -Syu
    sagt mir, es können die Datenbank nicht sperren und kann deswegen core, extra, community usw. nicht aktualisieren

    Kann ich wirklich einfach die angegebene Datei
    /var/lib/pacman/db.lck
    löschen?

  • @archibald said in schon länger keine Updates und "pacman ist z.Z. in Verwendung":

    /var/lib/pacman/db.lck

    Ja sonst wird pacman oder pamac nicht funktionieren!
    sudo rm /var/lib/pacman/db.lck
    yaourt -Syyua

  • Hallo,

    ging ja fix, vielen Dank.
    Jetzt rasseln “Hunderte” Updates durch … ☺

  • Hallo,

    Gesamtgröße der installierten Pakete:  3450,97 MiB
    Größendifferenz der Aktualisierung:   114,76 MiB
    
    :: Installation fortsetzen? [J/n] J
    (286/286) Prüfe Schlüssel im Schlüsselring                                                [####################################################] 100%
    (286/286) Überprüfe Paket-Integrität                                                      [####################################################] 100%
    (286/286) Lade Paket-Dateien                                                              [####################################################] 100%
    (286/286) Prüfe auf Dateikonflikte                                                        [####################################################] 100%
    Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
    js52: /usr/lib/libmozjs-52.so.0 existiert im Dateisystem
    Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
    
    

    Eigentlich alles soweit durch. Gibt es zur letzten Fehlermeldung noch eine Lösung?

  • Hallo,

    leider nach Reboot immer noch der gleiche Fehler. So wie sich das sehe kann er wegen diesem nichts aktualisieren. Die lange Liste der zu aktualisierenden Pakete bleibt gleich.

  • Hallo,

    vielen Dank. Läuft, konnte jetzt erst weitermachen.
    Also in Zukunft alles löschen was Probleme macht … 😂

    Jetzt mal im ernst. Wodurch kommen diese Dateileichen zustande?
    Damit ich das wenigstens etwas verstehe.

  • /var/lib/pacman/db.lck ist eine Sperrdatei die pacman sperrt wenn etwas schief läuft.
    /usr/lib/libmozjs-52.so.0 war in fehlerhafter Symlink der einen Fehler verursachte, der nicht durch ein update der Bibliothek behoben werden konnte…

    Fehler passieren…

  • alles klar. Ich fühle mich hier sehr gut aufgehoben.

updates58 keine2 schon1 länger1 Posts 9Views 653
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.