• gnome-terminal does not run after upgrade


    Hello guys,
    A few days back I posted an issue about the same topic, but at that moment I did not have proper information. Now, I have complete log of the activity, and have run the same process from a restored system.
    I upgraded my system a few minutes back, and after the upgrade, when I try to run gnome-terminal, I get the following message:

    
    [crafter AT toolsbox IN ~]
      $   >_gnome-terminal
     Locale not supported by C library.
    	Using the fallback 'C' locale.
     Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached
    
    

    I used the following command to upgrade:

    sudo pacman -Syu
    

    And the following is the whole log of upgrade activity:

    :: Synchronizing package databases...
     antergos is up to date
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (134) accountsservice-0.6.49-1  alsa-plugins-1.1.6-2
                   antergos-desktop-settings-1.9-1  apm-1.19.0-6  atom-1.27.0-1
                   babl-0.1.46-2  bind-tools-9.12.1.P2-1  binutils-2.30-4
                   bluez-5.49-4  bluez-libs-5.49-4  brotli-1.0.4-1
                   ca-certificates-mozilla-3.37-1  chromaprint-1.4.3-2
                   chromium-66.0.3359.181-1  cmake-3.11.1-1  crda-4.14-1
                   cryptsetup-2.0.3-1  cups-filters-1.20.3-2  curl-7.60.0-1
                   dbus-1.12.8-1  dhcpcd-7.0.4-1  e2fsprogs-1.44.2-1  eog-3.28.2-1
                   evolution-3.28.2-1  evolution-data-server-3.28.2-1
                   ffmpegthumbnailer-2.2.0-2  file-5.33-1  firefox-60.0.1-1
                   freetype2-2.9.1-1  gcc-8.1.0-1  gcc-libs-8.1.0-1  gcr-3.28.0-3
                   gegl-0.4.0-2  gjs-1:1.52.3-1  glibc-2.27-3
                   gnome-calendar-3.28.2-1  gnome-contacts-3.28.2-1
                   gnome-desktop-1:3.28.2-1  gnome-disk-utility-3.28.2-1
                   gnome-keyring-1:3.28.2-1  gnome-logs-3.28.2-1
                   gnome-maps-3.28.2-1  gnome-music-1:3.28.2.1-1
                   gnome-online-accounts-3.28.0-1  gnome-photos-3.28.0-3
                   gnome-shell-3.28.2-1  gnome-system-monitor-3.28.2-1
                   gnupg-2.2.7-1  gst-libav-1.14.1-1  gst-plugins-bad-1.14.1-1
                   gst-plugins-base-1.14.1-1  gst-plugins-base-libs-1.14.1-1
                   gst-plugins-good-1.14.1-1  gst-plugins-ugly-1.14.1-1
                   gstreamer-1.14.1-1  gstreamer-vaapi-1.14.1-1  gvfs-1.36.2-1
                   gvfs-goa-1.36.2-1  gvfs-google-1.36.2-1  gvfs-mtp-1.36.2-1
                   gvfs-smb-1.36.2-1  hplip-3.18.4-2  hunspell-fr-6.2-1
                   imagemagick-7.0.7.33-1  intel-ucode-20180425-1  js52-52.7.3-2
                   krb5-1.16.1-1  libaio-0.3.111-1  libdmx-1.1.4-1  libdrm-2.4.92-1
                   libgpg-error-1.31-1  libidn-1.34-2  libinput-1.10.7-1
                   libmagick-7.0.7.33-1  libnm-1.10.8-1  libnm-glib-1.10.8-1
                   libphonenumber-8.9.4-1  libpsl-0.20.2-1  libraw-0.18.11-1
                   librsvg-2:2.42.4-1  libsoup-2.62.2-1  libsrtp-1:2.2.0-1
                   libtirpc-1.0.3-2  libtool-2.4.6+40+g6ca5e224-6  libuv-1.20.3-1
                   libwbclient-4.8.1-1  libwebp-1.0.0-1  libx264-2:152.20171224-2
                   libx264-all-2:152.20171224-2  linux-4.16.9-1
                   linux-firmware-20180507.8fc2d4e-1  linux-lts-4.14.41-1
                   linux-lts-headers-4.14.41-1  man-pages-4.16-1  mesa-18.0.3-4
                   mesa-vdpau-18.0.3-4  mutter-3.28.2-1  nano-2.9.7-1
                   networkmanager-1.10.8-1  nodejs-10.1.0-1  npm-6.0.1-1
                   nss-3.37-1  openal-1.18.2-2  pacman-5.0.2-3
                   pacman-mirrorlist-20180517-1  pamac-6.3.1-1
                   perl-io-socket-ssl-2.056-1  perl-net-http-6.18-1
                   pinentry-1.1.0-3  pipewire-0.1.9-3  poppler-0.64.0-1
                   poppler-glib-0.64.0-1  python-3.6.5-3  python-packaging-17.1-1
                   python-setuptools-1:39.1.0-1  python2-2.7.15-1
                   qt5-base-5.10.1-8  smbclient-4.8.1-1  sudo-1.8.23-2
                   transmission-gtk-2.94-1  tzdata-2018e-1  unrar-1:5.6.4-1
                   vulkan-icd-loader-1.1.73.0-1  wayland-1.15.0-1
                   wayland-protocols-1.14-1  webkit2gtk-2.20.2-1  wget-1.19.5-1
                   xdg-utils-1.1.3-1  xf86-video-fbdev-0.4.4+13+g9af7f81-1
                   xf86-video-vesa-2.4.0-2  xorg-server-1.20.0-2
                   xorg-server-common-1.20.0-2  xorg-server-xwayland-1.20.0-2
                   xz-5.2.4-1
    
    Total Installed Size:  2541.49 MiB
    Net Upgrade Size:        71.07 MiB
    
    :: Proceed with installation? [Y/n] y
    (134/134) checking keys in keyring                 [######################] 100%
    (134/134) checking package integrity               [######################] 100%
    (134/134) loading package files                    [######################] 100%
    (134/134) checking for file conflicts              [######################] 100%
    (134/134) checking available disk space            [######################] 100%
    :: Processing package changes...
    (  1/134) upgrading tzdata                         [######################] 100%
    (  2/134) upgrading glibc                          [######################] 100%
    Generating locales...
    Generation complete.
    (  3/134) upgrading gcc-libs                       [######################] 100%
    (  4/134) upgrading js52                           [######################] 100%
    (  5/134) upgrading xz                             [######################] 100%
    (  6/134) upgrading libgpg-error                   [######################] 100%
    (  7/134) upgrading dbus                           [######################] 100%
    (  8/134) upgrading cryptsetup                     [######################] 100%
    (  9/134) upgrading libidn                         [######################] 100%
    ( 10/134) upgrading e2fsprogs                      [######################] 100%
    ( 11/134) upgrading krb5                           [######################] 100%
    ( 12/134) upgrading libtirpc                       [######################] 100%
    ( 13/134) upgrading accountsservice                [######################] 100%
    ( 14/134) upgrading alsa-plugins                   [######################] 100%
    ( 15/134) upgrading antergos-desktop-settings      [######################] 100%
    ( 16/134) upgrading libuv                          [######################] 100%
    ( 17/134) upgrading nodejs                         [######################] 100%
    ( 18/134) upgrading npm                            [######################] 100%
    ( 19/134) upgrading python2                        [######################] 100%
    ( 20/134) upgrading apm                            [######################] 100%
    ( 21/134) upgrading nss                            [######################] 100%
    ( 22/134) upgrading freetype2                      [######################] 100%
    ( 23/134) upgrading libwebp                        [######################] 100%
    ( 24/134) upgrading libdrm                         [######################] 100%
    ( 25/134) upgrading libx264                        [######################] 100%
    ( 26/134) upgrading wayland                        [######################] 100%
    ( 27/134) upgrading mesa                           [######################] 100%
    ( 28/134) upgrading librsvg                        [######################] 100%
    ( 29/134) upgrading wayland-protocols              [######################] 100%
    ( 30/134) upgrading libtool                        [######################] 100%
    ( 31/134) upgrading ca-certificates-mozilla        [######################] 100%
    ( 32/134) upgrading libsoup                        [######################] 100%
    ( 33/134) upgrading atom                           [######################] 100%
    ( 34/134) upgrading babl                           [######################] 100%
    ( 35/134) upgrading bind-tools                     [######################] 100%
    ( 36/134) upgrading binutils                       [######################] 100%
    ( 37/134) upgrading bluez                          [######################] 100%
    ( 38/134) upgrading bluez-libs                     [######################] 100%
    ( 39/134) upgrading brotli                         [######################] 100%
    ( 40/134) upgrading chromaprint                    [######################] 100%
    ( 41/134) upgrading xdg-utils                      [######################] 100%
    ( 42/134) upgrading chromium                       [######################] 100%
    ( 43/134) upgrading libpsl                         [######################] 100%
    ( 44/134) upgrading curl                           [######################] 100%
    ( 45/134) upgrading cmake                          [######################] 100%
    ( 46/134) upgrading crda                           [######################] 100%
    ( 47/134) upgrading poppler                        [######################] 100%
    ( 48/134) upgrading libmagick                      [######################] 100%
    ( 49/134) upgrading imagemagick                    [######################] 100%
    ( 50/134) upgrading cups-filters                   [######################] 100%
    ( 51/134) upgrading dhcpcd                         [######################] 100%
    ( 52/134) upgrading gnome-desktop                  [######################] 100%
    ( 53/134) upgrading eog                            [######################] 100%
    ( 54/134) upgrading gstreamer                      [######################] 100%
    ( 55/134) upgrading gst-plugins-base-libs          [######################] 100%
    ( 56/134) upgrading webkit2gtk                     [######################] 100%
    ( 57/134) upgrading gcr                            [######################] 100%
    ( 58/134) upgrading gnome-online-accounts          [######################] 100%
    ( 59/134) upgrading libphonenumber                 [######################] 100%
    ( 60/134) upgrading evolution-data-server          [######################] 100%
    ( 61/134) upgrading pinentry                       [######################] 100%
    ( 62/134) upgrading gnupg                          [######################] 100%
    ( 63/134) upgrading evolution                      [######################] 100%
    ( 64/134) upgrading ffmpegthumbnailer              [######################] 100%
    ( 65/134) upgrading file                           [######################] 100%
    ( 66/134) upgrading firefox                        [######################] 100%
    ( 67/134) upgrading gcc                            [######################] 100%
    ( 68/134) upgrading gegl                           [######################] 100%
    ( 69/134) upgrading gjs                            [######################] 100%
    ( 70/134) upgrading libwbclient                    [######################] 100%
    ( 71/134) upgrading smbclient                      [######################] 100%
    ( 72/134) upgrading gst-plugins-base               [######################] 100%
    ( 73/134) upgrading libsrtp                        [######################] 100%
    ( 74/134) upgrading openal                         [######################] 100%
    ( 75/134) upgrading vulkan-icd-loader              [######################] 100%
    ( 76/134) upgrading gst-plugins-bad                [######################] 100%
    ( 77/134) upgrading gst-plugins-good               [######################] 100%
    ( 78/134) upgrading libinput                       [######################] 100%
    ( 79/134) upgrading libnm                          [######################] 100%
    ( 80/134) upgrading libnm-glib                     [######################] 100%
    ( 81/134) upgrading gnome-calendar                 [######################] 100%
    ( 82/134) upgrading gnome-contacts                 [######################] 100%
    ( 83/134) upgrading python                         [######################] 100%
    ( 84/134) upgrading libaio                         [######################] 100%
    ( 85/134) upgrading gnome-disk-utility             [######################] 100%
    ( 86/134) upgrading gnome-keyring                  [######################] 100%
    ( 87/134) upgrading gnome-logs                     [######################] 100%
    ( 88/134) upgrading gnome-maps                     [######################] 100%
    ( 89/134) upgrading gvfs                           [######################] 100%
    ( 90/134) upgrading python-packaging               [######################] 100%
    ( 91/134) upgrading python-setuptools              [######################] 100%
    ( 92/134) upgrading poppler-glib                   [######################] 100%
    ( 93/134) upgrading gnome-music                    [######################] 100%
    ( 94/134) upgrading libraw                         [######################] 100%
    ( 95/134) upgrading gnome-photos                   [######################] 100%
    ( 96/134) upgrading pipewire                       [######################] 100%
    ( 97/134) upgrading mutter                         [######################] 100%
    ( 98/134) upgrading gnome-shell                    [######################] 100%
    ( 99/134) upgrading gnome-system-monitor           [######################] 100%
    (100/134) upgrading gst-libav                      [######################] 100%
    (101/134) upgrading libx264-all                    [######################] 100%
    (102/134) upgrading gst-plugins-ugly               [######################] 100%
    (103/134) upgrading gstreamer-vaapi                [######################] 100%
    (104/134) upgrading gvfs-goa                       [######################] 100%
    (105/134) upgrading gvfs-google                    [######################] 100%
    (106/134) upgrading gvfs-mtp                       [######################] 100%
    (107/134) upgrading gvfs-smb                       [######################] 100%
    (108/134) upgrading hplip                          [######################] 100%
    (109/134) upgrading hunspell-fr                    [######################] 100%
    (110/134) upgrading intel-ucode                    [######################] 100%
    (111/134) upgrading libdmx                         [######################] 100%
    (112/134) upgrading linux-firmware                 [######################] 100%
    (113/134) upgrading linux                          [######################] 100%
    (114/134) upgrading linux-lts                      [######################] 100%
    (115/134) upgrading linux-lts-headers              [######################] 100%
    (116/134) upgrading man-pages                      [######################] 100%
    (117/134) upgrading mesa-vdpau                     [######################] 100%
    (118/134) upgrading nano                           [######################] 100%
    warning: /etc/nanorc installed as /etc/nanorc.pacnew
    (119/134) upgrading networkmanager                 [######################] 100%
    (120/134) upgrading pacman-mirrorlist              [######################] 100%
    warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
    (121/134) upgrading pacman                         [######################] 100%
    (122/134) upgrading pamac                          [######################] 100%
    (123/134) upgrading perl-io-socket-ssl             [######################] 100%
    (124/134) upgrading perl-net-http                  [######################] 100%
    (125/134) upgrading qt5-base                       [######################] 100%
    (126/134) upgrading sudo                           [######################] 100%
    (127/134) upgrading transmission-gtk               [######################] 100%
    (128/134) upgrading unrar                          [######################] 100%
    (129/134) upgrading wget                           [######################] 100%
    (130/134) upgrading xf86-video-fbdev               [######################] 100%
    (131/134) upgrading xf86-video-vesa                [######################] 100%
    (132/134) upgrading xorg-server-common             [######################] 100%
    (133/134) upgrading xorg-server                    [######################] 100%
    (134/134) upgrading xorg-server-xwayland           [######################] 100%
    :: Running post-transaction hooks...
    ( 1/20) Updating linux-lts module dependencies...
    ( 2/20) Updating linux module dependencies...
    ( 3/20) Updating linux-lts initcpios...
    ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
      -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
    ==> Starting build: 4.14.41-1-lts
      -> Running build hook: [base]
      -> Running build hook: [udev]
      -> Running build hook: [autodetect]
      -> Running build hook: [modconf]
      -> Running build hook: [block]
      -> Running build hook: [keyboard]
      -> Running build hook: [keymap]
    /etc/locale.conf: line 2: warning: setlocale: LC_COLLATE: cannot change locale (en_US.UTF-8)
      -> Running build hook: [resume]
      -> Running build hook: [filesystems]
      -> Running build hook: [fsck]
    ==> Generating module dependencies
    ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts.img
    bsdcpio: Failed to set default locale
    ==> Image generation successful
    ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
      -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
    ==> Starting build: 4.14.41-1-lts
      -> Running build hook: [base]
      -> Running build hook: [udev]
      -> Running build hook: [modconf]
      -> Running build hook: [block]
    ==> WARNING: Possibly missing firmware for module: aic94xx
    ==> WARNING: Possibly missing firmware for module: wd719x
      -> Running build hook: [keyboard]
      -> Running build hook: [keymap]
    /etc/locale.conf: line 2: warning: setlocale: LC_COLLATE: cannot change locale (en_US.UTF-8)
      -> Running build hook: [resume]
      -> Running build hook: [filesystems]
      -> Running build hook: [fsck]
    ==> Generating module dependencies
    ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
    bsdcpio: Failed to set default locale
    ==> Image generation successful
    ( 4/20) Updating linux initcpios...
    ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
      -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
    ==> Starting build: 4.16.9-1-ARCH
      -> Running build hook: [base]
      -> Running build hook: [udev]
      -> Running build hook: [autodetect]
      -> Running build hook: [modconf]
      -> Running build hook: [block]
      -> Running build hook: [keyboard]
      -> Running build hook: [keymap]
    /etc/locale.conf: line 2: warning: setlocale: LC_COLLATE: cannot change locale (en_US.UTF-8)
      -> Running build hook: [resume]
      -> Running build hook: [filesystems]
      -> Running build hook: [fsck]
    ==> Generating module dependencies
    ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
    bsdcpio: Failed to set default locale
    ==> Image generation successful
    ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
      -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
    ==> Starting build: 4.16.9-1-ARCH
      -> Running build hook: [base]
      -> Running build hook: [udev]
      -> Running build hook: [modconf]
      -> Running build hook: [block]
    ==> WARNING: Possibly missing firmware for module: aic94xx
    ==> WARNING: Possibly missing firmware for module: wd719x
      -> Running build hook: [keyboard]
      -> Running build hook: [keymap]
    /etc/locale.conf: line 2: warning: setlocale: LC_COLLATE: cannot change locale (en_US.UTF-8)
      -> Running build hook: [resume]
      -> Running build hook: [filesystems]
      -> Running build hook: [fsck]
    ==> Generating module dependencies
    ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
    bsdcpio: Failed to set default locale
    ==> Image generation successful
    ( 5/20) Warn about old perl modules
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    	LANGUAGE = (unset),
    	LC_ALL = (unset),
    	LC_COLLATE = "en_US.UTF-8",
    	LANG = "en_US.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    ( 6/20) Probing GDK-Pixbuf loader modules...
    ( 7/20) Updating GIO module cache...
    ( 8/20) Compiling GSettings XML schema files...
    ( 9/20) Updating icon theme caches...
    (10/20) Reloading GVFS config...
    (11/20) Reloading system manager configuration...
    (12/20) Updating udev hardware database...
    (13/20) Creating system user accounts...
    (14/20) Creating temporary files...
    (15/20) Reloading device manager configuration...
    (16/20) Arming ConditionNeedsUpdate...
    (17/20) Updating the info directory file...
    (18/20) Rebuilding certificate stores...
    (19/20) Updating the desktop file MIME type cache...
    (20/20) Updating the MIME type database...
    
    

    If there is anything to know, please ask.
    Thanks.

  • Please help.

  • @mahadihs said in gnome-terminal does not run after upgrade:

    Please help.

    Hi!
    By your own output from error

    Locale not supported by C library.
    

    Your upgrade error:

    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    	LANGUAGE = (unset),
    	LC_ALL = (unset),
    

    https://wiki.archlinux.org/index.php/Locale

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto
    Per your suggestion, I have read the post and have been able to solve the problem.
    Thank you very much. I really appreciate it.

upgrade67 gnome-terminal4 Posts 4Views 313
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.