• xorg-server update causes issues with nvidia propritary drivers

    After massive panic! and full format (yes it was planned already) and panic! again after installing drivers

    nvidia-installer -n

    worked for me with a GF 9600.
    Thou i had trouble getting to the TTY. Screen was blinking mad until all disk activity stopped.

  • Sounds like it will be safer to not update right now. Just wanted to do that, good I read this here before trying…

  • So is it advised not to take this update currently? My older desktop is on the nvidia 390xx drivers. I just updated my newer optimus laptop with no issues but don’t feel like breaking my desktop atm.

  • @delusional
    If you backup your system ,for example with Timeshift, then you can try the update. As you can read, the xorg- server update doesn’t behave the same with every system.
    If it breaks you can put your system back with timeshift, by downloading it in the live environment on the Antergos ISO.

  • @bryanpwo Thanks for the reply. I did just that, fortunately I had no issues with either of my systems, both using different Nvidia driver versions. Everything updated and working as intended.

    I tried to edit my original post but the forum wouldn’t let me. Apologies for cluttering up the thread.

  • As mostly every user with an issue is back on normal and fully updated?

    If someone still have issue please report here!!!

    • 390xx is fixed.
    • 340xx is fixed.
    • nvidia (latest) with 10xx graphics =?
    • nvidia-lts works also // but kernel is updated later than the driver.
  • My system still can’t run with the latest xorg-server version (nvidia 340xx)

  • Ups 😌


    340xx NOT FIXED JET!!!

  • 340xx is maintained by another person than 390xx 😉

  • yes mr. heftig and mr. haase

  • My wifes is on 340xx and is running fine with xfce…
    Thinkpad T410

  • I think it has to do with the specific card, the latest 340xx driver is from before the xorg-server update. So I’m quite certain that it is the xorg-server that causes the problem in my case. (The 340xx update was a day before the xorg-server update)

  • So that’s a hold on the 340xx as of yet?

  • @Firespray
    No, the latest version of 340xx works fine for some cards with xorg-server 1.19xx and not with 1.20-0.2. In that case the problem lies at Xorg-server.
    You can try, maybe in your case it works, just like the machine of @joekamprad 's wife.

  • Thanks @Bryanpwo
    I’ve got my 212 updates down to 5 lol
    Leaving yet to update

    I’m just not sure if I should wait as I don’t have much time during the week to fix stuff.
    Out of curiosity which video card you have?
    Mine is a GeForce GT730, and I ask because it may dare me to hit the apply button lol

  • Add another 340xx not working…

    …and after telling my son just how much better an experience I’d been having since, erm, defecting from the various Ubuntus.
    Oh well.

  • my wifes Card-1: NVIDIA GT218M [NVS 3100M] driver: nvidia v: 340.106
    Is also not working… there was no reboot after last updates… and after tonight poweroff, no X … downgrading xorg-server helps but causes a dependency problem with antergos-common-meta:

    sudo pacman -R antergos-common-meta
    cd /var/cache/pacman/pkg

    sudo pacman -U xorg-server-1.19.6+13+gd0d1a694f-2-x86_64.pkg.tar.xz xorg-server-common-1.19.6+13+gd0d1a694f-2-x86_64.pkg.tar.xz xorg-server-xwayland-1.19.6+13+gd0d1a694f-2-x86_64.pkg.tar.xz
  • @Firespray
    I have a Geforce 9600M GT

    The problem is, unfortunately linux-wide.

    How does the system behave, now you’ve downgraded those packages?

  • boots to X for sure yes… and is working as expected with XFCE…

  • Ah, okay well then we’re in the same boat☺

nvidia166 issues100 causes6 xorg-server3 Posts 177Views 10925
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.