• Can't change Keyboard Layout


    Hello,

    I am trying to switch my keyboard to Russian, but the layout doesn’t change at all. I created a new layout for Russian Phonetic in: System Settings -> (Hardware ->) Input Devices -> Keyboard -> Layout and switched with ctrl+alt+k the layout. But nothing happens. I still have my German (latin alphabet) layout. Flags are enabled, too, so I am sure that the right layout is choosen.

    If I change it with “setxkbmap ru phonetic”, it works perfectly, and I can write with cyrillic letters. I tried to install gxkb and put it in the autostart, but after every reboot I need to restart gxkb in order to have the cyrillic letters, again.

    Journalctl tells me:

    kdeinit5[683]: org.kde.kcm_keyboard: Current group number 2 is outside of current layout list ("de", "ru(phonetic)")

    I have no idea what’s wrong. On my laptop with kde5 and antergos it works perfectly. Other languages seem to work, too. Removing the German layout and using only the Russian layout didn’t work either.

  • Have you tried reinstalling Antergos?

  • Not yet. Still hoping that there’s another solution.

  • @ruper said in Can't change Keyboard Layout:

    Not yet. Still hoping that there’s another solution.

    I’ve never encountered such a strange keyboard problem earlier in Kde, and cannot reproduce it now. Switching between multiple keyboard layouts works without a problem here. Cannot suggest a solution.

    About a re-installation. Starting from 2017.12 all Antergos DEs are spoiled by meta packages. If you have installed after that date, you may avoid to re-install the whole DE from scratch, and install only missing packages:

    sudo pacman -Sy antergos-kde-meta --needed
    

    It will greatly reduce the download size.

  • @ruper

    …or even

    sudo pacman -Sy antergos-common-meta antergos-kde-meta --needed
    

    (Editing of old posts doesn;t work)

  • I installed Antergos before this date, unfortunately. What would be the simplest way to re-install KDE?

  • @ruper said in Can't change Keyboard Layout:

    I installed Antergos before this date, unfortunately.

    Unfortunately? I consider myself lucky, because my Antergoses were installed in 2016, i.e., without disliked meta packages.

    In any case, modern Antergos installations or re-installations are impossible without them. They may be added to older Antergos installations, prior to 2017.12. Or to any Arch system in general, which has added [antergos] repository.

    What would be the simplest way to re-install KDE?

    Chances are that the following command will fix the system, without re-installing it from scratch:

    sudo pacman -Sy antergos-common-meta antergos-kde-meta --needed
    

    Actually, the command won’t re-install the whole Antergos Kde. It will only add missing, accidentally or erroneously deleted packages. It won’t re-download and won’t re-install already installed packages. It will return Antergos Kde almost to the same state as it was right after a fresh installation.

    The price to pay for the convenience is too high, for my tastes. Adding meta packages will transform a modular, flexible, easily configurable system into a piece of monolithic basalt rock.

  • This post is deleted!
  • Editing doesn’t work: To be more specific, Yes, I used the command and packages were installed. But the problem still occurs, changing the layout is not working.

  • what is about locales?
    May it is not aviable because of lang is not generated?

    I do not use qt/kde/plasma and uinder gtk/gnome keyboard layout can be choosen also without having the correspondending lang generated…

    locale -a will list aviable langs

    to add one edit the /etc/locale.gen
    sudo nano /etc/locale.gen
    and uncomment the one you want to add:

    ...
    #en_SG ISO-8859-1
    en_US.UTF-8 UTF-8
    #en_US ISO-8859-1
    ...
    

    save ( Ctrl+X ) and generate:
    sudo locale-gen

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Actually, Kde doesn’t require a locale to read-write in a national languages.

    Here, Kde has only two additions to the default installation

    • national keyboard layouts (English US, Russian, Italian, Finnish)

    • various fonts with national alphabetic and special charactes

    On the screenshot below

    • top left - kate with /etc/locale.gen; ru-RU locales aren’t uncommented

    • bottom left - konsole lists enabled locales; there’s no Russian among them

    • top right - Writer with various languages mixed in a single document

    • bottom right - systemsettings5 shows ru among additional keyboard layouts

    • near the top of the panel on the right - keyboard layout indicator shows Russian as the current layout

    0_1526572594740_antergos-kde-doesnt-require-locale-2018.05.17.png

  • @joekamprad said in Can't change Keyboard Layout:

    what is about locales?
    May it is not aviable because of lang is not generated?

    I tried that already, but nothing did change so far.

    The only working possibility would be

    setxkbmap ru phonetic
    
  • @just said in Can't change Keyboard Layout:

    Actually, Kde doesn’t require a locale to read-write in a national languages.

    Does it uses xorg files like /etc/X11/xorg.conf.d/00-keyboard.conf?

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto said in Can't change Keyboard Layout:

    Does it uses xorg files like /etc/X11/xorg.conf.d/00-keyboard.conf?

    Yes, it does. There’s 00-keyboard.conf in /etc/X11/xorg.conf.d:

    ┌──[just]@[alexasp]:~$
    └─> ls -lha /etc/X11/xorg.conf.d
    total 20K
    drwxr-xr-x 2 root root 4.0K May 17 19:57 .
    drwxr-xr-x 4 root root 4.0K Jun  4  2017 ..
    -rw-r--r-- 1 root root  232 May 17 19:57 00-keyboard.conf
    -rw-r--r-- 1 root root 1.7K Jun  4  2017 50-synaptics.conf
    -rw-r--r-- 1 root root  216 Jun  4  2017 99-killX.conf
    ┌──[just]@[alexasp]:~$
    └─> 
    

    But I never touched or opened them. They are pretty much default ones. None of my 3 additional layouts is present in it:

    ┌──[just]@[alexasp]:~$
    └─> cat /etc/X11/xorg.conf.d/00-keyboard.conf
    # Read and parsed by systemd-localed. It's probably wise not to edit this file
    # manually too freely.
    Section "InputClass"
            Identifier "system-keyboard"
            MatchIsKeyboard "on"
            Option "XkbLayout" "us"
    EndSection
    ┌──[just]@[alexasp]:~$
    └─> 
    

    Kde was and remains so problemless with national languages, that I never asked myself where it keeps additional layouts and how it uses them.

  • @just said in Can't change Keyboard Layout:

    None of my 3 additional layouts is present in it:

    Kde was and remains so problemless with national languages, that I never asked myself where it keeps additional layouts and how it uses them.

    Just like gnome, i have no idea where their language files are located, since they don’t use the xorg file (wayland)…

    these are the places where laguage files would be configured but AFAIK the post’s creator already tried everything:

    /etc/locale.gen
    /etc/locale.conf
    /etc/vconsole.conf
    /etc/X11/xorg.conf.d/00-keyboard.conf
    

    but gnome and kde seems to have another way to configure language settings…

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto said in Can't change Keyboard Layout:

    these are the places where laguage files would be configured…

    Yes, but none of them has to do with additional keyboard layouts.

    > /etc/locale.gen
    

    It’s a simple list of all existing locales. Used only during installation and when sudo locale-gen is run. Doesn’t used in other moments.

    /etc/locale.conf
    

    If national date, time formats, paper sizes, sort order, collate rules etc. were customized and are different from those for the default locale, they are kept here. Otherwise, the file simple contains the default locale, the same as in /etc/locale.gen.

    > /etc/vconsole.conf
    

    This is the keyboard layout used in terminal emulators and in virtual consoles (VC, Ctrl+Alt+F1,2,3…7).

    > > /etc/X11/xorg.conf.d/00-keyboard.conf
    

    As already seen, there’re no national layouts here.

    A mystery.

  • I renamed the whole config folder, but still no changes. I am at a loss.

  • I have to correct myself: Other layouts don’t work either. I tested Hebrew and Turkish, but the characters are wrong.

    alt text looks like this

keyboard64 layout14 Posts 18Views 584
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.