• switch_root: failed to execute /sbin/init: Input/output error

    card is one of the now legacy cards for nvidia-390xx
    so will work with nvidia-390xx + bumblebee setup…

    nvidia-installer from Antgergos should do this job:

    nvidia-installer -b -t to test
    if it do not paste errors do the real install:

    sudo nvidia-installer -b

    and prior read the wiki to get knowledged about:

  • @manuel https://ptpb.pw/uAyS looks ok to me…
    I think if I could only use intel graphics that would be a good next step…

  • @joekamprad thx

    Just to check - my system will not boot at all at the moment (panic…)
    I am using the laptop with an antergos boot usb stick

    I think your two instructions both require the system to be booted normally, not with a usb boot.
    Do I somehow have to get the system to boot before I can do anything else or…

  • or chroot into it…

  • I run multiple linux distros and for reasons I do not remember now, my system was rendered unbootable for all distros - may be a corrupted MBR though nothing trivial should be touching that!

    I used the super grub2 disk to get myself out of that jam. https://www.supergrubdisk.org/super-grub2-disk/

    It booted successfully to Antergos (I used the boot manually option) and I then fixed with

    grub-mkconfig -o /boot/grub/grub.cfg
    grub-install /dev/sda

    change /dev/sda to match your setup.

    I do not use a separate boot partition so YMMV, but I would think it is worth a try.

  • @joekamprad hi just reminded myself that chroot fails as per previous message:

    Thought it would be worth trying out the first few commands:
    mount /dev/sda2 /mnt
    mount /dev/sda1 /mnt/boot

    these worked ok

    arch-chroot /mnt
    got the error message:
    failed to run command ’ /bin/bash’: Input/output error

  • @boogy make sure you are mounting the right partitions, check that with lsblk -fm

  • @joekamprad
    If the partitions have not changed, the mounts should be OK.
    So the problem seems something different. Maybe disks or partitions are corrupted?

execute3 inputoutput1 sbininit1 switchroot1 Posts 48Views 2262
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.