• Updated Friday and broke X/NVidia


    So on Friday I updated to the latest kernel, 4.16.8.1 and also the latest NVidia drivers from the Extra repository, 396.24.2. Upon restarting the LightDM service failed to start, so I installed SDDM thinking it was a LightDM problem. That was even worse as at least when it crashed with LightDM I could still use the tty sessions properly. Eventually removed SDDM and went back to LightDM.

    On investigating the logs, it X was throwing up a framebuffer error, and didn’t appear to be trying to start the NVidia drivers. I downgraded to 4.16.7.1 and 390.48 and my system booted correctly again allowing me to access the KDE desktop. It seems to me like the kernel modules for NVidia weren’t being built. Has anyone else come across this problem?

  • Nvidia 396.24 runs just fine here on kernel 4.16.8:

    $ date +"%Y-%m-%d %H:%M:%S" && pacman -Q linux nvidia && optirun inxi -Gxzc0
    2018-05-13 15:43:27
    linux 4.16.8-1
    nvidia 396.24-2
    Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel bus ID: 00:02.0 
               Card-2: NVIDIA GK107M [GeForce GT 750M] driver: nvidia v: 396.24 bus ID: 01:00.0 
               Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,intel,vesa 
               resolution: 1920x1080~60Hz 
               OpenGL: renderer: GeForce GT 750M/PCIe/SSE2 v: 4.6.0 NVIDIA 396.24 direct render: Yes 
    $ 
    
  • Odd, wonder if something else is happening as well though nothing else appears in the LightDM log or the Xorg log.

    My card is a Quadro 2000 so in the older range, but should still be supported by 396.24. I’ll try another update and see what happens.

  • @jonnie_rz Manjaro people have had much trouble with Nvidia 396.24, and many of them were forced to downgrade to 390.nn. But Manjaro treats Nvidia in its own, particular way, which doesn’t apply to Arch | Antergos.

  • @jonnie_rz
    Maybe you could try the dkms versions of nvidia and other related packages? That would guarantee a new compilation of the stuff. Needs also linux-headers package though.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • Seems to be the same problem like here:

    antergos forum : system-suddently-won’t-complete-boot

    @jonnie_rz what GPU do you have?

    I solved it with:

    sudo pacman -S nvidia-installer
    

    and then

    sudo nvidia-installer -n
    

    This disables the Nvidia driver and activates the opensource nouveau driver.

  • @dr-jep
    Nouveau is good for all basic things, but maybe not well suited for intensive playing.
    But that’s not a problem for you?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel
    Yes your right. For people that want to game thats not the perfect solution. But at least it can help to get a DM running.
    I’m quite sure it wont take much time till some smart arch guy makes a AUR package for the old nvidia driver.

    For me personally it was no problem because it was my work PC.

  • @dr-jep
    Out of curiosity, which graphics card do you have?
    You can find it with command lspci if not otherwise.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel It is a GTX 650 TI.

  • @dr-jep
    Just wondering, I couldn’t find your card on this list:
    http://www.nvidia.com/object/IO_32667.html

    It might be possible that you’d need an older driver, maybe nvidia-340 series, but this is just a guess since the card was not on the list above.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @just said in Updated Friday and broke X/NVidia:

    nvidia 396.24
    List of supported cards:

    http://www.nvidia.com/Download/driverResults.aspx/133859/en-us

    includes GTX 650 TI

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Sorry my bad. It is the 560 TI.
    Not at work today so i couldn’t “lspci”.

  • @dr-jep
    560 TI is using the 390xx series.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • This has gtx 560 ti:
    http://www.nvidia.com/download/driverResults.aspx/132845/en-us

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @jonnie_rz Yes, I came across a similar problem. After upgrading a few days ago the LightDM service failed to start; later I noticed that X was not able to start the Nvidia drivers. I have reported this in this discussion in this forum - I have tried many options but no solution (X fails to open).

    I tried to downgrade the kernel to 4.16.7.1 and to also downgrade Nvidia to 390.48 - but I keep receiving error messages.

    My conclusion by seeing your message is that also in my machine the kernel modules for Nvidia were not built.

    This has been the most frustrating upgrade in a long time for me in arch-based systems.

  • @manuel said in Updated Friday and broke X/NVidia:

    560 TI is using the 390xx series.

    you can try also nvidia-390xx-dkms that will buzild the modules for each kernel update with dkms!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @manuel I will have a look at that, though shouldn’t be necessary surely. My card is supported from what I can tell.

    @dr-jep I have a Quadro 2000 card(GF106L) which appears to be supported on the list.

    I haven’t tried reinstalling yet as I need to do work, and worst case I’ll just fit a newer GTX680 that my friend gave me, though I need to order a power lead splitter.

    I use my machine for 3D CAD so not sure how the nouveau driver would perform with that.

  • @jonnie_rz I had the same issue, after a normal update I rebooted to find the same issue with the black screen and no LightDM. Now I did one further than you, I booted with a livecd, thinking the update had gone bad, backed up all my data and did a reinstall only to find the same issue, Doh!!

    Anyway, manuel suggested using the dkms version of the driver and so I installed nvidia-390xx-dkms and linux-headers and that worked for me. Now, I have to reinstall all my apps 😞

  • @emyrbateman you can downgrade updates with the pacman -U command, saves a lot of hassle, and would have meant you didn’t need to reinstall.

    According to the nvidia page my card is supported under the latest version so I guess I’ll just have to install the dkms packages.

broke20 updated8 friday1 xnvidia1 Posts 26Views 639
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.