• Large number of orphaned packages


    Hello, I was trying to do a bit of cleanup earlier: When I run
    pacman -Rns $(pacman -Qtdq)

    Packages (108) accounts-qml-module-0.7-1  appstream-0.12.0-1  appstream-glib-0.7.7-1  appstream-qt-0.12.0-1  archlinux-appstream-data-20180424-1
                   cfitsio-3.440-1  crypto++-7.0.0-1  djvulibre-3.5.27-3  gcab-1.0+2+gc0947f6-1  gconf-3.2.6+11+g07808097-3  gcr-3.28.0-3  ghostscript-9.23-1
                   glew-2.1.0-1  ijs-0.35-1  jbig2dec-0.14-1  kaccounts-integration-18.04.1-1  kactivities-stats-5.45.0-1  kcontacts-18.04.1-1
                   kdebase-runtime-17.08.3-3  khotkeys-5.12.5-1  kidentitymanagement-18.04.1-1  kmenuedit-5.12.5-1  knetattach-5.12.5-1  kpeople-5.45.0-1
                   kpimtextedit-18.04.1-1  ksysguard-5.12.5-1  libaccounts-glib-1.23-2  libaccounts-qt-1.15-1  libappindicator-gtk3-12.10.0-12  libburn-1.4.8-1
                   libdbusmenu-glib-16.04.0-2  libdbusmenu-gtk3-16.04.0-2  libdvbpsi-1:1.3.2-1  libebml-1.3.5-1  libechonest-2.3.1-1  libgpod-0.8.3-5
                   libindicator-gtk3-12.10.1-7  libkate-0.4.1-5  libkcddb-18.04.1-1  libkleo-18.04.1-1  liblastfm-1.0.9-2  libmatroska-1.4.8-1
                   libmusicbrainz5-5.1.0-2  libotr-4.1.1-1  libpaper-1.1.24-10  libplacebo-0.4.0-1  libpwquality-1.4.0-1  libspectre-0.2.8-1  libstemmer-0+337-2
                   libtar-1.2.20-3  libtiger-0.3.4-4  libupnp-1.6.25-1  libyaml-0.1.7-1  lua-5.3.4-2  mutagen-1.40.0-1  numactl-2.0.11-2  oxygen-icons-1:5.45.0-1
                   pamac-6.3.1-1  polkit-kde-agent-5.12.5-1  protobuf-3.5.2-1  pulseaudio-gconf-11.1-1  purpose-5.45.0-1  qgpgme-1.11.1-1  qjson-0.9.0-1
                   qtcurve-utils-1.9.1.git20170710-2  run-parts-4.8.4-1  sg3_utils-1.42-1  signon-kwallet-extension-18.04.1-1  signon-plugin-oauth2-0.24-1
                   signon-ui-0.17+20150611-1  signond-8.59-1  socat-1.7.3.2-2  systemsettings-5.12.5-1  vte-common-0.52.1-1  vte3-0.52.1-1  ark-18.04.1-1
                   aspell-en-2017.08.24-1  clementine-1.3.1-17  gwenview-18.04.1-1  hwloc-1.11.10-1  k3b-1:18.04.1-1  kate-18.04.1-1  kcalc-18.04.1-1
                   kde-gtk-config-5.12.5-1  kdesudo-3.4.2.4-1  kfaenza-icon-theme-0.8.9-5  kfind-18.04.1-1  kinfocenter-5.12.5-1  kopete-18.04.1-1
                   kscreen-5.12.5-1  kwallet-pam-5.12.5-3  kwayland-integration-5.12.5-1  kwrited-5.12.5-1  nm-connection-editor-1.8.11dev+12+ga37483c1-1
                   okular-18.04.1-1  oxygen-5.12.5-1  pamac-tray-appindicator-6.3.1-1  plasma-desktop-5.12.5-1  plasma-pa-5.12.5-1
                   qtcurve-gtk2-1.9.1.git20170710-2  qtcurve-kde-1.9.1.git20170710-2  qtcurve-qt4-1.9.1.git20170710-2  spectacle-18.04.1-1  sweeper-18.04.1-1
                   transmission-qt-2.94-1  user-manager-5.12.5-1  vlc-3.0.1-2  xdg-user-dirs-0.17-1
    
    

    Surely these can’t all be safe to remove? Apologies if I didn’t format this post correctly. I wasn’t sure how to make the output a little easier to read.

  • Hi,

    You will remove plasma desktop if you remove those packages.

    I would guess that you removed antergos-kde-meta at some point, right? The installer uses that package to pull all Plasma desktop. If you remove that meta package, all depencencies will show up as orphaned packages.

    Either reinstall them, or just ignore their “orphan” state.

    Cheers!

  • @karasu said in Large number of orphaned packages:

    You will remove plasma desktop if you remove those packages.

    I would guess that you removed antergos-kde-meta at some point, right? The installer uses that package to pull all Plasma desktop. If you remove that meta package, all depencencies will show up as orphaned packages.

    Actually this is a fresh install from about two weeks ago. I haven’t un-installed anything from my system since then. There was a large kde update at end of April or first of May, could that have something to do with this?

    I really have no idea why it would be flagging all of these as orphans or how to correct it. I understand I can ignore it but over time it will become more difficult to recognize what is a valid orphan and what’s not.

    Thanks for the reply.

  • So, after going through my logs I noticed (and remembered) that I had removed dolphin and re-installed because of a problem I was having. For some reason antergos-kde-meta was also removed, most likely user error on my part. After re-installing the meta package I no longer have any orphans.

    Marking solved. Thank you!

orphaned3 number2 Posts 4Views 316
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.