• CUPS Error Trying To Add Printer


    I’ve been able to use this printer before, so I’m not sure why I can’t now. However, whenever I try to add my Canon ip6700D printer to CUPS, I get the following:

    Add Printer
    Add Printer Error

    Unable to add printer:

    Forbidden
    

    I’ve used my user name and password…what am I doing wrong?

  • root + password, printer administration is not allowed as normal user!

  • @adam-worth
    AFAIK you should use root and root’s password.
    But I’m not a printer specialist, @joekamprad is. :) Hopefully he has a better answer if root permissions don’t help.
    I just plug in my printer and use it. ;)

  • Here’s a nice dumb question: How do I get the root+password? ;-)

    Thanks, Joe

  • @manuel The system doesn’t even show the printer is there. LOL, so I was thinking about going the CUPS route.

  • the CUPS route…

    I’ve used my user name and password…what am I doing wrong?

    root = username (it is a username ;) )
    password = the same as your users password, if you do not change it after initial install.

  • @adam-worth

    sudo system-config-printer
    or
    sudo /usr/bin/xdg-open http://localhost:631/

  • @joekamprad This is frustrating. I’m using my sudo user name, and I’m putting in my password, but I’m still getting the “Forbidden” message. I wonder if I messed something up by accident?

  • @manuel said in CUPS Error Trying To Add Printer:

    sudo /usr/bin/xdg-open http://localhost:631/

    no this will not work, it will run default browser as root… open http://localhost:631/ inside browser and go to Admin tab, and press button “add printer” will ask for username and password, there you enter root + password:

    0_1525887829423_Bildschirmfoto vom 2018-05-09 19-43-12.png

  • @manuel I tried the first one, and it says: command not found

    I tried the second one, and it brings me to the CUPS page, but when I add my sudo user name and password, I get “Forbidden” again.

  • @joekamprad Hi Joe. Sorry for the dumb questions, but the user name is the user name I use when I’m in the terminal, correct? Like my login name? I use the same password, too. Just like the terminal.

  • @manuel said in CUPS Error Trying To Add Printer:

    system-config-printer

    system config printer has a unlock button top right, where you can give root+password

    But it is a GTK app and not needed for Plasma/KDE, there you have print-manager

  • @adam-worth said in CUPS Error Trying To Add Printer:

    @joekamprad Hi Joe. Sorry for the dumb questions, but the user name is the user name I use when I’m in the terminal, correct? Like my login name? I use the same password, too. Just like the terminal.

    Yes password is the same for “user” and root, and with “user” i mean your normal username same as you take to login…

  • @joekamprad
    Could this be a more general problem, since this is not the first report about printer issues today?

  • @joekamprad Bizarre. It won’t work at all.
    0_1525888339222_3766ca71-8a29-4a3e-b827-aaa14c2dcebc-image.png

  • @adam-worth said in CUPS Error Trying To Add Printer:

    sudo user name

    if you run command as sudo it will give you admin rights for your normal user, but for cups you do not get the rights so you need to take root as username and your password (same for user and root by Antergos default)

  • @joekamprad Got it! Hahaha! I feel sooooooo stoooopid!

    I kept putting my user name is for root. I should have simply typed “root” which is what I think you were trying to tell me in the last message.

    It works! Thank you guys! Hahaha! Learn something new every day. Love it!

  • @manuel said in CUPS Error Trying To Add Printer:

    @joekamprad
    Could this be a more general problem, since this is not the first report about printer issues today?

    i can see 2 posts, this can be coincidence ;)

  • @joekamprad
    So it seems. :)

  • i have no such problem here…

error307 printer46 cups19 Posts 23Views 880
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.