• System suddenly won't complete boot

    Firstly, thanks all for the advice I found here, for me a slight variation worked

    nvidia-installer -n
    pacman -R -u nvidia-utils 
    pacman -S nvidia-390xx

    Had to remove nvidia-utils otherwise installing nvidia-390xx failed to install, cause of existing files.
    Also just cause I’m suspicious, I subsequently uninstalled noveau.

    I’m a newbie to Antergos, so apologies if this is a naive question.
    Do I need to do anything to ensure that future upgrades do not install newer versions of the nvidia drivers?

  • pacman -S nvidia-390xx-utils
  • I guess a lot of older cards got dropped. This happened to me on my older desktop today. Using the 390xx drivers as stated fixed it here.

  • In the end, after many days, this worked for me. Not directly, though: perhaps trying so many “solutions” before created layers of files that prevented this from working. I ended reinstalling - and getting the same problem right after reinstall this time (but now knowing what to expect). Immediately after reinstall I downgraded nvidia to 390xx and after many days the X system started again.

    I got weary, however - I think this was a very troublesome update, and I am still scared of the system collapsing again.

  • the latest switch of nvidia seems to include some changes… and /or bugs also… we get many issues related to this update… but this is a main problem with proprietary drivers… they are closed and not open, so no one realy knows what will happen on all the different systems before it is installed…

  • new woes and solution:


    installs version 390.48 - this is incompatible with

    xorg-server 1.20.0-2

    from latest update

    this breaks the X system (again)

    after a lot of search I ended up installing directly nvidia-390.59 from the nvidia website (arch only has nvidia-390.48) - the driver 390.59 was made exactly to solve the incompatibility with xorg-server 1.20.0-2

    it works

    (I could also perhaps have downgraded xorg-server but since this was a fairly recent install I didn’t have local files of xorg-server 1.19 - I also read that downgrading xorg-server is potentially very troublesome with lots of remaining files …

    is there a neat way to downgrade packages which are not in the local system?

    how dangerous is it to downgrade xorg-server in antergos?)

  • @avillavecesn
    Download package downgrade. But be aware downgrading may cause serious compatibility problems, too. To fix those problems, you may need to chroot to your install.

  • @avillavecesn said in System suddenly won't complete boot:


    Flagged out-of-date on 2018-05-16


    So will be solved soon!

  • @avillavecesn Thanks for working out the the fix. I had moved to nvidia-390xx and when prompted blithely updated :-(
    Surprisingly doing

    nvidia-installer -n 

    did not work. I then uninstalled all nvidia-390xx related modules

    pacman -R u nvidia-390xx-dkms nvidia-390xx-utils opencl-nvidia-390xx nvidia-installer

    That brought up X again.
    Then installed the downloaded driver package you mentioned.

    systemctl isolate multi-user.target

    and followed the instructions. I’ve written out the commands cause changing the run-level using systemd is new to me, and it may help someone.

    All is working for now, hopefully future upgrades will not break things, I installed the dkms drivers, so should work for while, it may be time to buy a newer graphics card or move to nouveau.

  • @joekamprad thanks - looking forward to the update to 390.59 in the arch/antergos packages

    meanwhile, using the nvidia package…

boot320 system145 suddenly7 complete4 Posts 31Views 2067
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.