• System suddenly won't complete boot


    After my last update, I rebooted, but the system hangs at the display of a black background with the cursor. Same when I select the backup mode at the beginning. ??!?!?! I can reinstall, but will that fix it? Thanks in advance.

  • can you login to CLI by pressing [Ctrl+alt+F2} and give username password ?

    Then try to update again with sudo pacman -Syu

    and if you are willing give the logs autopastebin url:

    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    
  • I installed Antergos for the first time last night. After installation and the first reboot I had the same issue. Black screen with mouse cursor only.

    I reinstalled and found the “advanced” options on Cnchi where I could install graphics card drivers this time (which I did not do it the first time) and after that installation and reboot it worked.

    So from my limited experience and knowledge it sounds like it could be a graphics/driver issue?

  • @knpstrr
    Yes. And for the record, could you please show the output of command

    lspci
    

    and tell exactly what you had to do in cnchi to make it work.

    That may be very helpful information for people with the same or similar machine or graphics hardware you have.

  • @joekamprad said in System suddenly won't complete boot:

    joekamprad: thanks! I get https://ptpb.pw/ZAeM. Running the update as above did not fix the problem. I’m curious what went wrong with the previous update.

  • Very similar situation. Installed antergos two nights ago; it was working fine. I rebooted (after trying to install dropbox - the icon wasn’t showing and I read this is related to some problem with gnome that requires rebooting) and then the blank screen with cursor on the upper left corner happened.

    I pressed Ctrl-Alt-F2 to get to a tty and tried reinstalling nvidia - to no avail. When trying X I get the message “no screens found (EE)”. I believe the issue may be related to the most recent update of nvidia proprietary modules. So far no solution.

  • Had the same problem with my one year old installation after an nvidia driver update.
    Solved it with:

    nvidia-installer -n
    

    Not the perfect solution but works for now.

  • Thanks for the prompt reply, dr-jep. But using

    nvidia-installer -n
    

    just didn’t work here. There seems to be something seriously wrong with the latest nvidia updates on arch-based systems (had the same problem with manjaro).

    This is getting truly worrisome.

  • nvidia-installer -n
    

    Will revert to nouveau open source drivers and remove Nvidia drivers complete…

    But need for having the package nvidia-Installer installed

    sudo pacman -S nvidia-installer
    
  • @avillavecesn: with that cue, I also tried running

    nvidia-installer -n
    

    but got an error message that there was “no such command”.

    So I then ran

    pacman -S nvidia-installer
    

    and then

    nvidia-installer -n
    

    and rebooted, and now everything works again. I noted a text line during the nvidia-installer install that stated that Nouveau was being installed, and so I’m led to wonder if the last update killed all my display drivers and that that was the problem. Don’t know for sure, but thanks to all for your help.

  • @joekamprad

    right, of course, I installed the package nvidia-installer before running

    nvidia-installer -n
    

    .

    But the message is still the same:

    Fatal server error.
    (EE) No screens found. (EE)
    

    reverted to nvidia drivers (with nvidia-installer), same result.

    The card is a GTX 550 Ti. I don’t know what else to try at this point (following other posts I tried bumblebee - no luck there).

    Any help with this issue would be greatly appreciated!

  • Must be

    sudo nvidia-installer -n
    

    Also, and read the output to get errors.

  • sure, of course, I run it with sudo

    The output is very standard: all in green, no red characters, no error messages.

    Last two lines are

    Removing /etc/X11/xorg.conf.d/20-nvidia.conf file...
    Installation finished. You need to reboot now!
    

    But after rebooting… same problem.

  • I had further adventures also. After a second reboot, I was back to the same problem. I’m running a GeForce 8400 GS video card, which uses the nVidia 340 driver, so I ran:

    sudo pacman -S nvidia-340xx
    sudo nvidia-xconfig
    

    The system came back with:

    WARNING: unable to locate/open X configuration file.
    Package Xorg-server was not found in the package-config search path.
    Perhaps you should add the directory containing 'xorg-server.pc' to the PKG_CONFIG_PATH environment variable.
    No package 'xorg-server' found.
    New X11 configuration file written to '/etc/X11/xorg.conf'
    
    

    Figuring that if push came to shove, I could reinstall, I therefore ran:

    sudo pacman -S xorg-server
    

    And rebooted. This time, the desktop came back and stayed. However, the CPU Usage widget really, really fouled up the rendering of the top menu bar; other widgets were missing, the temperature from the weather widget duplicated itself three times, etc. So I removed the CPU Usage and Net Usage widgets, and selected the “Resources Monitor” widget that I had to download. That seems to be working now after logging out and back in, and the other widgets are back and working.
    I claim no great virtue in figuring out this fix. Why did Xorg-server go away? Or did the install simply fix the environment variable problem?
    Does the system want me to sacrifice a purebred red chicken at install?
    I have no clue.

  • I tried the sequence you mention

    (with

    sudo pacman -S nvidia-390xx
    sudo nvidia-xconfig
    

    since the card I have is apparently better supported by the 390 version of nvidia (I read) and then

    sudo pacman -S xorg-server
    

    The desktop did not come back. I never experienced this with arch-based distributions. I wonder what may have gone wrong with nvidia drivers.

  • @avillavecesn I had that problem with a 650 TI.
    While searching a solution I additionally reinstalled LightDM and the Greeter.
    Not sure if that will help.

  • It looks like Nvidia might be dropping support for some older cards. I had a problem this morning where LightDM would fail to start on my server. After fighting with it for a while I found the Nvidia Driver (396.24) wasn’t running. Checking Nvidia’s website the last driver for my card (Tesla C2075) is the 390.46. I have attempted to install the 390 drivers with pacman -S nvidia-390xx but I am getting a lot of “file exists in file system” errors.

  • @dr-jep thanks for the response, dr-jep. I will try that (I am away from the main computer, where I had the problem with nvidia and xorg - still unsolved).

  • @autonomousj I tried something along those lines. I believe the latest kernel update plus the nvidia upgrade is creating problems in some systems. I have tried many things - of course I may reinstall. But reinstalling doesn’t seem like a very good solution, especially if the same thing is going to happen again at some point.

  • @avillavecesn GTX 550 Ti needs 390 as it is not supported by latest nvidia drivers anymore:
    http://www.nvidia.de/download/driverResults.aspx/133318/de

    make sure linux-headers are installed also…
    nvidia-390xx

    Or dkms driver:

    nvidia-390xx-dkms

boot271 system126 suddenly5 complete3 Posts 31Views 1739
Locked
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.