• Recent problem with booting: mount dependencies failed


    For some reasons recently I have problems booting Antergos. I can’t exactly say when this started happening, but it happens frequently but not always. Rebooting (multiple times) makes it work again.

    alt text

    I wanted to add more useful information but I can’t seem to find the error records in the journal anymore :’(

  • @earthmind
    Hard to conclude much, but my first guesses are:

    • the hard disk is failing?
    • btrfs has corrupted something?

    In both cases up-to-date backups are very important to have.

    But it may me something else… Still backups are important. :)

  • Nope, the SSD drives are fine and the data is intact. It seems to be a pure boot issue, where maybe one thing is happening to fast over the other, which causes it to miss some require dependencies.

    I also have (Borg) backups and snapshots so I’m safe as far as that goes :-)

    Extra info I couldn’t add by editing my post:

    My OS is installed on a RAID1 BTRFS setup, and it seems like only the mounts (and subvolumes) where the OS is installed on seem to fail sometimes.

  • systemctl status "run-btrfs\\x2droot.mount"
    
  • That’s the problem, it doesn’t report anything useful now because I managed to boot Antergos. Here’s the proof:

    ● run-btrfs\x2droot.mount - /run/btrfs-root
       Loaded: loaded (/etc/fstab; generated)
       Active: active (mounted) since Tue 2018-05-08 20:25:24 CEST; 1 day 2h ago
        Where: /run/btrfs-root
         What: /dev/sdb2
         Docs: man:fstab(5)
               man:systemd-fstab-generator(8)
      Process: 600 ExecMount=/usr/bin/mount /dev/disk/by-uuid/e48f18a7-8525-4ef1-ac8f-9b127b123210 /run/btrfs-root -t btrfs -o defaults,noatime,compres>
        Tasks: 0 (limit: 4915)
       Memory: 64.0K
       CGroup: /system.slice/run-btrfs\x2droot.mount
    
    mei 08 20:25:24 Aardbol systemd[1]: Mounting /run/btrfs-root...
    mei 08 20:25:24 Aardbol systemd[1]: Mounted /run/btrfs-root.
    
  • I’ve taken a picture of the recent boot problem:

    alt text
    alt text

    I don’t know if that makes anything more clear

  • Got the same error message today on a VM (xenserver). It is a separate disk with ext4 mounted as /Downloads.
    Happens on every boot. And there is no problem accessing the dive as soon as the system is booted.
    Checked it on both xenserver and the partition on the VM itself, tried different options in fstab, no proper error messages anywhere I can find. I can even unmount/mount it manually…

    Don’t have time to troubleshoot it now but there’s definitively something fishy going on as there’s been a few of them on IRC too the last week or so too.

  • So, yeah, here’s the same thing:
    https://bugs.archlinux.org/task/59266

    It’s apparently that package. Not going to reboot my VM right now, but I guess the automount or downgrade is an option until the issue is fixed.

booting43 mount22 dependencies18 Posts 9Views 455
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.