• gnome-shell 3.28.2-1: keyboard and mouse don't work

    Had to switch back to version 3.28.1-1. Anybody else with this issue?

  • no problem here so far…

  • me too
    not work keyboard and mouse
    so downgrade to gnome-shell 3.28.1-1

  • please give me logs and specs:

    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2

    So we can take a look what is the cause.

  • I’m having the same issue. Gnome shell seems to load, but then the keyboard/mouse/touchscreen cannot interact with it. I know the mouse is working, because I can move it around the screen, I just can’t click anything. Same with the keyboard. I can use system shortcuts to get back to a tty, but I can’t use any of the gnome shortcuts. I installed cinnamon using tty and it is working fine. Gnome is still broken. I’m using GDM.

    @joekamprad Output from your script: https://gist.github.com/Mando75/1f1fe4c75a5daa2bc7df70941163307c

    I ran it inside of cinnamon. If you would like me to run it from tty, let me know. I won’t be able to run it from within gnome itself, because I can’t open a terminal haha.

  • @chrisflr I am also having this problem and have had to downgrade to 3.28.1

  • @horga83 I wonder if this is related to a bad extension.

    I have the following installed.
    Applications menu
    Arch linux updates
    Auto move windows
    Dash to Dock

  • @horga83

    I am using

    Block Caribou
    Dash to Dock
    Desk Changer
    Drop Down Terminal
    Dynamic Panel Transparency
    Media Player Indicator
    Native Window Placement
    No Title Bar
    No Topleft Hot Corner
    User Themes
    Workspace Indicator
    Workspace to Dock

    I never realized just how many extensions I had enabled until I had to type them all out… Dang.

  • What is the best way to debug gnome-shell?

  • i try something…
    and after all solved “gnome-shell 3.28.2-1 trouble”

    in my case…
    Workspaces to dock (gnome-extensions) is OFF
    and update to “gnome-shell 3.28.2-1”
    that’s all
    works fine

  • I’m using manjaro and I can confirm the issue.
    Disabling “workspaces to dock” extension like @opiumartdirectdesign said the issue resolved.
    It seems that “gnome-shell 3.28.2-1” and the “workspaces to dock” do not work together.

  • Gnome extension system seems to have a profound design problem. Don’t know if it is an API problem or extension implementation problem, probably both.
    The Gnome extension API should enforce checking that an extension truly supports the current Gnome version. Since gnome extensions have caused many problems also before, that kind of check clearly is not working.

    So, when installing any Gnome extension, be aware that it may not be compatible with the current Gnome version, and try to check the compatibility before installing.

  • Thank you @opiumartdirectdesigns. Don’t like that solution for workspaces to dock is my favorite Gnome extension, but I will give it a try.

  • I reported the issue and the solution is described here.
    Just follow the instructions. ☺

  • @kouros17 Thanks! Works like a charm!

keyboard75 mouse69 gnome-shell16 3.28.2-11 Posts 15Views 1654
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.