• Steam + Witcher 2 + 1920 x 1080 full screen -> delayed mouse response


    Guys, did anyone succeed in running The Witcher 2 (Steam) on an Optimus laptop fluently in 1920 x 1080 full screen resolution? On my machine everything works well up to “High” graphics quality, except for the mouse. The cursor movement is delayed, and the buttons must be held long for the presses to be detected. I use Bumblebee, and tried running the game with optirun and primusrun, and also disabling VSYNC with vblank_mode=0 primusrun steam-runtime. The latter helps a little bit, but it’s not enough to play comfortably. The only solution I’ve found so far is to decrease resolution: e.g. at 1280 x 960 the mouse responds well. I believe that my hardware, 4 years younger than the game itself, should be strong enough to run it in full HD. Details below.

    $ inxi -Fxzc0
    System:
      Host: asuspro Kernel: 4.16.6-1-ARCH x86_64 bits: 64 compiler: gcc v: 7.3.1 
      Desktop: Gnome 3.28.1 Distro: Arch Linux 
    Machine:
      Type: Laptop System: ASUSTeK product: P751JF v: 1.0 serial: N/A 
      Mobo: ASUSTeK model: P751JF v: 1.0 serial: N/A UEFI: American Megatrends 
      v: P751JF.210 date: 10/30/2015 
    Battery:
      ID-1: BAT0 charge: 12.0 Wh condition: 26.7/47.5 Wh (56%) 
      model: ASUSTeK K55--44 status: Discharging 
    CPU:
      Topology: Quad Core model: Intel Core i7-4712MQ bits: 64 type: MT MCP 
      arch: Haswell rev: 3 L2 cache: 6144 KiB 
      flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36733 
      Speed: 986 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 998 2: 997 
      3: 998 4: 998 5: 998 6: 998 7: 997 8: 998 
    Graphics:
      Card-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915 
      v: kernel bus ID: 00:02.0 
      Card-2: NVIDIA GM108M [GeForce 930M] driver: nvidia v: 390.48 
      bus ID: 01:00.0 
      Display: x11 server: X.Org 1.19.6 driver: nvidia tty: N/A 
      OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.0.2 
      direct render: Yes 
    Audio:
      Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
      driver: snd_hda_intel v: kernel bus ID: 00:03.0 
      Card-2: Intel 8 Series/C220 Series High Definition Audio 
      driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
      Sound Server: ALSA v: k4.16.6-1-ARCH 
    Network:
      Card-1: Intel Wireless 7260 driver: iwlwifi v: kernel bus ID: 04:00.0 
      IF: wlp4s0 state: down mac: <filter> 
      Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
      driver: r8169 v: 2.3LK-NAPI port: d000 bus ID: 05:00.0 
      IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
    Drives:
      HDD Total Size: 1.13 TiB used: 221.40 GiB (19.2%) 
      ID-1: /dev/sda model: KINGSTON_SV300S3 size: 223.57 GiB 
      ID-2: /dev/sdb type: USB model: External size: 931.51 GiB 
    Partition:
      ID-1: / size: 210.63 GiB used: 64.83 GiB (30.8%) fs: ext4 dev: /dev/sda3 
      ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
    Sensors:
      System Temperatures: cpu: 47.0 C mobo: N/A 
      Fan Speeds (RPM): cpu: 2500 
    Info:
      Processes: 291 Uptime: 22m Memory: 15.56 GiB used: 3.08 GiB (19.8%) 
      Init: systemd Compilers: gcc: 7.3.1 Shell: bash v: 4.4.19 inxi: 3.0.07
    
  • Damn, I’ve just discovered the fps overlay in Steam. In full HD it does not exceed 10. Any suggestions? Other DE? Proprietary drivers?

  • Alright, I got it. To use the game with primusrun %command% the lib32-primus library is necessary.

  • @joekamprad I read the whole Internet to find a solution. ;) If it comes to my hardware, there seems to be no other way than using primusrun. I installed optiprime, but missed the lib32 package mentioned above. Not that I’m a gamer, but I’ve always been curious if playing demanding games on Linux is possible at all.

  • H a Ha !

    I am less then anything you would call a gamer… and yes i do care about accelleration too!

  • @piotr One thing I am noticing is that you’re invoking the Steam runtime with primusrun instead of the game itself. Try moving the primus settings from your Steam launcher into the game launcher - right click on its entry in steam and you can edit the command/how it’s run.

    Other than that, are you sure it’s not actually a bug in Witcher? I’ve had cursor issues with some games that claim to have Linux-native versions as well.

  • Well, lately I start the game this way: optiprime %command%. I tested a number of solutions, and the best I can achieve is 18 fps at 1920 x 1080 full screen at medium details. Even starting X directly with nvidia-xrun brings no further improvement. However, it’s enough to play quite fluently.

steam65 10802 19201 witcher1 Posts 8Views 549
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.