• Tip KDE: Reducing Drastically the use of CPU and RAM


    Hello I found a way to reduce cpu usage and especially the memory RAM in KDE.

    Read more here : [https://userbase.kde.org/Akonadi#Disabling_the_Akonadi_subsystem][0]">[https://userbase.kde.org/Akonadi#Disabl][1] … _subsystem

    [b:2ue3ruw9]Akonadi.[/b:2ue3ruw9]

    Akonadi is a system meant to act as a local cache for PIM data, regardless of its origin, which can be then used by other applications. This includes the user’s emails, contacts, calendars, events, journals, alarms, notes, and so on. It interfaces with the Nepomuk libraries to provide searching capabilities.

    Akonadi does not store any data by itself: the storage format depends on the nature of the data (for example, contacts may be stored in vCard format).

    For more information on Akonadi and its relationship with Nepomuk.

    [b:2ue3ruw9]Controlling the Akonadi server[/b:2ue3ruw9]

    \# akonadictl start  
      
    \# akonadictl stop  
      
    \# akonadictl restart  
      
    \# akonadictl status
    

    [b:2ue3ruw9]
    Disabiling Akonadi[/b:2ue3ruw9]

    \# akonadictl stop
    

    [b:2ue3ruw9]Note: [/b:2ue3ruw9]

    Remember to check Plasma widgets as well — the Digital Clock widget in the default panel, for instance uses Akonadi to (optionally) display calendar events and this is enabled in its settings by default
    (see the “Display Events” option).In particular, open the Plasma clock applet preferences, go to Calendar and uncheck Show events to prevent Plasma from requesting information from Akonadi and thus allowing it to start.

    If you don’t want to have Akonadi’ running on your system at all, you can not use any of the Akonadi-enabled applications:

    [b:2ue3ruw9]KMail
    KAddressBook
    KOrganizer
    KJots
    KAlarm[/b:2ue3ruw9]

    [b:2ue3ruw9]Cheking everything is correct :[/b:2ue3ruw9]

    [[img:2ue3ruw9]http://i273.photobucket.com/albums/jj229/hectorsales/archkdebashndashKonsole_002_zps0ef01869.png[/img:2ue3ruw9][/url:2ue3ruw9]

    After reboot [b:2ue3ruw9]Memory RAM usage is 440 MB[/b:2ue3ruw9]. Before was about[b:2ue3ruw9] 580 MB[/b:2ue3ruw9]

    Best Regards,

    Héctor][2]

    [0]: <a href=
    [1]: https://userbase.kde.org/Akonadi#Disabl
    [2]: http://s273.photobucket.com/user/hectorsales/media/archkdebashndashKonsole_002_zps0ef01869.png.html:2ue3ruw9

  • Hello I found a way to reduce cpu usage and especially the memory RAM in KDE.

    Read more here : [https://userbase.kde.org/Akonadi#Disabling_the_Akonadi_subsystem][0]">[https://userbase.kde.org/Akonadi#Disabl][1] … _subsystem

    [b:2ue3ruw9]Akonadi.[/b:2ue3ruw9]

    Akonadi is a system meant to act as a local cache for PIM data, regardless of its origin, which can be then used by other applications. This includes the user’s emails, contacts, calendars, events, journals, alarms, notes, and so on. It interfaces with the Nepomuk libraries to provide searching capabilities.

    Akonadi does not store any data by itself: the storage format depends on the nature of the data (for example, contacts may be stored in vCard format).

    For more information on Akonadi and its relationship with Nepomuk.

    [b:2ue3ruw9]Controlling the Akonadi server[/b:2ue3ruw9]

    \# akonadictl start  
      
    \# akonadictl stop  
      
    \# akonadictl restart  
      
    \# akonadictl status
    

    [b:2ue3ruw9]
    Disabiling Akonadi[/b:2ue3ruw9]

    \# akonadictl stop
    

    [b:2ue3ruw9]Note: [/b:2ue3ruw9]

    Remember to check Plasma widgets as well — the Digital Clock widget in the default panel, for instance uses Akonadi to (optionally) display calendar events and this is enabled in its settings by default
    (see the “Display Events” option).In particular, open the Plasma clock applet preferences, go to Calendar and uncheck Show events to prevent Plasma from requesting information from Akonadi and thus allowing it to start.

    If you don’t want to have Akonadi’ running on your system at all, you can not use any of the Akonadi-enabled applications:

    [b:2ue3ruw9]KMail
    KAddressBook
    KOrganizer
    KJots
    KAlarm[/b:2ue3ruw9]

    [b:2ue3ruw9]Cheking everything is correct :[/b:2ue3ruw9]

    [[img:2ue3ruw9]http://i273.photobucket.com/albums/jj229/hectorsales/archkdebashndashKonsole_002_zps0ef01869.png[/img:2ue3ruw9][/url:2ue3ruw9]

    After reboot [b:2ue3ruw9]Memory RAM usage is 440 MB[/b:2ue3ruw9]. Before was about[b:2ue3ruw9] 580 MB[/b:2ue3ruw9]

    Best Regards,

    Héctor][2]

    [0]: <a href=
    [1]: https://userbase.kde.org/Akonadi#Disabl
    [2]: http://s273.photobucket.com/user/hectorsales/media/archkdebashndashKonsole_002_zps0ef01869.png.html:2ue3ruw9

  • Hello, Héctor

    I’ve tried this trick today on my KDE. Work’s like a charm.
    And instead of 5 PIM apps, I’ve switched to Thunderbird (with some extensions ofc).

    Anyway - thanks!

Posts 3Views 4191
Log in to reply