• Surface Pro 3 Goes Straight to Grub Rescue


    I follow the instruction on dual booting with Windows 10 with Antergos, and upon rebooting, the laptop will not do anything after the Surface splash screen but go straight to grub rescue. The commands I saw which are supposed to be available likie ‘exit’ and such do not work. I have not been able to get the laptop to boot from the same USB I installed Antergos with. No matter if I hold the volume key down or not it goes straight to grub rescue and I can do nothing but hold the power key down and shut it down. I can go the UEFI settings to do whatever but I already have it set to try the USB first at power on time.

    Sys01: Surface Pro 3; Antergos + Plasma; 4GB mem; linux-surfacepro3-git 4.18+ kernel, thanks to alyptik

  • @joekamprad Yes I’ve seen this before, but it will not even boot from the USB for me to do anything. It goes directly to grub rescue with nothing for me to do. No commands work.
    0_1525450332248_grub-rescue.jpg

    Sys01: Surface Pro 3; Antergos + Plasma; 4GB mem; linux-surfacepro3-git 4.18+ kernel, thanks to alyptik

  • @n_mag
    When you are in “grub rescue” prompt, what’s the output of command

    ls
    

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel 0_1525452478200_grub-rescue-commands.jpg

    Sys01: Surface Pro 3; Antergos + Plasma; 4GB mem; linux-surfacepro3-git 4.18+ kernel, thanks to alyptik

  • @n_mag
    The ‘ls’ command showed your machine’s partitions. Do you know the contents of the partitions, i.e. where is Windows, where is Antergos, etc.?
    And what would you like to do (instead of installing Antergos), does it boot to Windows anymore?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel I want to mention that the SET command works as well as LS

    I can boot into Windows if I turn Secure Boot back on that way it doesn’t even try grub or whatever it does, then it will in fact jump into Windows just fine.

    I do know which partitions are which yes sir. The second is the FAT32 UEFI partition I edit with CNCHI doing the work. The last two should be SWAP then the ROOT fs which is EXT4

    Sys01: Surface Pro 3; Antergos + Plasma; 4GB mem; linux-surfacepro3-git 4.18+ kernel, thanks to alyptik

  • @n_mag
    I looked at the link that Joe presented, and it seems to be quite hard to get Arch/Antergos work with Surface Pro 3. That Secure boot is really spoiling the party here, since Antergos (and Arch AFAIK) are not supporting it.

    But I’m not saying it is impossible. Maybe someone has already found a way, but I’m not aware of that. Seems like hard searching on the net I’m afraid. 😞

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel Ya I’m leaving secure boot off since I don’t really mind the red screen, so that shouldn’t be a problem I think

    Sys01: Surface Pro 3; Antergos + Plasma; 4GB mem; linux-surfacepro3-git 4.18+ kernel, thanks to alyptik

  • @n_mag
    You could try commands like

    cat (hd0,7)/boot/grub/grubenv
    

    to find out exactly which one is the Antergos root partition.

    Then try commands (X is a number for the Antergos root partition):

    set root=(hd0,X)
    configfile /boot/grub/grub.cfg
    

    Not sure if that really helps but shouldn’t hurt either.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

    • Boot into the USB/SD card

    • Power off the device

    • Press & hold Volume down

    • Press power button

    • Wait until the surface logo appears

    • Release Volume down

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad thanks but this method doesn’t work

    @manuel thanks I will try that

    Sys01: Surface Pro 3; Antergos + Plasma; 4GB mem; linux-surfacepro3-git 4.18+ kernel, thanks to alyptik

  • @manuel I set my root to (hd0,gpt7) however although there is a boot folder in it, there’s seems to be nothing else that I can point to since I can’t really see much doing the LS command it. I did ls (hd0,gpt7)/ and it showed boot, var, and etc. ls on the boot folder showed nothing else in it so I have no idea… I did a insmod normal and it just gave me the same error that I started with.

    I’m gonna turn secure boot back on since that’s the only way to boot anything and use Windows and try to just restore the UEFI drive and give up for a bit. I guess it was worth a shot.

    Sys01: Surface Pro 3; Antergos + Plasma; 4GB mem; linux-surfacepro3-git 4.18+ kernel, thanks to alyptik

  • @n_mag
    Do you have a separate boot partition for Antergos? That may explain why (x,y)/boot is empty.

    One thing still to try if you’re not bored yet. 😉
    Use bcdedit in Windows to make Antergos to boot via Windows boot loader. Not sure if it works in Surface, but worth a try. More info here: http://www.rodsbooks.com/linux-uefi/

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel I don’t have a seperate boot which is why it’s weird, I only have a swap and root, then just the UEFI partition.

    Using the bcdedit might be worth a shot, I’ve done that a long time ago from what I remember, thanks @manuel 🙂

    Sys01: Surface Pro 3; Antergos + Plasma; 4GB mem; linux-surfacepro3-git 4.18+ kernel, thanks to alyptik

grub225 dual boot23 pro13 surface5 Posts 15Views 186
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.