• Black screen with cursor after logging in [xfce and lightdm]


    I recently installed nvidia drivers (force install) to resolve screen tearing. At some point i just cloudn’t login to antergos. I tried installing gdm but it didn’t worked.

  • not enough informations to help you !

    may you do not have the right driver installed, or do it the wrong way…

    Antergos have a installer for nvidia-drivers:
    https://antergos.com/wiki/hardware/graphics/antergos-nvidia-installer-2/

  • @joekamprad I used exactly this installer (with -f as I said). My graphic card is 1050ti if this helps.

  • what are the logs from nvidia-installer gives out?

    cat /tmp/nvidia-installer.log
    

    how do you install and enable gdm?

    https://antergos.com/wiki/desktops/installing-display-managers/

  • @joekamprad I installed gdm in that way:

    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl stop lightdm
    sudo systemctl enable gdm
    sudo systemctl start gdm
    

    (I found this command in this forum btw in smiliar thread but it didn’t worked)
    Now im going to check logs

  • it is enough to run:

    sudo systemctl -f enable gdm

    and reboot is better as there may be some glitches if not…

    lspci -vnn | grep '\''[030[02]]'
    

    as i see this:

    https://forum.antergos.com/topic/9564/antergos-is-not-booting-after-instalation-alongside-windows-10/38

  • @joekamprad when i tried to find logs i saw something like: this file or folder doesn’t exist

  • @joekamprad Wait! Something weird happened. When i enabled gdm by your command i tried to log in, there was a black screen. But when i pressed ctrl alt and f2 it moved me to login screen and when i pressed it again it booted into system

  • if you get a optimus combi nvidia+intel graphics, itz is better to reset first to nouveau and go to install bumblebee.
    (after reboot) so you will have X running also…
    you can run this:

    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    and give the link/url it gives out at the end so i can read your yournal and system specs.

  • @joekamprad https://ptpb.pw/QGC2 (Ignore wierd name of my pc)

  • so a PC no notebook?

  • Setting mode "nvidia-auto-select+0+0{ForceCompositionPipeline=On,ForceFullCompositionPipeline=On}"
    

    may you try without this, you have this iside 20-nvidia.conf under /etc/X11/xorg.conf.d ??

  • @joekamprad Turned it off but now i have screen tearing

  • what exactly is running?

    Gnome or XFCE?

    is GDM logging you in to XFCE? or do you tried to install GNOME also? (i fails to start)

    maj 04 14:33:53 WUNGIEL systemd-coredump[546]: Process 507 (gnome-shell) of user 120 dumped core
    maj 04 14:33:53 WUNGIEL kernel: gnome-shell[570]: segfault at 20 ip 00007f5c2af49df5 sp 00007ffd532d1750 error 4 in libmutter-2.so.0.0.0[7f5c2ae45000+181000]
    maj 04 14:33:54 WUNGIEL gnome-session[563]: gnome-session-binary[563]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
    

    And screen-tearing all over the DE or on special apps?

  • @joekamprad Im running xfce but few days ago i tried to install gnome but i didn’t liked it and did fresh install of xfce. And in gdm i see options gnome an xfce. And screen tearing is everywhere.

  • so you can or can not login to xfce now?

    and do you have nvidia-settings installed?

    you can enable full compositing also inside running DE:

    nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

  • @joekamprad I have nvidia-settings installed. And i logged into xfce by weird accident as I said.

  • @joekamprad I still can’t login

  • may you have an option inside Bios to disable integrated GPU?
    And may try go back to lightdm…

    I do not get fully what you are doing all together…

black69 cursor20 logging5 [xfce1 Posts 20Views 1220
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.