• No more monospace font


    Hi,

    a few weeks ago I’ve noticed that all applications displaying text using monospace fonts are now diplaying an unreadable serif font. See pics for examples :

    Software Center

    Firefox

    I changed the font when I could find the option in different apps but it’s not very pratical. I wonder if there’s an option in Dconf Editor to change this.

    Thanks in advance for any tips 🙂

  • do you try Install gnome tweak tool?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in No more monospace font:

    do you try Install gnome tweak tool?

    Nope, should I ? I would have thought the built-in deconf editor will suffice. Unless it’s something in a .Desktop file.

  • sadly i can not try as i accidently erase my deepin VM… But before tweak tool was able to do so…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad Just tried : it doesn’t even start (loads of errors, wrong shell etc). Probably because Deepin is now massively using Qt.

    I checked my fontconfig file and it’s using Noto fonts as it should. I’ll keep digging.

  • Ah! Solved it. There were a few options in dconf still using ‘Monospace’ instead of ‘Noto Sans Mono’.

    Apparently, when the Noto fonts were installed automatically with a previous update, the old Monospace font was changed and a placeholder is loaded instead.

    I’m sorry I can’t be more precise about wich dfonf parameter did the trick, but it’s one of these :

    /com/deepin/dde/appearance/monospace-font
    /com/deepin/wrap/gnome/desktop/interface/monospace-font-name
    /org/gnome/desktop/interface/monospace-font-name

    Thanks for the help anyway 🙂

font27 monospace2 Posts 6Views 172
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.