• Cantata not opening


    Hello.
    After a system update I have cantata that doesn’t open, I can see the process live but not the app.
    I wonder if it depends from recent updates of qt5.
    I unistall/install again in vain.
    Anyone else with this problem?

    Antergos KDE + Kubuntu 18.04 + Windows 10
    Motherboard Asus P8H67-M LE - CPU: Intel Core™ i5-2400 CPU @ 3.10GHz - RAM 10 Gb
    Samsung EVO 250 Gb Ssd + WD HDD 2 Tb

  • cantata last update is 26.4 and qt5-base 27.4. so this looks like what you thinking

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hi!!

    I’m having this exact same problem…I tried uninstalling and reinstalling but it still doesn’t work…How do I fix this?

  • @joekamprad said in Cantata not opening:

    cantata last update is 26.4 and qt5-base 27.4. so this looks like what you thinking

    What exactly does this mean, and how does it affect Cantata?

  • @mattb66 cantata is a QT client so may Gui is broken caused by the QT update.
    May cantata needs rebuild against new qt version…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • What happen if you all open it from terminal?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Cantata not opening:

    What happen if you all open it from terminal?

    Same thing…Nothing.

  • This really sucks because I really like Cantata.
    So am I going to have to wait until the developer rebuilds Cantata with the new QT version?

  • @mattb66 in Terminal you get no error shown up?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Cantata not opening:

    @mattb66 in Terminal you get no error shown up?

    Nope. No error…Just nothing happens. I can open the process viewer and see that the Cantata process has started. But that’s it. It’s the same when opening it from the icon.

  • I opened an issue on Cantata github.
    I said that when I start the app, it doen’t open and that if I kill it and start from terminal, I receive the “Icon theme “cantata” not found” warning and cantata doesn’t open.

    The dev told me to ignore this warning message (…not sure why it happens, but the icons are still found and used).

    He added that this is not the reason cantata fails to start. He has no idea why it’s not starting and guessed must be an issue on my system.

    Anyway he changed cantata so it’s no longer using own icon theme - so this warning will now not happen.

    So far, the only way for me to start cantata is (a) kill the process and then (b) start the app by icon.

    I hope it’s the old problem with qt dependence, so that with a simple update of it, cantata will be back with us 😉

    Antergos KDE + Kubuntu 18.04 + Windows 10
    Motherboard Asus P8H67-M LE - CPU: Intel Core™ i5-2400 CPU @ 3.10GHz - RAM 10 Gb
    Samsung EVO 250 Gb Ssd + WD HDD 2 Tb

  • Last time I had a similar problem, the update of “qt5-styleplugins” package solved the problem.
    On the repo the version is 5.0.0.20170311-5.
    Should I try to install the git version from aur?
    I’m afraid to mess up my system.

    Antergos KDE + Kubuntu 18.04 + Windows 10
    Motherboard Asus P8H67-M LE - CPU: Intel Core™ i5-2400 CPU @ 3.10GHz - RAM 10 Gb
    Samsung EVO 250 Gb Ssd + WD HDD 2 Tb

  • @fabio said in Cantata not opening:

    qt5-styleplugins-git

    i would give it a try, you can revert this if it does not work… i can see qt5-styleplugins-git dio not depending other git builds, only on the default:
    Dependencies (4)
    gtk2
    libx11
    qt5-base
    git (make)

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • but why not first try cantata-git 😉 ?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad both suggestions tried, the issue is still there.
    Now to start cantata I start the app (it doesn’t open), kill the process, restart cantata, that this time is opened.
    I wonder if it’s really a problem of the system, it’d be interesting to know what happens to other user with cantata installed.

    Antergos KDE + Kubuntu 18.04 + Windows 10
    Motherboard Asus P8H67-M LE - CPU: Intel Core™ i5-2400 CPU @ 3.10GHz - RAM 10 Gb
    Samsung EVO 250 Gb Ssd + WD HDD 2 Tb

  • i can start up cantata issueless here… on your side main two issues (if not related to broken libs/deps)
    – theming or mpd config / configuration of the client settings…

    To me it looks like that per default setup question it only ask for Music directory and listen to any running mpd to connect… I can share my mpd.conf:

    # See: /usr/share/doc/mpd/mpdconf.example
    
    pid_file "~/.config/mpd/mpd.pid"
    db_file "~/.config/mpd/mpd.db"
    state_file "~/.config/mpd/mpdstate"
    playlist_directory "/where/are/your/playlists"
    music_directory ">/wher/is/music"
    
    #pulseaudio
    audio_output {
            type            "pulse"
            name            "pulse audio"
    }
    
    audio_output {
    	type		"httpd"
    	name		"Fancy Name - Musik Stream Server"
    	encoder		"lame"		# optional
    	port		"8000"
    #	quality		"5.0"			# do not define if bitrate is defined
    	bitrate		"128"			# do not define if quality is defined
    	format		"44100:16:1"
    	always_on       "yes"			# prevent MPD from disconnecting all listeners when playback is stopped.
    	tags            "yes"			# httpd supports sending tags to listening streams.
    }
    

    includes streaming with local ip to local network , running as user service …

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hey

    Cantata is still not working on my system…No error messages, nothing. If I click on the icon in the kde “start” menu, The icon will briefly flash on my toolbar and then disappear. Cantata loads into memory (I can see it in the process list), but that’s it.

    If I try to start it from the command line, I get no error messages. 😞

    Matt

  • Installing cantata-git worked for me…Thanks!

opening9 cantata2 Posts 19Views 754
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.