• Several apps very slow to load when connected to office network


    Hi guys,

    in the last few weeks, I’m facing up a very strange issue with my Antergos KDE OS.
    When at home, everything works fine with and without Internet connection.
    As soon as I connect the PC to my office network I get long delays (30s or more) in loading a few applications. I have this issue with LibreOffice, Thunderbird, VMWare Workstation Player, etc.
    When connected to office network, I’ve also noticed a long delay when I use Okular to print a file (Okular loads very fast but, as soon as I ask to “Print”, I have to wait 30s or more before to get the “Print — Okular” window).
    There other apps, e.g. GIMP, that work always fine. GIMP loads always very fast and no delay issue with printing.
    Before getting this issue, I worked a few months in the office without any issue when connected to the network. It’s about 2 months that I’ve this delay issue. I’m not aware of any change in the office network. I don’t know whether the issue started after installing new packages or after some package upgrade.
    In the last few days, supposing that it the delay was an issue with “QT printer discover”, I’ve played with avahi-daemon configuration (“use-ipv4=no”,
    “use-ipv6=no”) and tried to set “QT_DISABLE_PRINTER_DISCOVERY=1” but no results at all.

    I have no idea what I should look at to understand more and fix the issue.

    Thanks in advance for your support,
    Francesco

  • @francesco-ntrgs logs mr. ! where are the logs ?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Maybe samba or its configuration causes the issue?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @joekamprad

    Dear Joe,
    please, find the links below:

    Home Log Example: https://www.dropbox.com/s/az9zga6h7b74qf0/home.txt?dl=0
    Office Log Example: https://www.dropbox.com/s/eus2si2qrvhygv8/office.txt?dl=0

    Sorry for the links, but I don’t know how to attach a file here.

    Thanks,
    Francesco

  • @manuel

    Dear Manuel,

    thanks for your suggestion.
    Unfortunately, I don’t think this is the case.
    Looking at “pacman.log”, I’ve installed “samba” only 2 weeks ago ([2018-04-14 13:49] [ALPM] installed samba (4.7.6-1)), but the delay issue started a few weeks before.

    Francesco

  • HOME: (249 times “error” inside log)

    Apr 30 20:45:15 francescoLenovo dolphin[1366]: kf5.kio.core: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf\nError loading services.\n"
    Apr 30 20:45:15 francescoLenovo dolphin[1366]: kf5.kio.core: We got some errors while running 'net usershare info'
    Apr 30 20:45:15 francescoLenovo dolphin[1366]: kf5.kio.core: "Can't load /etc/samba/smb.conf - run testparm to debug it\n"
    Apr 30 20:45:15 francescoLenovo dolphin[1366]: inotify_add_watch("/home/francesco/.dropbox-dist") failed: "Permission denied"
    
    Apr 30 20:47:19 francescoLenovo gvfsd-network[1435]: Couldn't create directory monitor on dns-sd://local/. Error: Automount failed: No such interface 'org.gtk.vfs.Mountable' on object at path /org/gtk/vfs/mountable
    

    This looks like @manuel is right 😉 as this is where all is good, You may have this services created for use at work? And at home they can not connect… ?

    And there is also hundreds of:
    QXcbConnection: XCB error: 3 (BadWindow), sequence:

    May not harmfull at all but can link to something wrong related to graphicdriver

    WORK: 2712 times “error”

    plasmashell[1078]: Could not find service for job "Job 23" with app name "org.kde.kded5"
    

    this one spamms a lot…

    org.kde.kded5 --> https://packages.debian.org/en/sid/kded5

    Apr 27 17:20:28 francescoLenovo klauncher[1028]: kf5.kservice.sycoca: Service type not found: "application/wps-office.doc"
    Apr 27 17:20:28 francescoLenovo klauncher[1028]: kf5.kservice.sycoca: Service type not found: "application/wps-office.pptx"
    Apr 27 17:20:28 francescoLenovo klauncher[1028]: kf5.kservice.sycoca: Service type not found: "application/wps-office.ppt"
    Apr 27 17:20:28 francescoLenovo klauncher[1028]: kf5.kservice.sycoca: Service type not found: "application/wps-office.xls"
    
    kconf_update[16570]: "Missing \"Version=5\", file '/usr/share/kconf_update/okular.upd' will be skipped."
    
    • also samba error.

    and another graphics related:

    kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=1980182 end=1980183) time 118 us, min 1073, max 1079, scanline start 1072, end 1080
    

    BUT this is only data collection… first…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad

    I will remove “samba” package and try again tomorrow at office.
    Unfortunately, I don’t think this is the root-cause of the delay issue.
    I installed samba 2 weeks ago with the “wine” package, but the delay issue is much older than that.
    Anyway, it does make sense to have a try.

    Obviously, I don’t know how to fix the other errors…

    If there is anything more I can do to debug this issue, please, let me know.

    Thanks for your help,
    Francesco

  • @francesco-ntrgs
    There may be some change in the office that are causing delays, can you check that?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • And it could be something quite simple like

    • changed network paths
    • changed network file locations
    • changes in /etc/fstab

    etc.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel

    Dear Manuel,
    there are no network path or file location changes that I’m aware of.
    I use office network to connect to Internet and print files only.
    Internet with Chromium works well and no print delay in Chromium.
    As tried to explain before, there are apps that work well with no delay at all (Chromium, GIMP), a few apps with delay when loading (Libreoffice, Thunderbird, VMWare Player), other apps with delay only with “File -> Print” command (Okular).
    Printer paths have not been changed.

    Tomorrow I will record a short video to explain better what’s happening.

    My /etc/fstab is very simple with no access to network resources.
    It’s the same one from the first installation (Dec.3rd 2017).
    Please, find it here:
    "

    /etc/fstab: static file system information.

    Use ‘blkid’ to print the universally unique identifier for a

    device; this may be used with UUID= as a more robust way to name devices

    that works even if disks are added and removed. See fstab(5).

    <file system> <mount point> <type> <options> <dump> <pass>

    UUID=0300cef9-d548-4e13-ac5d-5d86bc41a9ff / ext4 defaults,relatime,data=ordered 0 1
    UUID=fefca66c-6e14-46a8-8032-885449338d3c /home/data ext4 defaults,relatime,data=ordered 0 1
    UUID=321ba0b2-a208-498d-830f-0d08498bda44 /home/workingOn ext4 defaults,relatime,data=ordered 0 1
    UUID=3c114ec5-267c-48fd-b8c1-73113b38f872 /home/vMachines ext4 defaults,relatime,data=ordered 0 1
    UUID=dfddfa30-484b-44af-aa67-2cd1746e4d8b none swap defaults 0 0
    "

    Thanks,
    Francesco

  • @manuel

    The /etc/fstab attached in my previous post is confusing.
    …so, here the link for my /etc/fstab: https://www.dropbox.com/s/hfxh9jwj505s5st/fstab.txt?dl=0

    Francesco

  • Quite strange problem. Most of those apps are on the heavy side, but in “normal” cases they shouldn’t have problems. The only additional potential reason might be a very limited RAM that causes swap usage on a slow HDD, but I guess your machine is not like that?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • So I’d guess it is a networking issue (maybe samba, a driver, etc.). Currently I cannot imagine any other reason based on this info. Hopefully someone can find the answer! 🙂

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel

    …8GB of RAM.
    And, when I get the delay issue, I cannot find any system overload.
    …let me put in this way, it looks like there is a timeout the system is waiting for.

    Francesco

  • @francesco-ntrgs
    Sounds like a network protocol issue, one end is waiting for an answer that never comes, and results in a timeout. That would still point to a samba issue, unless there are other network protocols involved.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • Hi,

    Can you post your /etc/hosts?

    Also, which DNS are you using? The same at home and in the office? Check your /etc/resolv.conf file and also (if exists) /etc/resolvconf.conf file.

    Cheers!

  • Hi Karasu,

    my /etc/hosts file does contain only 2 commented lines:
    "
    ’# Static table lookup for hostnames.
    ’# See hosts(5) for details.
    "
    I’ve noticed that this file has not been changed from Jan.05, so much before the issue came up.

    Here my “at home” /etc/resolv.conf file:
    "
    ’# Generated by NetworkManager
    search Home
    nameserver 192.168.1.1
    "
    Tomorrow I will post the “at office” /etc/resolv.conf file.

    Here my /etc/resolvconf.conf file:
    "
    ’# Configuration for resolvconf(8)
    ’# See resolvconf.conf(5) for details

    resolv_conf=/etc/resolv.conf
    ’# If you run a local name server, you should uncomment the below line and
    ’# configure your subscribers configuration files below.
    ’#name_servers=127.0.0.1
    "

    Obviously, I’ve replaced here “#” by " '#" but in the files the commented lines start with “#”.

    Thanks for your help,
    Francesco

  • @francesco-ntrgs
    A side note: you can use the “</>” button above the reply area to make scripts, config files etc. show as they originally are. 🙂

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • Hi,

    Maybe you’re having this problem?
    https://bugs.archlinux.org/task/56684

    Check that in your /etc/nsswitch.conf file, the hosts line looks like this one (the order is very important!):

    hosts: files mymachines myhostname resolve [!UNAVAIL=return]  dns
    

    ICheers!

  • Oh, I forgot, you can also try to restore your /etc/hosts file to the old way:

    127.0.0.1       localhost.localdomain localhost
    ::1     localhost6.localdomain6 localhost6
    

    Cheers!

slow27 apps17 connected9 several3 Posts 22Views 365
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.