• Cinnamon crashes at boot.


    Since the last update cinnamon crashes, 95% of the time, just as the desktop loads. The restart cinnamon window pops up for a second before my autostart applications load. This gives me less than one second to click yes before the window is covered and becomes inaccessible.

    What could be the cause and how do I rectify it? Not sure if I need to post any logs but will at your request. Thanks.

  • This also affects me after clean install two days ago. Click restart restores Cinnamon then works no problems until the next boot. Does this 100% of the time.

  • antergos-cinnamon-meta is installed?

    pacman -Qs antergos-cinnamon-meta
    

    to see if…

  • @joekamprad It wasn’t installed, I installed it, rebooted and it still crashed.

  • can you access TTY2? then try to move configs out of the way:

    mv ~/.config/cinnamon ~/.config/bak.cinnamon
    

    and restart lightdm:
    sudo systemctl restart lightdm

  • I don’t have a cinnamon config in the .config directory - only a cinnamon-session directory. But, that command works from TTY2. Cool work around for now, thanks.

    Anyway to tell what is causing the crash and fix it?

  • then it was some settings that whetre conflicting in a way… you can check journal if it paste something around:

    journalctl | grep cinnamon-session

    Or what the starter is called ;)

  • I had the same problem and Cinamon went into Safe Mode. However, I uninstalled a few apps and it seems to be running fine now.

  • cinnamon seems to be very sensual to some settings …

  • // gtk = GNOME //

  • So, I ran journalctl | grep cinnamon-session and this is this output from this morning:

    May 01 08:16:26 thebeginning dbus-daemon[552]: [session uid=1000 pid=552] Activating via systemd: service name='org.a11y.Bus' unit='at-spi-dbus-bus.service' requested by ':1.5' (uid=1000 pid=547 comm="cinnamon-session --session cinnamon ")
    May 01 08:16:27 thebeginning at-spi-bus-launcher[574]: dbus-daemon[579]: Activating service name='org.a11y.atspi.Registry' requested by ':1.0' (uid=1000 pid=547 comm="cinnamon-session --session cinnamon ")
    May 01 08:18:08 thebeginning at-spi-bus-launcher[574]: dbus-daemon[579]: Activating service name='org.a11y.atspi.Registry' requested by ':1.34' (uid=1000 pid=1934 comm="cinnamon-session --session cinnamon ")
    May 01 08:22:52 thebeginning dbus-daemon[529]: [session uid=1000 pid=529] Activating via systemd: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service' requested by ':1.2' (uid=1000 pid=524 comm="cinnamon-session --session cinnamon ")
    May 01 08:22:52 thebeginning dbus-daemon[529]: [session uid=1000 pid=529] Activating via systemd: service name='org.a11y.Bus' unit='at-spi-dbus-bus.service' requested by ':1.5' (uid=1000 pid=524 comm="cinnamon-session --session cinnamon ")
    May 01 08:22:52 thebeginning at-spi-bus-launcher[552]: dbus-daemon[557]: Activating service name='org.a11y.atspi.Registry' requested by ':1.0' (uid=1000 pid=524 comm="cinnamon-session --session cinnamon ")
    May 01 08:23:33 thebeginning at-spi-bus-launcher[552]: dbus-daemon[557]: Activating service name='org.a11y.atspi.Registry' requested by ':1.34' (uid=1000 pid=1880 comm="cinnamon-session --session cinnamon ")
    

    I don’t really get most of this but there doesn’t seem to be any warnings

  • Good news: few minutes ago cinnamon package was upgraded from 3.8.0 to 3.8.1:

    $  pacman -Q cinnamon
    cinnamon 3.8.1-1
    

    It has fixed the issue with Cinnamon DE starting up in Fallback Mode. Cinnamon starts up normally now.

boot271 cinnamon89 crashes30 Posts 12Views 661
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.