• Antergos does not boot anymore after random shut down


    Hello and thanx for your precious help, if possible. We had an electric shutdown and now antergos which worked to perfection until now does not boot correctly anymore. I have read several topics but have not enough knowledge to understand what I need to do. Attached is a screenshot of the present situation. Maybe some of you know how to solve the pb? Many thanks in advance.
    0_1525017456068_IMG_3186.JPG

  • I would first start up with live iso if you have Antergos still on a stick or CD.
    Then run fsck on the device…
    As it say you should
    I can go more into details but not today late here in Germany…

  • @joekamprad Thank you very much. Boot on the stick, correct ? Then C for command line? And then? I am not familiar with the procedure, sorry…

  • open terminal running:
    sudo fsck -p /dev/sda2

  • Thank you. Here is the outcome.

    [[email protected] ~]$ sudo fsck -p /dev/sda2
    fsck from util-linux 2.29.1
    /dev/sda2 contains a file system with errors, check forced.
    /dev/sda2: Inode 264886 extent tree (at level 1) could be shorter. IGNORED.
    /dev/sda2: Inodes that were part of a corrupted orphan linked list found.

    /dev/sda2: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
    (i.e., without -a or -p options)

  • @joe kamprad - with more recent version and without -p

    [[email protected] ~]$ sudo fsck /dev/sda2
    fsck from util-linux 2.32
    e2fsck 1.44.1 (24-Mar-2018)
    /dev/sda2 contains a file system with errors, check forced.
    Pass 1: Checking inodes, blocks, and sizes
    Inode 264886 extent tree (at level 1) could be shorter. Fix<y>?

  • @joekamprad - Thank you, after replying “yes” to all “Fix?” questions, the system boots normally, all fixed. Thank you very much once again!

  • then you are a lucky one!

  • @longliveantergos
    So anything can happen. This incident may serve as a reminder of keeping good backups all the time… :)

boot271 random15 anymore12 shut4 Posts 9Views 421
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.