• Pacmanxg failing to open


    Hello from a few weeks ago pacmanXg has a strange behavior :

    [http://forum.antergos.com/viewtopic.php?f=6&t=1939][0]">viewtopic.php?f=6&t=1939

    [http://forum.antergos.com/viewtopic.php?f=28&t=1904][0]">viewtopic.php?f=28&t=1904

    Today [b:3qdhq37y](Kde-Desktop[/b:3qdhq37y]), I went to open the application ([b:3qdhq37y]via the icon[/b:3qdhq37y]) and I will not open, only opens from the terminal … you do not really know what is happening with pacmankg …
    [b:3qdhq37y]
    UPDATE **: [/b:3qdhq37y] I think it’s an issue of user permissions. Let me explain:

    I’ve been trying different[b:3qdhq37y] kdm[/b:3qdhq37y] (display manager) if I disable [b:3qdhq37y]Lightdm[/b:3qdhq37y]:

    sudo systmctl disable lightdm.service
    

    …and I enable …

    sudo systemctl enable kdm.service
    

    …here is the error: [b:3qdhq37y][u:3qdhq37y]pacmanxg only open via terminal:[/u:3qdhq37y][/b:3qdhq37y]

     $ pacmanxg
    

    [b:3qdhq37y](current user)[/b:3qdhq37y]

     $ kdesu pacmanxg
    

    [b:3qdhq37y](root user) [/b:3qdhq37y]

    If I enable lightdm again. ¡¡¡ Everything works fine !!!.

    Well any idea to fix this issue.

    Best Regards,

    Héctor.

    [0]: <a href=

  • Hello from a few weeks ago pacmanXg has a strange behavior :

    [http://forum.antergos.com/viewtopic.php?f=6&t=1939][0]">viewtopic.php?f=6&t=1939

    [http://forum.antergos.com/viewtopic.php?f=28&t=1904][0]">viewtopic.php?f=28&t=1904

    Today [b:3qdhq37y](Kde-Desktop[/b:3qdhq37y]), I went to open the application ([b:3qdhq37y]via the icon[/b:3qdhq37y]) and I will not open, only opens from the terminal … you do not really know what is happening with pacmankg …
    [b:3qdhq37y]
    UPDATE **: [/b:3qdhq37y] I think it’s an issue of user permissions. Let me explain:

    I’ve been trying different[b:3qdhq37y] kdm[/b:3qdhq37y] (display manager) if I disable [b:3qdhq37y]Lightdm[/b:3qdhq37y]:

    sudo systmctl disable lightdm.service
    

    …and I enable …

    sudo systemctl enable kdm.service
    

    …here is the error: [b:3qdhq37y][u:3qdhq37y]pacmanxg only open via terminal:[/u:3qdhq37y][/b:3qdhq37y]

     $ pacmanxg
    

    [b:3qdhq37y](current user)[/b:3qdhq37y]

     $ kdesu pacmanxg
    

    [b:3qdhq37y](root user) [/b:3qdhq37y]

    If I enable lightdm again. ¡¡¡ Everything works fine !!!.

    Well any idea to fix this issue.

    Best Regards,

    Héctor.

    [0]: <a href=

  • Try editing /usr/share/applications/pacmanxg.desktop and change the exec command to this:

    kdesudo ssx pacmanxg
    

    If that doesnt help try this:

    kdesudo pacmanxg
    

    Cheers!

  • Thanks, Dustin, i have edited the file [b:3vov3fhc]pacmanxg.desktop[/b:3vov3fhc]

    [Desktop Entry]
    Version=1.0
    Name=PacmanXG
    Name[ru]=PacmanXG
    GenericName=GUI for pacman and yaourt
    GenericName[ru]=Графическая оболочка для Pacman и Yaourt
    [b:3vov3fhc]Exec=kdesu pacmanxg[/b:3vov3fhc]
    Icon=/usr/share/pixmaps/pacmanxg.png
    StartupNotify=false
    Terminal=false
    Type=Application
    Categories=Application;Utility;
    Name[ru_RU.UTF-8]=pacmanxg
    [[email protected] applications]$

    [b:3vov3fhc]Now… ¡¡¡work fine!!![/b:3vov3fhc]

    [b:3vov3fhc]Note:[/b:3vov3fhc] Three issues:

    a) I have deleted the package: [b:3vov3fhc](ssx)[/b:3vov3fhc], i think in my situation it was not useful this package

    sudo -Rdd ssx
    

    b) I open the terminal and type as normal user:

    $ pacmanxg

    …and the error that describe the user [b:3vov3fhc]“MichaelTiebesl”[/b:3vov3fhc] is gonne.

    When i open PacmanXG by icon and run as current user it display twice PacmanXG and i get an error with "Disk Full

    c) I have installed pacmanxg from aur… and open pacmanxg and this show the versión correctly:

    [[img:3vov3fhc]http://i273.photobucket.com/albums/jj229/hectorsales/Seleccioacuten_001_zpse1897e88.png[/img:3vov3fhc][/url:3vov3fhc]

    Best Regards,

    Héctor.]0

  • @“hector”:tiv4bfoh said:

    c) I have installed pacmanxg from aur… and open pacmanxg and this show the version correctly:
    [/quote:tiv4bfoh]We are working on fixing this. The problem is that the developer only released a 32-bit version of the last update. The 64-bit file on his server remains at the previous version. He told me that he will try and get it updated within the next week.

    Cheers!

  • ok, thanks for the explanation …

Posts 6Views 943
Log in to reply