• Updating doesn't work, available updates accumulating!


    Hi. The Updates window shows me there are 434 available updates but when I try to apply (by selecting, clicking on apply, entering my password and clicking on authenticate), a little round icon goes round and round and the updates are not applied. Can you please help? Thank you

  • @gamma
    Hi!
    Updating using the graphical interface (pamac) may not show you errors when they occur. Also not updating the system for a month or more may increase the chance of errors.

    So, i’d recommend you to update through terminal, opening one and typing sudo pacman -Syu
    In case of any errors they will be displayed in the terminal.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto hello! Thanks for replying, I don’t know much about computers so I’m quite lost with this.
    I have done sudo pacman -Syu a couple of times. It complains about being unable to retrieve lots of files (for example failed retrieving file ‘core.db’ from mirror.tyborek). All of them mention this ‘mirror’…

  • @gamma said in Updating doesn't work, available updates accumulating!:

    mirror.tyborek

    when was your last update?

    https://www.archlinux.org/mirrors/tyborek.pl/869/

    seems mirror do not exist anymore?

    you may need to remove this one from your mirrorlist…

    /etc/pacman.d/mirrorlist
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • wget http://antergos.kamprad.net/antergos-packages/fetchmirrors-0.5-3-any.pkg.tar
    sudo pacman -U  fetchmirrors-0.5-3-any.pkg.tar
    sudo fetchmirrors -q -s 16 -c PL
    

    will download and install fetchmirrorscript to get the best mirrors and write a new mirrorlist with them.
    Where PL stands for Poland, if you resident there 😉 If not choose the two letter short for your country…

    1)   AM  All-Mirrors     -  2)   AS  All-Https       -  3)   AT  Austria
    4)   AU  Australia       -  5)   BE  Belgium         -  6)   BG  Bulgaria
    7)   BR  Brazil          -  8)   BY  Belarus         -  9)   CA  Canada
    10)  CL  Chile           -  11)  CN  China           -  12)  CO  Columbia
    13)  CZ  Czech-Republic  -  14)  DE  Germany         -  15)  DK  Denmark
    16)  EE  Estonia         -  17)  ES  Spain           -  18)  FI  Finland
    19)  FR  France          -  20)  GB  United-Kingdom  -  21)  HU  Hungary
    22)  IE  Ireland         -  23)  IL  Isreal          -  24)  IN  India
    25)  IT  Italy           -  26)  JP  Japan           -  27)  KR  Korea
    28)  KZ  Kazakhstan      -  29)  LK  Sri-Lanka       -  30)  LU  Luxembourg
    31)  LV  Lativia         -  32)  MK  Macedonia       -  33)  NC  New-Caledonia
    34)  NL  Netherlands     -  35)  NO  Norway          -  36)  NZ  New-Zealand
    37)  PL  Poland          -  38)  PT  Portugal        -  39)  RO  Romania
    40)  RS  Serbia          -  41)  RU  Russia          -  42)  SE  Sweden
    43)  SG  Singapore       -  44)  SK  Slovakia        -  45)  TR  Turkey
    46)  TW  Taiwan          -  47)  UA  Ukraine         -  48)  US  United-States
    49)  UZ  Uzbekistan      -  50)  VN  Viet-Nam        -  51)  ZA  South-Africa
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    thanks for helping with this, you helped me a lot a while ago when my Linux stopped working, you got my laptop working again!
    Ok, I’ve followed your instructions. Shall I now shut down the laptop and start it again to see if the Updates window works?

  • should work right now by updating with:
    sudo pacman -Syyu

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • LVM recovery session … i remember now 🙂

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    ok, great. And what shall I reply to 'Replace compositeproto with extra/xorgproto? ’ and all these xorgproto questions?

  • yes is the best here…with some hope that the rest wents fine !

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    it complained about only one of those ‘replace’ questions, with error: failed to prepare transaction (could not satisfy dependencies)’
    :: libxfont: removing fontsproto breaks dependency 'fontsproto>=2.1.3’
    But it didn’t fail to retrieve the files it was failing to retrieve before! The Updates window still doesn’t let me apply the updates though. Shall I shut down laptop

  • @joekamprad
    decided not to shut down the computer, I’m trying the update but this time I answered No to the xrgproto questions. It seems to be installing lots of things, maybe it’s working now 🙂

  • there was a change to fontsproto and you will need to remove one package:

    Uninstall libxfont and ONLY this!

    pacman -Rdd libxfont
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @gamma
    Hi! I had to deal with that fonstproto error too if i’m not mistaken.

    I guess you can “safely” do sudo pacman -Rdd libxfont && sudo pacman -Syyu
    (this is going to uninstall the conflicting package.

    Later on you can reinstall with sudo pacman -S libxfont
    (I believe libxfont was replaced by libxfont2, so it’s ok if you can’t install it later)

    So sudo pacman -S libxfont2 to install/reinstall the new package

    maybe @joekamprad can confirm it, he is the master 🙂

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • libxfont2 must be installed to check:

    pacman -Qs libxfont2
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    it’s still happily installing stuff. Shall I do pacman -Rdd libxfont when it finishes installing?
    Maybe once I’ve uninstalled libxfront, I can do sudo pacman -Syyu again and this time answer Yes to the ‘proto’ questions?

  • sounds good! but check if libxfont2 is installed or not

    pacman -Qs libxfont2
    

    after it is finished…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • thank you @fernandomaroto
    @joekamprad is definitely THE MASTER, yes. Problem solved, managed to update everything! Do I still need to remove libxfont2 or shall I leave it like this? I replied ‘no’ to all the proto questions, didn’t replace anything. Maybe the system upgrades it automatically at some point later and installs libxfont2?
    @joekamprad you’re a star, this is the second time you prevent me from leaving Linux forever! Thank you 🙂

  • @gamma said in Updating doesn't work, available updates accumulating!:

    I replied ‘no’ to all the proto questions, didn’t replace anything

    You should replace them all, otherwise:

    • Graphical updater won’t work anymore
    • Everytime you update through terminal all those messages will popup again
    • Someday your system may stop working, this is a rolling release distro, and packages depend on another (specially the ones from xorg are vital)

    So try to update again and see if the error will popup (replace all packages), in case of that error you must remove libxfont update again and reinstall libxfont2 if needed.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @gamma
    Never get discouraged and feel you have to leave linux!

    I myself as I’m sure alot here took the big plunge and left microjunk permanently for one reason or another…some for the challenge, some because their fed up.

    There is a vast world of linux things out there but it all amounts to what you need at the time.
    My time started out with needing a media server and learned about NAS4Free which led me to Arch, then Antergos…now that I think about it…Antergos would make a friggin killer NAS OS…G*^%$# now I’m off thinking of a new pursuit, but that does spark a new install idea if someone made a NAS4Free Arch install? I know it’s BSD, but…an Arch version?

    Anyway, back to what I was saying. nice group here and don’t give up…if you need to run a “gulp” microsoft program, linux will do almost anything as well as OR better than microjunk, it’s just about finding your path and where it leads…crap, …just said some Jedi speech lol
    …but don’t give up and leave linux, no matter your flavor…however, imo Arch is best with all my searching…

    BUT I stand by what I said about NAS! Arch would be great to have a NAS media server/everything NAS4Free does, installer in the mix, just sayin’ as I’m pretty happy right now, everything is installing lol.

updates53 updating28 accumulating1 Posts 20Views 405
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.