• Antergos won't show up in BIOS after fresh install on HDD


    @karasu SDA is my internal HDD containing Windows 10 Pro education. I have another PC if this is the thing causing problem. Let me do those commands for ya =D

  • Hi,

    Sorry this should be /dev/sdc1 not /dev/sda1

    sudo mount /dev/sdc1 /mnt
    cd /mnt/loader/entries
    cat antergos.conf
    
  • So the mount went well. In /mtn I have EFI and “System Volume Information” and inside EFI I have Boot, HP, Insyde and Microsoft.
    Doing cat antergos.conf tells me no such file exist (Warning, I’m pretty new at linux.
    Sudo blkid gave me tons of info. What partion did you need? Efibootmgr gave me all my booting list. My live usb being first, followed by networkboot, then USB devices, DVD, network again, and it looped.

  • https://pastebin.com/dUADisju

    Doing mount /dev/sdc1 /mnt tells me the special device /dev/sdc1 doesn’t exist

  • I’m dumb, I figured out xD my HDD was not connected. So the thing is
    Title Antergos
    Linux /vmlinuz-linux
    invited /intel-ucode.img
    invited /initramfs-linux.img
    option root=UUID=8b311bae-0c5b-4e11-b04c-2a07ebbb7f84 rw quiet

  • @theatomickitty said in Antergos won't show up in BIOS after fresh install on HDD:

    I’m dumb, I figured out xD my HDD was not connected. So the thing is
    Title Antergos
    Linux /vmlinuz-linux
    invited /intel-ucode.img
    invited /initramfs-linux.img
    option root=UUID=8b311bae-0c5b-4e11-b04c-2a07ebbb7f84 rw quiet

    replace invited with initrd, can’t edit for some reasons

  • @karasu as I said earlier, it’s strange because it works perfectly on my 32Go USB Key

  • As I see it, you have two options:

    Option 1:

    When you install antergos, select advanced partitioning.
    Then, you should select your existing EFI partition /dev/sda1 as your efi partition in advanced
    DO NOT MARK IT TO FORMAT
    Delete your sdc external disk partitions.
    Create a new partition /dev/sdc1 and select it as root.

    Option 2:

    Add boot option in /dev/sda1 so it knows how to boot /dev/sdc2 (so no reinstall needed)

    This is how:

    • Boot with your Antergos ISO, open a terminal and:
      sudo su

    • Mount /dev/sda1 (yes, /dev/sda1):
      mount /dev/sda1 /mnt

    • Install systemd-boot:
      bootctl --path=/mnt install

    • Check that efibootmgr is working (-v shows boot options):
      efibootmgr -v

    • If there is no antergos option, add it:
      efibootmgr -c -d /dev/sda -p 1 -L "Antergos" -l "\efi\systemd\systemd-bootx64.efi"

    I still do not understand why you can’t instruct your BIOS to boot directly from /dev/sdc1

    Cheers!

  • @karasu I get Segmentation fault at the bootctl command. Is it installing on my Windows partition? Also efibootmgr -v is stuck too

  • @karasu, just rebooted but still nothing. I’m in live iso rn

  • Hi,

    I get Segmentation fault at the bootctl command. Is it installing on my Windows partition? Also efibootmgr -v is stuck too

    Strange… can you please post the exact output?

    Is it installing on my Windows partition?

    It should install in your EFI partition. Can you run fdisk -l /dev/sda so I can see your partition layout?

  • @karasu Will do asap, have to boot it up and stop rebooting. Just to make it clear, I don’t want to wipe windows, simply install antergos like I did on my USB on my 500Go external HDD

  • Hi,

    I think the easiest way will be to reinstall Antergos in your external disk. Just take this into account:

    • Boot in UEFI mode. You’ll know if you’re seeing this bootmenu:

    0_1525011399410_efi_menu.png

    • In the installer, use advanced partitioning
    • Choose /dev/sda1 as your efi partition. DO NOT MARK IT TO FORMAT!
    • Wipe your partition scheme in /dev/sdc, create a new partition and set it as your root / partition.
    • You can also add a swap partition if you desire so.

    That’s it.

  • @karasu but it means the HDD doesn’t have a bootloader and that the bootloader is on the PC? And that would mean I have only one PC where it works

  • Yep, you’re right.

    But I don’t know how to make your comp boot /dev/sdc if you say that it doesn’t show up in your bios boot menu…

    In my computer, when I press F8 while booting, a boot menu appears where I can select from where to boot.

  • Yea I know. That’s the problem I was hoping to fix. I don’t know why it works with my USB but not my HDD. Thanks for trying tho!

    https://pastebin.com/1n3B5J8j

  • Yes, it’s clear you’re booting in UEFI mode and that /dev/sda1 is your EFI partition.

    If you install Antergos onto the ext. harddisk but select /dev/sda1 as your EFI partition it will work. Then, you can do the same in the other computer.

    I know it is far from perfect but this way you will be able to use the same ext. disk in both computers.

  • I tried again a new install. It looks like the install doesn’t finish. Like the bar dissapeared and the message to reboot only a minute after

  • I’ll try one with my other PC, maybe it changes something

  • Okay so I figured it out !

    The problem was manual install kept making a weird partition.
    I used the auto installed and boom! I got everything!

boot bios2 Posts 40Views 1150
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.