• Antergos boot hanging at start up job for swap partition.


    Hello, my problem is that at boot I hang for a full 1min 30s when mounting my encrypted swap partition. After the minute 30 it seems to boot fine.
    When I run

    swapon --show
    #output is
    NAME      TYPE      SIZE USED PRIO
    /dev/dm-2 partition 4,1G   0B   -2
    

    which to me suggests it is actually being mounted properly after the minute 30 seconds

    When I run:

    lsblk -f
    #output is
    NAME              FSTYPE      LABEL      UUID                                 MOUNTPOINT
    sda                                                                           
    ├─sda1            ntfs                   B49CE2FA9CE2B650                     
    ├─sda2            vfat                   3CD7-4E41                            /boot/efi
    ├─sda3            ntfs                   581005C81005ADD6                     
    ├─sda4            crypto_LUKS            0d1d3bdc-1a8d-428c-8cdd-ef83f9c4085b 
    │ └─root          ext4        root       b1880162-0097-4905-9e89-09c05a76c2dd /
    ├─sda5            crypto_LUKS            fcac292a-0ce9-4be7-9c9d-377c30ea4a00 
    │ └─home          ext4        home       a6f07b96-34b9-4fd1-9463-0f14514f030e /home
    └─sda6            crypto_LUKS            8cbc504d-9141-4127-b7c6-cce91815871b 
      └─luks-8cbc504d-9141-4127-b7c6-cce91815871b
                      swap        swap       99625013-c89f-4e75-bdc1-fbb448673e31 [SWAP]
    sdb                                                                           
    └─sdb1            ntfs        Data Drive 38DAD478DAD433BA 
    

    The UUID that the start job is hanging on is the swap UUID not the crypto_LUKS UUID.
    Anyone have a fix for this Arch newb? :)
    I have not done any additional configuration beyond the cnchi installer.

  • couldn’t figure it out :/ ended up just commenting swap out of fstab for now

  • do you make some changes to partitions before this happen?

  • nope this was a default install I did have to reinstall grub because the installer did not work.

boot271 swap8 hanging6 job4 Posts 5Views 316
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.