• Dock not starting

    After a recent update, the dock wont start. i am new to this OS and the DE as well… Any help would be appreciated

  • @taskmaster07 said in Dock not starting:


    is what then? GNOME ? as Antergos offers 6 Desktops To Choose From

  • “hello everyone
    I was using openSuse but got bored and wanted to try arch but without going through the installation so i found antergos.
    Installed Antergos with deepin DE and no issues so far…”

    i just remember ;)

    system is up to date?

  • @joekamprad said in Dock not starting:

    system is up to date?

    Yes it is, Updated just now.

    @joekamprad said in Dock not starting:

    i just remember

    i posted it under deepin category so i thought i didnt need to specify 😅😅

  • oh yes i do not see that…may you can provide journal:

    journalctl -b -0  | curl -F [email protected] https://ptpb.pw/?u=1

    and give the link…

  • Apr 26 01:06:49 phoenix startdde[729]: session_procese.go:61: Start command /usr/bin/dde-dock [] failed: fork/exec /usr/bin/dde-dock: exec format error
    Apr 26 01:07:07 phoenix daemon/watchdog[729]: manager.go:89: Launch 'dde-dock' failed: org.freedesktop.DBus.Error.ServiceUnknown:The name com.deepin.dde.Dock was not provided by any .service files
    Apr 26 21:45:04 phoenix daemon/dock[780]: dock_manager_hide_state.go:77: getActiveWinGroup: not found active window in clientListStacking
    Apr 26 21:45:04 phoenix daemon/dock[780]: xutils.go:305: GetProperty: No such property '_NET_WM_DESKTOP' on window 5400010.
    Apr 26 22:35:54 phoenix daemon/dock[780]: process_info.go:132: lstat /home/taskmaster/.local/share/TelegramDesktop/Telegram: no such file or directory

    there is indeed something failing… what happens if you start it from terminal:


  • Nothing happens. No error is displayed but it does not start as well.

  • /home/taskmaster/.local/share/TelegramDesktop/Telegram: no such file or directory

    Is telegram installed or not anymore?

    May reset configuration for dock can help.
    I do not have any running deepin in stall at the moment… so i can not realy check here…

  • @joekamprad said in Dock not starting:

    Is telegram installed or not anymore?

    Yes, telegram is installed
    how to reset configuration for dock?

  • Hello

    I started to use Deepin as DE about 2 weeks ago.
    I have a similar issue after some updates or additional tweaks. I am not sure.
    My issue is it takes about 30 seconds to get the dock on screen. But this times varies.

    I ran the journalctl command provided earlier.
    Here is the link, in case it helps : https://ptpb.pw/l76p

    Thanks for your support and let me know whether you need more information.

  • @squid-f There’s an issue with start-dde 3.1.28-1 making the Dock start with a long delay and the process using over 25% CPU (a whole core actually). You can solve this by downgrading start-dde to the previous version :

    sudo pacman -U /var/cache/pacman/pkg/start-dde_3.1.37.1.pkg.tar.xz
  • Hi
    Thanks for support @SodaFormulas
    Just tried to downgrade using your command. But I get an

    error : '/var/cache/pacman/pkg/start-dde_3.1.37.1.pkg.tar.xz': impossible to find or to read package

    (translation from the message in french).

    Is there another way to downgrade ?

  • install downgrade and get it do the job ;)

    sudo pacman -S downgrade
    downgrade startdde

    but as you can see package is not called start-dde it is named startdde

  • Yep, sorry, my bad ^^’

    it’s startdde and I wrote the wrong version, it’s 27 not 37.

    You can either use downgrade as suggested by @joekamprad or try again the command I gave you with the right syntax (try to autocomplete using Tab)

    sudo pacman -U /var/cache/pacman/pkg/startdde_3.1.27.1.pkg.tar.xz
  • Thanks for your great support!

    I have not downgraded yet. Not knowing why exactly (new update meanwhile ?), the dock has been starting quickly the last 2 days !
    I’ll keep monitoring that and will downgrade if the lag time comes back.

  • Same guy, again and again ! :)

    In fact, I still do have a small lag time. I am wondering whether it is linked to program priority management.
    Let me explain.

    I have automatic launch of programs at startup (franz and nextcloud-client). I am wondering whether the dock waits for them before starting ?
    With Linux Mint for instance, there is a way in the parameters menu to delay the start of a program automatic launch at startup. Do you know whether it is possible with deepin DE ?

    Thanks !

  • @squid-f The latest version of startdde should have resolved this issue. Do you still have a lag?

  • –closing–

    problem solved by update of the package

starting25 dock19 Posts 19Views 1047
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.