• Cambiar Pamac por Octopi.


    Hola buenas, soy nuevo en el foro y usando Antergos.
    Utilizo deribadas de Ubuntu y quiero probar con Arch y he comenzado con Antergos que me parece bastante amigable. Voy al asunto:
    He intentado desinstalar Pamac (gtk3) para instalar Octopi, pero no me deja por ciertas dependencias:

    “[[email protected] ~]$ sudo pacman -R pamac
    [sudo] password for miguel:
    comprobando dependencias…
    error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
    :: pamac-tray-appindicator: quitando «pamac» se rompe la dependencia con «pamac»”

    He instentado instalar Octopi desde los repositorios de Antergos (no de AUR) :

    *"[[email protected] ~]$ sudo pacman -S octopi
    resolviendo dependencias…
    advertencia: no se pudo resolver «gksu», una dependencia de «octopi»
    :: El siguiente paquete no se puede actualizar debido a dependencias que no se pudieron resolver:
    octopi

    :: ¿Quiere omitir el siguiente paquete para esta actualización? [s/N] s
    buscando conflictos entre paquetes…
    …el sistema ya está actualizado.
    [[email protected] ~]$ sudo pacman -S octopi
    resolviendo dependencias…
    advertencia: no se pudo resolver «gksu», una dependencia de «octopi»
    :: El siguiente paquete no se puede actualizar debido a dependencias que no se pudieron resolver:
    octopi

    :: ¿Quiere omitir el siguiente paquete para esta actualización? [s/N] n
    error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
    :: octopi: necesita gksu
    [[email protected] ~]$"*

    Como puedo hacer esta operación, ya que Pamac se ve horrible en kde.

    Gracias.

  • @milabmor

    Hola,

    Hace justo un par de días gksu se ha quitado de los repositorios oficiales.

    De todas maneras está en el AUR.

    yaourt es para instalar paquetes del AUR, pero está un poco viejuno, te recomiendo pacaur or aurman

    Primero instala aurman:
    yaourt -S aurman

    Y luego ya utilízalo para instalar paquetes del AUR:

    aurman -S gksu
    aurman -S octopi
    

    Para desinstalar pamac (junto con dependencias y ficheros de configuración):

    sudo pacman -Rnsc pamac

    Saludos!

  • @karasu , gracias por responder.
    Si que es verdad que han quitado “gksu” y “kdesu” en los repositorios, también, de Ubuntu.

    No lo he comentado al inicio del post, uso Antergos con Kde 5, por eso el cambio de “pamac” por “octopi”.
    ¿La sintaxis de aurman y pacaur es la misma que en "yaourt? ¿Se tiene que desinstalar yaourt?

    Gracias.

  • Hola
    Yo he usado (y uso) pacaur y la sintaxis parece ser la misma (que alguien que sepa más me corrija); y lo uso para todo, para AUR y para los repos.

  • @karasu, Buenas otra vez, desinstalar “pamac” usando:

    $ sudo pacman -Rnsc pamac me sale lo siguiente:

    *"[email protected] ~]$ sudo pacman -Rnsc pamac
    comprobando dependencias…
    :: avahi requiere opcionalmente qt4: qt4 bindings
    :: chromium requiere opcionalmente kdialog: needed for file dialogs in KDE
    :: kio requiere opcionalmente kio-extras: extra protocols support (sftp, fish and more)
    :: kio requiere opcionalmente kdoctools: for the help kioslave
    :: kio requiere opcionalmente knetattach: to add new kio-remote entries
    :: kwallet requiere opcionalmente kwalletmanager: Configuration GUI
    :: libmagick requiere opcionalmente libraw: DNG support
    :: libreoffice-fresh requiere opcionalmente kdelibs: for KDE desktop integration
    :: openssh requiere opcionalmente x11-ssh-askpass: input passphrase in X
    :: pinentry requiere opcionalmente gcr: gnome3 backend
    :: python-pyqt5 requiere opcionalmente qt5-tools: QtHelp, QtDesigner
    :: python-pyqt5 requiere opcionalmente qt5-webkit: QtWebKit, QtWebKitWidgets
    :: vim requiere opcionalmente lua: Lua language support
    :: xdg-utils requiere opcionalmente kde-cli-tools: for KDE Plasma5 support in xdg-open
    advertencia: bucle de dependencias detectado:
    advertencia: phonon-qt4-gstreamer se quitará después de su dependencia phonon-qt4

    Paquetes (209) accounts-qml-module-0.7-1 antergos-kde-meta-1.0-2
    appstream-0.12.0-1 appstream-glib-0.7.7-1
    appstream-qt-0.12.0-1 archlinux-appstream-data-20180424-1
    ark-18.04.0-1 aspell-en-2017.08.24-1 attica-qt4-0.4.2-4
    baloo-5.45.0-1 baloo-widgets-18.04.0-1 breeze-5.12.4-1
    breeze-gtk-5.12.4-1 breeze-icons-5.45.0-1
    breeze-kde4-5.12.4-1 cdrdao-1.2.3-10 cfitsio-3.440-1
    clementine-1.3.1-16 convertlit-1.8-7 crypto+±7.0.0-1
    djvulibre-3.5.27-3 docbook-xml-4.5-6 docbook-xsl-1.79.2-4
    dolphin-18.04.0-2 dolphin-plugins-18.04.0-1
    dvd+rw-tools-7.1-7 ebook-tools-0.2.2-4
    editorconfig-core-c-0.12.2-1 exiv2-0.26-2
    ffmpegthumbs-18.04.0-1 frameworkintegration-5.45.0-1
    gamin-0.1.10-8 gcab-1.0+2+gc0947f6-1
    gconf-3.2.6+11+g07808097-3 gcr-3.28.0-2 grantlee-5.1.0-1
    gwenview-18.04.0-1 k3b-1:18.04.0-1
    kaccounts-integration-18.04.0-1 kactivities-stats-5.45.0-1
    kactivitymanagerd-5.12.4-1 kate-18.04.0-1 kcalc-18.04.0-1
    kcontacts-18.04.0-1 kde-cli-tools-5.12.4-1
    kde-gtk-config-5.12.4-1 kde-servicemenus-rootactions-2.9.1-1
    kdebase-runtime-17.08.3-3 kdeconnect-1.3.0-1
    kdecoration-5.12.4-1 kded-5.45.0-1
    kdegraphics-thumbnailers-18.04.0-1 kdelibs-4.14.38-4
    kdelibs4support-5.45.0-1 kdesu-5.45.0-1 kdesudo-3.4.2.4-1
    kdialog-18.04.0-1 kdnssd-5.45.0-1 kdoctools-5.45.0-1
    kemoticons-5.45.0-1 kfaenza-icon-theme-0.8.9-5
    kfilemetadata-5.45.0-1 kfind-18.04.0-1 khelpcenter-18.04.0-1
    kholidays-1:5.45.0-1 khotkeys-5.12.4-1 khtml-5.45.0-1
    kidentitymanagement-18.04.0-1 kidletime-5.45.0-1
    kinfocenter-5.12.4-2 kinit-5.45.0-1 kio-extras-18.04.0-1
    kipi-plugins-5.9.0-1 kitemmodels-5.45.0-1 kjs-5.45.0-1
    kjsembed-5.45.0-1 kmenuedit-5.12.4-1 knetattach-5.12.4-2
    knotifyconfig-5.45.0-1 konsole-18.04.0-1 kopete-18.04.0-1
    kparts-5.45.0-1 kpeople-5.45.0-1 kpimtextedit-18.04.0-1
    kpty-5.45.0-1 krunner-5.45.0-1 kscreen-5.12.4-1
    kscreenlocker-5.12.4-1 ksshaskpass-5.12.4-1
    ksysguard-5.12.4-1 ktexteditor-5.45.0-1 kuiserver-5.12.4-3
    kunitconversion-5.45.0-1 kwallet-pam-5.12.4-1
    kwalletmanager-18.04.0-1 kwayland-integration-5.12.4-1
    kwin-5.12.4-2 kwrited-5.12.4-1 ldb-1.3.2-1
    libaccounts-glib-1.23-2 libaccounts-qt-1.15-1
    libappindicator-gtk3-12.10.0-12 libburn-1.4.8-1
    libdbusmenu-glib-16.04.0-2 libdbusmenu-gtk3-16.04.0-2
    libdbusmenu-qt4-0.9.3+16.04.20160218-1 libdmtx-0.7.4-6
    libdvbpsi-1:1.3.2-1 libebml-1.3.5-1 libechonest-2.3.1-1
    libfakekey-0.1-7 libgit2-1:0.27.0-1 libgpod-0.8.3-5
    libindicator-gtk3-12.10.1-7 libkate-0.4.1-5
    libkcddb-18.04.0-1 libkdcraw-18.04.0-1 libkexiv2-18.04.0-1
    libkipi-18.04.0-1 libkleo-18.04.0-1 libkscreen-5.12.4-1
    libksysguard-5.12.4-1 liblastfm-1.0.9-2 libmad-0.15.1b-7
    libmatroska-1.4.8-1 libmng-2.0.3-1 libmtp-1.1.15-1
    libmusicbrainz5-5.1.0-2 libotr-4.1.1-1 libplacebo-0.4.0-1
    libpwquality-1.4.0-1 libqalculate-2.4.0-1 libraw-0.18.9-1
    libspectre-0.2.8-1 libstemmer-0+337-2 libtar-1.2.20-3
    libtiger-0.3.4-4 libupnp-1.6.25-1 libutempter-1.1.6-2
    libxres-1.2.0-1 libyaml-0.1.7-1 libzip-1.5.0-1 lmdb-0.9.22-1
    lua-5.3.4-2 milou-5.12.4-1
    mobile-broadband-provider-info-20170310-1
    modemmanager-qt-5.45.0-1 mutagen-1.40.0-1
    networkmanager-qt-5.45.0-1
    nm-connection-editor-1.8.11dev+12+ga37483c1-1 okular-18.04.0-2
    oxygen-5.12.4-1 oxygen-icons-1:5.45.0-1
    pamac-tray-appindicator-6.2.7-1 phonon-qt4-4.10.1-1
    phonon-qt4-gstreamer-4.9.0-4 plasma-desktop-5.12.4-2
    plasma-integration-5.12.4-1 plasma-nm-5.12.4-1
    plasma-pa-5.12.4-1 plasma-workspace-5.12.4-3
    plasma-workspace-wallpapers-5.12.4-1 polkit-kde-agent-5.12.4-1
    polkit-qt4-0.112.0+git20180107-1 poppler-qt5-0.64.0-1
    powerdevil-5.12.4-2 prison-5.45.0-1 protobuf-3.5.2-1
    pulseaudio-gconf-11.1-1 purpose-5.45.0-1 qca-qt5-2.1.3-10
    qgpgme-1.11.1-1 qjson-0.9.0-1 qqc2-desktop-style-5.45.0-1
    qrencode-4.0.0-1 qt4-4.8.7-24 qt5-location-5.10.1-2
    qt5-sensors-5.10.1-1 qt5-tools-5.10.1-1
    qt5-webchannel-5.10.1-1 qt5-webkit-5.212.0alpha2-14
    qtcurve-gtk2-1.9.1.git20170710-2
    qtcurve-kde-1.9.1.git20170710-2
    qtcurve-qt4-1.9.1.git20170710-2
    qtcurve-utils-1.9.1.git20170710-2 sg3_utils-1.42-1
    signon-kwallet-extension-18.04.0-1 signon-plugin-oauth2-0.24-1
    signon-ui-0.17+20150611-1 signond-8.59-1 smbclient-4.8.0-2
    socat-1.7.3.2-2 spectacle-18.04.0-1 sweeper-18.04.0-1
    syntax-highlighting-5.45.0-1 systemsettings-5.12.4-1
    tevent-1:0.9.36-1 threadweaver-5.45.0-1
    transmission-qt-2.93-1 ttf-hack-3.003-1 user-manager-5.12.4-1
    vlc-3.0.1-2 vte-common-0.52.1-1 vte3-0.52.1-1
    xapian-core-1:1.4.5-1 xcb-util-cursor-0.1.3-1
    xdg-user-dirs-0.17-1 xorg-xmessage-1.0.5-1 pamac-6.2.7-1

    Tamaño total quitado: 1150,06 MiB"

    :: ¿Desea quitar estos paquetes? [S/n]*

    Evidentemente, me elimina todo el metapaquete de kde, claro y esa no es mi intención.

    Saludos.

  • Hola,

    De momento, hemos añadido gksu al repo de antergos, mientras que no eliminamos las dependencias de otros paquetes (principalmente algunos del escritorio Mate).

    Vaya, que un simple sudo pacman -S gksu debería funcionar.

    Ahora ya puedes instalar octopi tranquilamente.

    Si lo que quieres es también borrar pamac, tienes que eliminarlo sin eliminar el metapaquete de antergos-kde (ya que depende de él)… tal que así:

    sudo pacman -Sdd pamac

    Si no es estrictamente necesario, yo no lo borraría.

    Saludos!

  • @karasu said in Cambiar Pamac por Octopi.:

    sudo pacman -Sdd pamac

    Para evitar problemas @karasu y disculpa, el comando sería:

    sudo pacman -Rdd pamac
    ☺

  • @judd

    Se me fué la olla…

    gracias!

pamac65 octopi11 por4 cambiar4 Posts 8Views 962
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.