• XPS 13 on Gnome DE - Slow and Laggy


    Hello Everyone,

    I have a Dell XPS 13 with the following specs:

    Specs:
    Intel Core i5-6200U (Skylake)
    8GB Memory
    256GB SSD

    Behavior:
    I am running Antergos with the Gnome DE. For some reason, after I’m booted into my system and have my usual apps open (Chromium, Spotify, Terminal, etc.) it seems like my system gets really laggy after 10-20 mins. I know there is a memory leak on Gnome 3.28.x version currently, but not sure if this is connected to that or not.

    Is there any way I can do some profiling or see what is actually going on underneath the hood per se easily? I know I can run TOP, but looking to see if there is a better way to identify maybe what is actually slowing down my system.

    Thanks in advance to everyone for your time and help. It is greatly appreciated!

    Thanks,
    Asif

  • @a4orce84
    htop shows the memory and swap usage quite clearly. Also glances is good for doing about the same.

    Use the tool right after boot, and later when the system is slow. Then compare the results, hopefully you’ll find the reason.

    If you have Gnome extensions, one or some of them may be the reason, too.

    I use Xfce, and have never noticed any slowing down.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • This post is deleted!
  • watching the live journal can be helpfull too:
    journalctl -f

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hey Everyone,

    Attaching some HTOP screenshots to help in the troubleshooting. More details below:

    Image 1 - Fresh Boot (6 minute uptime):
    https://imgur.com/a/p84Iw4f

    Image 2 - 12 Hour uptime:
    https://imgur.com/a/ii8BkOU

    Image 3 - 1 day and 12 Hour uptime:
    https://imgur.com/a/nGECiix

    These are with my usual applications open. I can see chromium taking up a lot of memory, but not sure if anything else jumps out at anyone. Thoughts?

    Thanks again everyone for your time ad help, it is super appreciated!

  • @a4orce84
    What if you try to reduce a program or its extension one by one, does the lagging stop at some point?

    For example, Gnome extensions may be candidates to try that.

    Another is chromium extensions, like PepperFlash. And if you don’t really need Flash, just remove it for good.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • Thanks @manuel, I’ll give that a shot. But with my previous question, is there anything in the htop command that jumps out as a potential memory hog application or process?

    Thanks again for everyones time and help, it is greatly appreciated!

  • @a4orce84
    Not very much, only chromium as you already mentioned. But chromium’s memory consumption doesn’t seem extraordinarily high.
    You do have some swap usage (still not alarming amounts), but can you somehow see what’s causing it?

    Maybe show the output of

    lsblk -fm
    

    ?
    Also the journalctl what Joe suggested might show you some useful info.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel said in XPS 13 on Gnome DE - Slow and Laggy:

    lsblk -fm

    Output of the lsblk -fm command below:
    https://imgur.com/a/fuJzWNS

    Please let me know if I can provide anything else to help in the troubleshooting process.

  • @a4orce84 I would also suggest sorting by memory with the a descending order, so the highest memory using applications are on top.

    Sys01: Surface Pro 3; Antergos + Gnome; 4GB mem

  • I can’t see anything special with those outputs. Maybe @n_mag’s suggestion brings some more light.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • top -o %MEM

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in XPS 13 on Gnome DE - Slow and Laggy:

    top -o %MEM

    Output:
    https://imgur.com/a/OwRQzhZ

    Please let me know your thoughts! Thanks again everyone!

  • @a4orce84
    From Judd’s links it may be a problem with the latest kernel.
    If that is the case here, you could try changing the kernel to LTS kernel (if you are using the default kernel). Don’t know if that helps though, since someone said that the same modifications were done to LTS kernel, too. But worth a try I think.

    To install LTS linux:

    sudo pacman -S linux-lts  # and optionally linux-lts-headers
    

    and reboot to the lts kernel (in the boot submenus).

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

gnome304 slow26 xps23 laggy4 Posts 16Views 504
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.