• Bluetooth doesn't power back up (?)


    Running Antergos deepin on a Mac Mini and use Apple bluetooth keyboard and
    trackpad. Bluetooth goes idle when away from computer for a longer while, and that is totally normal I suppose, but it doesn’t switch back on. Like I switch on the monitor and punch a key on the keyboard or trackpad and nothing happens. It drove me nuts yesterday so I logged in to my session with USB keyboard and mouse to try to investigate what was going on with the help of similar issues people had reported, but with no luck. After rebooting things were fine again and now today when I got home the same thing happened. But this time I tried (with help of the USB-mouse) to hibernate the computer and then after waking it up bluetooth was up and running without issues. So it seems like it is some sort of maybe powersaving-function which kicks in when idle and then failes to fire back up on its own.

    Any help in trying to sort this out would be deeply appreciated 🙂

    No idea if this is a distro-issue or a DE-issue, but I had similar issues on my deepin installation. Although there the keyboard and trackpad would disconnect frequenlty during use - that was why I gave Antergos deepin a shot. And so far Antergos is way (way way) better, except for the mentioned issue 🖊

    /hackan

  • @hackan301
    https://wiki.archlinux.org/index.php/Bluetooth#Thinkpad_Bluetooth_Laser_Mouse_problems

    this can be helping… but i do not know, as BT input devices are this kind of stuff i would never use…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Thank you for that link, @joekamprad. I will have to wait a day so I can test this before I can change this to solved.

    What I did:

    --------------| /etc/bluetooth/input.conf |----------------
    
    # Configuration file for the input service
    # This section contains options which are not specific to any
    # particular interface
    [General]
    
    # Set idle timeout (in minutes) before the connection will
    # be disconnect (defaults to 0 for no timeout)
    IdleTimeout=0
    
    #Enable HID protocol handling in userspace input profile
    #Defaults to false(hidp handled in hidp kernel module)
    #hackan: This disables touch-surface of trackpad. Only sends hardware-clicks so I comment it out.
    #UserspaceHID=true
    
    -------------------------------------------------------------
    

    Have also changed these paragraphs (no idea if they help or not):

    ---------------| /etc/bluetooth/main.conf |-------------------
    
    # Permanently enables the Fast Connectable setting for adapters that
    # support it. When enabled other devices can connect faster to us,
    # however the tradeoff is increased power consumptions. This feature
    # will fully work only on kernel version 4.1 and newer. Defaults to
    # 'false'.
    FastConnectable = true
    
    # AutoEnable defines option to enable all controllers when they are found.
    # This includes adapters present on start as well as adapters that are plugged
    # in later on. Defaults to 'false'.
    AutoEnable=true
    

    To be concluded… 👣


  • The above tweak seems to work pretty well ⛑

    Only one time during the last couple of days the bluetooth has like not been able to wake up. The solution then was to put the computer to sleep from the password-screen with the use of a USB-mouse and then wake the computer back up. When the computer wakes up the bluetooth is up and running and has now been up even when I leave the computer idle for eleven hours ✌

  • great!

    I keep my fingers crossed to let it stay like this for you!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

bluetooth45 power19 Posts 5Views 233
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.