• Wifi not working


    ok now that i have internet i tried again and this came up resolving dependencies…
    looking for conflicting packages…

    Packages (2) libx86emu-1.12-1 hwinfo-21.52-1

    Total Download Size: 0.78 MiB
    Total Installed Size: 3.35 MiB

    :: Proceed with installation? [Y/n] y
    :: Retrieving packages…
    libx86emu-1.12-1-x86_64 50.5 KiB 1402K/s 00:00 [#####] 100%
    hwinfo-21.52-1-x86_64 745.9 KiB 7.28M/s 00:00 [#####] 100%
    (2/2) checking keys in keyring [#####] 100%
    (2/2) checking package integrity [#####] 100%
    (2/2) loading package files [#####] 100%
    (2/2) checking for file conflicts [#####] 100%
    (2/2) checking available disk space [#####] 100%
    :: Processing package changes…
    (1/2) installing libx86emu [#####] 100%
    (2/2) installing hwinfo [#####] 100%
    :: Running post-transaction hooks…
    (1/1) Arming ConditionNeedsUpdate…

  • if you are posting codeblocks/logs please use the </> button while marking the code part will put it like this:

    Packages (2) libx86emu-1.12-1 hwinfo-21.52-1
    
    Total Download Size: 0.78 MiB
    Total Installed Size: 3.35 MiB
    
    :: Proceed with installation? [Y/n] y
    :: Retrieving packages…
    libx86emu-1.12-1-x86_64 50.5 KiB 1402K/s 00:00 [#####] 100%
    hwinfo-21.52-1-x86_64 745.9 KiB 7.28M/s 00:00 [#####] 100%
    (2/2) checking keys in keyring [#####] 100%
    (2/2) checking package integrity [#####] 100%
    (2/2) loading package files [#####] 100%
    (2/2) checking for file conflicts [#####] 100%
    (2/2) checking available disk space [#####] 100%
    :: Processing package changes…
    (1/2) installing libx86emu [#####] 100%
    (2/2) installing hwinfo [#####] 100%
    :: Running post-transaction hooks…
    (1/1) Arming ConditionNeedsUpdate…
    
  • ok got it but what do i do now?

  • sudo hwinfo --short --netcard
    

    give short info about network cards installed

    hwinfo --all --log hardware_info.txt
    

    to pastebin the info and get an url you can post here:

    hwinfo --all --log hardware_info.txt && cat hardware_info.txt | curl -F [email protected] https://ptpb.pw/?u=1
    
  • when I did the sudo command this happened
    network:
    Realtek Network controller
    enp2s0 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

  • yes wifi is not detected at all… only wired lan connector…

  • that is the problem but when I had windows 10 my wifi would work perfectly

  • but windows is not installed anymore? if you have it installed you can get info about wifi hardware from windows (also hwinfo is aviable for windows)

  • just a question if i went out and bought an external wifi adapter would that fix all of this because I could just do that and all of this would be solved

  • and yes windows is gone

  • most of them will work out of the box, and you can get also some certified for working with linux…

    realtek is allways a bad choice, but i have 2 realtek usb wifi sticks working without a problem here… and most producers do not say anything about chipsets onto the package ;)

    not that i do recommend googlezon in any way but only to show:

    https://www.amazon.com/s/ref=nb_sb_noss?url=search-alias%3Dcomputers&field-keywords=wifi+usb+linux

  • So i got a new wifi & bluetooth adapter but the wifi still isn’t working (the bluetooth is tho

  • @nilnail0-01 lsusb will show some info about the wifi…or sudo hwinfo --short --netcard

  • [[email protected] ~]$ sudo hwinfo --short --netcard
    [sudo] password for nilnail:
    network:
    Realtek Network controller
    enp2s0 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    [[email protected] ~]$

    looks like it doesn’t even know i have a wifi adapter

  • lsusb should show some info, but it is bad luck …

    the wifi stick is not recognized by kernel drivers…
    I would give it back… and try another one… And ask your dealer that you do not want a realtek chipset!

  • Just a wild guess, but on my laptop, I have a small switch on the top of the unit that turns the wifi on or off.
    If you have this also it is in the on position?

  • ok so i got another one and it gave me some drivers to install and the script i’m supposed to install is this !/bin/bash

    Auto install for 8192cu

    September, 1 2010 v1.0.0, willisTang

    Add make_drv to select chip type

    Novembor, 21 2011 v1.1.0, Jeff Hung

    ################################################################################

    echo “##################################################”
    echo “Realtek Wi-Fi driver Auto installation script”
    echo “Novembor, 21 2011 v1.1.0”
    echo “##################################################”

    ################################################################################

    Decompress the driver source tal ball

    ################################################################################
    cd driver
    Drvfoulder=ls |grep .tar.gz
    echo “Decompress the driver source tar ball:”
    echo " "$Drvfoulder
    tar zxvf $Drvfoulder

    Drvfoulder=ls |grep -iv '.tar.gz'
    echo “$Drvfoulder”
    cd $Drvfoulder

    ################################################################################

    If makd_drv exixt, execute it to select chip type

    ################################################################################
    if [ -e ./make_drv ]; then
    ./make_drv
    fi

    ################################################################################

    make clean

    ################################################################################
    echo “Authentication requested [root] for make clean:”
    if [ “uname -r |grep fc” == " " ]; then
    sudo su -c “make clean”; Error=$?
    else
    su -c “make clean”; Error=$?
    fi

    ################################################################################

    Compile the driver

    ################################################################################
    echo “Authentication requested [root] for make driver:”
    if [ “uname -r |grep fc” == " " ]; then
    sudo su -c make; Error=$?
    else
    su -c make; Error=$?
    fi
    ################################################################################

    Check whether or not the driver compilation is done

    ################################################################################
    module=ls |grep -i 'ko'
    echo “##################################################”
    if [ “$Error” != 0 ];then
    echo “Compile make driver error: $Error”
    echo “Please check error Mesg”
    echo “##################################################”
    exit
    else
    echo “Compile make driver ok!!”
    echo “##################################################”
    fi

    if [ “uname -r |grep fc” == " " ]; then
    echo “Authentication requested [root] for install driver:”
    sudo su -c “make install”
    echo “Authentication requested [root] for remove driver:”
    sudo su -c “modprobe -r ${module%.}"
    echo “Authentication requested [root] for insert driver:”
    sudo su -c "modprobe ${module%.
    }”
    else
    echo “Authentication requested [root] for install driver:”
    su -c “make install”
    echo “Authentication requested [root] for remove driver:”
    su -c “modprobe -r ${module%.}"
    echo “Authentication requested [root] for insert driver:”
    su -c "modprobe ${module%.
    }”
    fi
    echo “##################################################”
    echo “The Setup Script is completed !”
    echo “##################################################”

    so i put the whole thing in terminal and it came out with…
    make: *** No rule to make target ‘clean’. Stop.
    can you help me install the drivers so my wifi might work?
    note i probably look really stupid and that i don’t understand basic code

  • @nilnail0-01 said in Wifi not working:

    8192cu

    usually there is no need to compile a driver on your own, as they are aviable from kernel itself or over a package/AUR PKGBUILD…

    And the one you get with the stick is may outdated and not compatible wuth archlinux system or the current kernel.

    So first check lsusb to see if it is aviable (also try changing the usb port as may the one you are using is different from the other // e…g usb3/2 // )

    Then check the journal if driver and firmware is loaded and working:

    journalctl | grep 8192cu
    journalctl | grep firmware
    

    I have a stick with the same chipset working here without any extra installation:

     kernel: usb 1-3.4: new high-speed USB device number 7 using ehci-pci
     kernel: usb 1-3.4: New USB device found, idVendor=0bda, idProduct=8178
     kernel: usb 1-3.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
     kernel: usb 1-3.4: Product: USB WLAN
     kernel: usb 1-3.4: Manufacturer: 802.11n
     kernel: usb 1-3.4: SerialNumber: 00e04c000001
     mtp-probe[12810]: checking bus 1, device 7: "/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-3/1-3.4"
     mtp-probe[12810]: bus: 1, device: 7 was not an MTP device
     kernel: cfg80211: Loading compiled-in X.509 certificates for regulatory database
     kernel: cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
     kernel: platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
     kernel: cfg80211: failed to load regulatory.db
     systemd-udevd[12831]: Process '/usr/bin/set-wireless-regdom' failed with exit code 1.
     kernel: rtl8192cu: Chip version 0x11
     kernel: rtl8192cu: Board Type 0
     kernel: rtl_usb: rx_max_size 15360, rx_urb_num 8, in_ep 1
     kernel: rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
     systemd[1]: Starting Load/Save RF Kill Switch Status...
     kernel: ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
     NetworkManager[351]: <info>  [1527497315.4134] wifi-nl80211: (wlan0): using nl80211 for WiFi device control
     kernel: usbcore: registered new interface driver rtl8192cu
     NetworkManager[351]: <info>  [1527497315.4138] device (wlan0): driver supports Access Point (AP) mode
     NetworkManager[351]: <info>  [1527497315.4169] manager: (wlan0): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/4)
     dbus-daemon[349]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service' requested by ':1.3' (uid=0 pid=351 comm="/usr/bin/NetworkManager --no-daemon ")
     kernel: usbcore: registered new interface driver rtl8xxxu
     systemd[1]: Starting WPA supplicant...
     systemd-udevd[12832]: link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
     kernel: rtl8192cu 1-3.4:1.0 wlp0s26f7u3u4: renamed from wlan0
     NetworkManager[351]: <info>  [1527497315.4345] rfkill1: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1a.7/usb1/1-3/1-3.4/1-3.4:1.0/ieee80211/phy0/rfkill1) (driver rtl8192cu)
     upowerd[527]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:1a.7/usb1/1-3/1-3.4
     systemd[1]: Started Load/Save RF Kill Switch Status.
     dbus-daemon[349]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
     wpa_supplicant[12848]: Successfully initialized wpa_supplicant
     systemd[1]: Started WPA supplicant.
     NetworkManager[351]: <info>  [1527497315.4585] supplicant: wpa_supplicant running
     NetworkManager[351]: <info>  [1527497315.4732] device (wlp0s26f7u3u4): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
     kernel: IPv6: ADDRCONF(NETDEV_UP): wlp0s26f7u3u4: link is not ready
     kernel: rtl8192cu: MAC auto ON okay!
     upowerd[527]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:1a.7/usb1/1-3/1-3.4/1-3.4:1.0
     kernel: rtl8192cu: Tx queue select: 0x05
     kernel: IPv6: ADDRCONF(NETDEV_UP): wlp0s26f7u3u4: link is not ready
     NetworkManager[351]: <info>  [1527497316.1260] device (wlp0s26f7u3u4): set-hw-addr: set MAC address to A2:29:2F:DE:52:69 (scanning)
     kernel: rtl8192cu: MAC auto ON okay!
     kernel: rtl8192cu: Tx queue select: 0x05
    
  • the first command did nothing and the second sent feedback longer than the max amount of characters

  • then give the full journal here after plugging in the wifi stick:

    lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1
    

    copy paste inside a terminal and give here only the url it gives out at the end!

wifi152 Posts 86Views 4390
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.