• Dual boot install problems


    I’m at a bit of a loss. I bought my laptop a year ot two ago. It came with Windows10 with a 1TB hard drive. I removed the hard drive and replaced it with a 250GB SSD. I don’t remember what I did when the old HD was installed, but apparently resized the windows partition and repartitioned it to dual boot it. Again, I don’t remember.

    I have reinstalled the 1TB hard drive because I need more storage than the 250GB SSD. Over the weekend I tried several things. Unfortunately I didn’t take any notes and I’m depending on my memory.

    I’ve attached a screenshot of Gparted with my current system setup.

    I originally tried installing Antergos on dev/sda5 from an older usb flash drive and it just wouldn’t work. So I tried and succeeded installing Anarchy Linux on dev/sda5 and on boot got the appropriate grub selection screen.

    I realized that I had been using an older antergos iso, so I downloaded the current version and then tried installing it on dev/sda7. The installation went fine, but I got some error when I rebooted and it wouldn’t boot.

    Next I successfully installed Ubuntu on dev/sda7 and it booted into a grub menu and I had access to both Linux installs but not the Windows. And that’s where I am now.

    I don’t like the Ubuntu grub screen, so I wanted to change to the Anarchy grub. Based on instructions I successfully used before which I got from the Antergos forums, I tried installing grub when I was logged into the Anarchy installation. I got the following:
    <code>[sudo] senha para randall:
    Instalando para a plataforma i386-pc.
    grub-install: aviso: this GPT partition label contains no BIOS Boot Partition; embedding won’t be possible.
    grub-install: aviso: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged…
    grub-install: erro: will not proceed with blocklists.</code>

    Also of note, when I look at the BIOS, it appears there is only a legacy boot option. I didn’t see an option for UEFI.

    I’d really like two things. First and more important, is I want to get Antergos installed and working on this computer. It’s the only distro I REALLY like. Second, I’d like to be able to use the Windows10.

    Any ideas what I should do?

  • @rpallen
    Couldn’t see your screenshot…

    Lets check some things. Could you show the output of commands

    lspci -fm
    blkid
    fdisk -l
    

    And could you explain in much more detail what worked and what not when installing Antergos? Also please explain what selections you made during install.

  • First, I tried to edit the original post that I couldn’t figure out how to attach a file. But akismet said it was spam. The forum software interface is terrible, but I wrote about that in another post. Because the are for writing the post is scrunched at the bottom of the screen I have to type the post in a text editor and then paste it into the fórum.

    lspci -fm gives
    [[email protected]_es_15:~]$ lspci -fm (04-23 17:27)
    lspci: invalid option – ‘f’
    and then a bunck of switch options

    blkid gives
    [[email protected]_es_15:~][1]$ blkid (04-23 17:27)
    /dev/sda1: LABEL=“ESP” UUID=“C4A8-FAD4” TYPE=“vfat” PARTLABEL=“EFI system partition” PARTUUID=“c6bc6ece-5a50-406f-8344-f1d5e75271e7”
    /dev/sda3: LABEL=“Acer” UUID=“D4EAAA84EAAA630A” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“45aac826-72f8-40ee-936a-ff7012628987”
    /dev/sda4: LABEL=“Recovery” UUID=“EA28AB5C28AB2693” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“4670f5b2-8a64-45ba-b3b2-dced211f8ce7”
    /dev/sda5: UUID=“15f68f49-dd45-411c-b378-a09ecac2a854” TYPE=“ext4” PARTLABEL=“Linux1” PARTUUID=“9914a149-2af2-45f7-b0a8-b7df6c39d8e9”
    /dev/sda6: UUID=“31729de2-7029-4cb1-884c-42586bef6122” TYPE=“swap” PARTUUID=“7cdda808-be96-4720-b335-96d7e712d21b”
    /dev/sda7: UUID=“29db7de6-4392-4553-b2f7-180b30173b15” TYPE=“ext4” PARTUUID=“3b7e9ba5-8d39-44f7-98a4-aa14de58a3ea”
    /dev/sda8: LABEL=“armazem-ext4” UUID=“641c95ed-c792-4c65-bfad-399bc1279b0b” TYPE=“ext4” PARTLABEL=“armazem-ext4” PARTUUID=“04296522-256e-4ae6-aea3-00ffe87abfe1”

    sudo fdisk -l gives
    [sudo] senha para randall:
    Disco /dev/sda: 931,5 GiB, 1000204886016 bytes, 1953525168 setores
    Unidades: setor de 1 * 512 = 512 bytes
    Tamanho de setor (lógico/físico): 512 bytes / 4096 bytes
    Tamanho E/S (mínimo/ótimo): 4096 bytes / 4096 bytes
    Tipo de rótulo do disco: gpt
    Identificador do disco: BF11A69F-2370-4BD1-9C25-227C521F2737

    Dispositivo Início Fim Setores Tamanho Tipo
    /dev/sda1 2048 206847 204800 100M Microsoft dados básico
    /dev/sda2 206848 239615 32768 16M Microsoft reservado
    /dev/sda3 239616 976984063 976744448 465,8G Microsoft dados básico
    /dev/sda4 1951424512 1953521663 2097152 1G Windows ambiente de recupera
    /dev/sda5 976984064 1079384063 102400000 48,8G Linux sistema de arquivos
    /dev/sda6 1079384064 1095008255 15624192 7,5G Linux swap
    /dev/sda7 1095008256 1198168063 103159808 49,2G Linux sistema de arquivos
    /dev/sda8 1198168064 1951424511 753256448 359,2G Linux sistema de arquivos

    Partições lógicas fora da ordem do disco.

    Regarding more details, I can’t really give more because I don’t remember. If it becomes necessary, I’ll try replicating what I did and take notes, but I won’t have time to do that till next weekend.

  • I just realized the results from the command line are in Portuguese. I live in Brazil and my system is in Portuguese. Some stuff is obvious, but if you don’t understand something I’ll try to translate it. "Partições lógicas fora da ordem do disco.” means logical partitions are out of order of the disk.

  • @rpallen
    Don’t worry about the language, Google translator is quite good (although not perfect).

    And sorry about one of the commands, I meant

    lsblk -fm
    

    But command

    lspci
    

    gives also useful info.

    Your /dev/sda1 is the ESP partition, so you have UEFI boot.

    Unfortunately it is very late here in Europe, so I’ll come back tomorrow. But maybe someone else manages to help you already before I come back. :)

  • @rpallen
    First you could show what EFI files you have in /dev/sda1:

    sudo mount /dev/sda1 /mnt
    find /mnt -iname \*.efi -exec ls -l {} \;
    sudo umount /mnt
    

    Based on that info, we can try to fix the system, or maybe reinstall Antergos (in UEFI mode).

  • First, Thanks for your help.
    Second, during the week I’m pretty busy so there may be times when it takes quite a while, even a day or two, for me torespond.
    Third, the results to the find command are:
    [[email protected]_es_15:local/bin]$ find /mnt -iname *.efi -exec ls -l {} ; (04-24 11:24)
    -rwxr-xr-x 1 root root 1159008 set 16 2016 /mnt/EFI/OEM/Boot/bootmgfw.efi
    -rwxr-xr-x 1 root root 1148256 set 16 2016 /mnt/EFI/OEM/Boot/bootmgr.efi
    -rwxr-xr-x 1 root root 1031520 set 16 2016 /mnt/EFI/OEM/Boot/memtest.efi
    -rwxr-xr-x 1 root root 1159008 set 16 2016 /mnt/EFI/Microsoft/Boot/bootmgfw.efi
    -rwxr-xr-x 1 root root 1148256 set 16 2016 /mnt/EFI/Microsoft/Boot/bootmgr.efi
    -rwxr-xr-x 1 root root 1031520 set 16 2016 /mnt/EFI/Microsoft/Boot/memtest.efi
    -rwxr-xr-x 1 root root 1159008 set 16 2016 /mnt/EFI/Boot/bootx64.efi

  • @rpallen
    From the info you have given, it seems that the problem is installing Ubuntu in BIOS boot mode, not UEFI mode.

    You have Windows installed in UEFI boot mode, and other systems need to be installed using the same boot mode.

    So probably a simple reinstall of Antergos with the proper mode (UEFI) should do the trick. I’d suggest you try that.

    If there are still problems with booting, don’t do anything more. Just give more details of your machine, model, and hardware:

    lspci
    lsblk -fm
    
  • Note that during reinstall, when the installer asks about partitions, especially EFI partition (/dev/sda1), just mount that EFI partition to /boot/efi (and do NOT format it!).
    Then the installer can do its magic and make system bootable again.

    And if you haven’t disabled secure boot in BIOS/firmware, do it before installing.

  • @manuel said in Dual boot install problems:I’ll write this quickly but then I have to go back to work.

    You said, “So probably a simple reinstall of Antergos with the proper mode (UEFI) should do the trick. I’d suggest you try that.” I’m not sure how to initiate that. I don’t remember anything asking me which mode to install in.

    I mentioned before that I didn’t see UEFI in my BIOS. I looked again and I still don’t see it. In the Boot screen of the BIOS, it only says Boot Mode: Legacy with no other options. Usually in a screen that has options, the opdtions are listed on the right side of the page. On the right side of the boot page it only says “Item Specific Help” and the below that “Set System Boot Mode” and nothing eles.

    Perhaps I did something to screw this up . You may recall I sais I tried installing Grub and got the result below. Is it possible I did something to the GPT Partition that isn’t allowing the UEFI option?

    [sudo] senha para randall:
    Instalando para a plataforma i386-pc.
    grub-install: aviso: this GPT partition label contains no BIOS Boot Partition; embedding won’t be possible.
    grub-install: aviso: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged…
    grub-install: erro: will not proceed with blocklists.

  • I just read your second post about reinstalling. You said, “Note that during reinstall, when the installer asks about partitions, especially EFI partition (/dev/sda1), just mount that EFI partition to /boot/efi (and do NOT format it!).” Is that the answer to my question about how to install in UEFI? Is that all there is to it? I don’t have to worry about the boot mode in the BIOS?

    Have to go to work now. Bye.

  • @rpallen
    Hmm… I installed so long ago that I’m not sure about all the details…

    Your BIOS/firmware may have settings about UEFI or BIOS legacy boot, check them first that they are OK.

    The trick is to install all operating systems in the same boot mode, and it seems that Windows is installed in UEFI mode, because you have a vfat partition /dev/sda1 with Windows efi files.

    So boot the installer (this is the part I’m not sure: does it have selection of UEFI vs. legacy boot, or not). Then as said previously, when selecting partitions, choose to mount /dev/sda1 to /boot/efi, and other partitions as you wish.

    If the installer has problems with UEFI stuff, then you need to recheck your BIOS/firmware about the UEFI settings and start the reinstall process again.

    So in principal this process should be quite straightforward (although you need to be careful when setting partitions). But sometimes a machine does not want to play it nice, and in that case we need some more info about your machine.

  • @manuel said in Dual boot install problems:

    So boot the installer (this is the part I’m not sure: does it have selection of UEFI vs. legacy boot, or not)

    If installer is boot in efi mode it will detect this and bott in efi mode, if legacy is enabled it will boot over grub mode (Bios Mode), but we have situations where this went wrong…(VERY LIMITED ONES)

  • Thanks, guys. I’ll work on this later today. I have to go to work now.

  • This post is deleted!
  • OK, let me re-cap to clarify the situation.

    A few years ago I bought an Acer Aspire ES 15 laptop with a 1TB hard drive running Windows10. Though I don’t remember for sure, I apparently I made this laptop a bual boot system. I don’t remember what, if anything, I did during that process that would have changed to GPT tables or removed the ability to boot UEFI.

    Not long after this, I installed a 240 GB SSD. I don’t remember how I did it, but I made this a dual boot system with Windows 10 and Antergos. Again, I don’t remember what, if anything, I did during the process of making this SSD a dual boot system that would have changed to GPT tables or removed the ability to boot UEFI.

    240 GB of storage became inadequate, so I put the original 1 TB hard drive back in and tried making it a triple boot system with the Windows 10 (which I never removed from the hard drive), Antergos and another Linux distro. I had problems installing the Antergos, so it currently has Anarchy on sda5 and Ubuntu on sda7. I don’t know if this works or if it causes a problem, but I have only one swap partition (sda6), which I used in the installation of both linux distros.

    Important note: This dual boot system on the SSD was working fine when I took the SSD out and put the original hard drive back in. I DIDN’T DO ANYTHING TO THE BIOS WHEN I PUT THE ORIGINAL HARD DRIVE BACK IN, so I had a properly functioning dual boot system with Windows 10 and Antergos on the machine with the BIOS as it currently is.

    Here are some of the current BIOS settings:
    In the boot tab:
    the Boot Mode is “Legacy” with no other options. Usually in a screen that has options, the options are listed on the right side of the page. On the right side of the boot page it only says “Item Specific Help” and then below that “Set System Boot Mode” and nothing else-nothing about UEFI. This is despite
    /dev/sda1 having the EPS flag and the rsults of a “find” command being:
    [[email protected]_es_15:local/bin]$ find /mnt -iname *.efi -exec ls -l {} ; (04-24 11:24)
    -rwxr-xr-x 1 root root 1159008 set 16 2016 /mnt/EFI/OEM/Boot/bootmgfw.efi
    -rwxr-xr-x 1 root root 1148256 set 16 2016 /mnt/EFI/OEM/Boot/bootmgr.efi
    -rwxr-xr-x 1 root root 1031520 set 16 2016 /mnt/EFI/OEM/Boot/memtest.efi
    -rwxr-xr-x 1 root root 1159008 set 16 2016 /mnt/EFI/Microsoft/Boot/bootmgfw.efi
    -rwxr-xr-x 1 root root 1148256 set 16 2016 /mnt/EFI/Microsoft/Boot/bootmgr.efi
    -rwxr-xr-x 1 root root 1031520 set 16 2016 /mnt/EFI/Microsoft/Boot/memtest.efi
    -rwxr-xr-x 1 root root 1159008 set 16 2016 /mnt/EFI/Boot/bootx64.efi

    THER DOES NOT APPEAR TO BE ANY WAY TO SELECT UEFI.

    In the Main tab, 3 of the entries are:
    GPT Partition Recovery [None]
    Clear GPT Petition [None]
    GPT Partition Record No Record

    In the Security tab I don’t see anything about secure boot or how to turn it off or on. Is that because there is apparently no GPT?

    2 questions:

    1. I had a functioning dual boot system on the SSD with the BIOS as it is now. So apparently I was able to get the Windows 10 and the Antergos to both boot in legacy mode. Why can’t I do that with the original hard drive.

    2. You suggested, “Note that during reinstall, when the installer asks about partitions, especially EFI partition (/dev/sda1), just mount that EFI partition to /boot/efi (and do NOT format it!).”
      Given that there apparently isn’t any GPT and that there is no option to switch to boot mode: UEFI, if I follow your suggestion and try installing Antergos on the sda7 partition (currently Ubunto which has the grub installation that appears during bootup) will it work? If it doesn’t work, will it “break” my current system?

  • @rpallen
    One question before answering to others: is it possible for you to reinstall all operating systems, including Windows 10?

    With this question I mean two things:

    1. Do you have good backups of your personal data, so that after reinstall you can restore all your data?
    2. Do you have Windows 10 activation key that you can use in case reinstall asks for it? It may not ask for it, but it is good to know before doing anything, if you want to keep Windows.

    I ask this because it seems that the easiest thing to do is reinstall everything. For me it seems that trying to find what’s wrong in the machine takes way more time than reinstalling it all from scratch.

    And if you choose to reinstall, first install Windows 10, and then Antergos.
    If you choose legacy boot (as you say you already have), then recreate partition table to msdos, not gpt (even though gpt is newer and thus potentially better). You could change partition table with gparted before installing Windows.

    It is possible to use gpt, but with gpt, I recommend creating a small (e.g. 1 MB) empty partition in the beginning of the drive, and mark its flags as bios_grub (hopefully I remember this type name right).

  • To answer your questions, yes, I have good backups of everything on my hard drive. I backup everything I store on an old hard drive I use as an external HD by connecting USB. Additionally, anything I absolutely, under no circumsatance want to lose I back up to my s3 account on AWS só it is backed up on and off site.

    No, I don’t have the Windows activation key. It has worn off of the bottom of my computer. As you said, it may not ask for it during installation, but it is good to have. The next time I but a computer with Windows, I’ll be sure to record it somewhere secure. If I recall correctly, when I did the install on the SSD I didn’t need it.

    I’ve thought about doing as you say, just reinstall everything. I’ve also considered using the recovery partition on /dev/sda4. I didn’t read thoroughly, but what I’ve read if I use that recovery capability, I may not lose the data I currently have stored on /dev/sda8 which is where I store virtually everything (except stuff I creat in Windows because it is formatted as ext4).

    Well, I guess I’ll see if I can download the Windows installation media now.

  • @rpallen
    Just occurred to me that you could try the Windows recovery thing so that it would make Windows in control of the booting. Then you wouldn’t have to reinstall Windows. Also you could check which boot mode the recovery chose for Windows, and use the same mode for Antergos.

  • Well Manuel, I didnt see your last post until just now. Anyway, I was able to successfully reinstall Windows 10 from the recovery partition and I didnt lose anything. The two Linux installations and my storage partition are fine. But of course I can`t access them from Windows and there is no longer a Grub boot selector.

    I tried installing Antergos from a live USB. The USB works fine (in fact I`m in Antergos right now on the live usb). But when I try to install I get an error, Cannot create download packager list (metalinks). Please reference the following number when reporting this error. 1083787.

    I tried several times and each time I got the same error but with a different number (1083804, 1083898, 1083921).

    I see others are having the same error (post 9745) and in this post joekamprd posted about 11 hours ago, “there is something wrong today, a lot users fail on install…”.

    What should I do? Should I wait for a resolution of the problem defined in that post #9745 or is there something else I can do?

boot271 dual35 Posts 91Views 3170
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.