• Latest Antergos Install mouting NTFS partitions read only

    I just installed Antergos again a few hours ago but I discovered that the new linux kernel added a new issue:
    My NTFS partition /dev/sda1 is read only for both user:ben and root.
    I was not used to see this issue in the previous installations.
    I’m pretty sure that the latest kernel update is for something.
    Here are some screenshots from Gnome Disks:
    alt text
    alt text

  • While I’m ont it I think I’m going to change my strategy for Antergos installations. I will use LTS kernels option in the future:
    the latest release 2017-11-12 which is quite recent.

  • Just to let everyone know that yesterday, I reinstalled Antergos late in the night with LTS Linux kernel option and the read only NTFS partitions (for root !!) issue persisted. So if there is a problem in the new updates, it’s not related to the kernel.
    Furthermore, I do see a memory leak in some gnome desktop applications, most apparent is the Text editor/gedit. In some circumstance there is slowness in the editor which is easily detectable when we see the mouse cursor busy.

    My point here is just to give some feedback to the developers so that they take care of issues that might appear in the future releases.

  • Hi!

    read only NTFS partitions

    This can happen if the partition is “dirty”.
    Just to be sure, unmount it, run ntfsfix on it and mount it again:

    sudo umoun /home/ben/User
    sudo ntfsfix /dev/sda1
    sudo mount /dev/sda1 /home/ben/User

    Hope this helps.

  • you can watch this in journalctl -f while mounting dirty ntfs:

     XXXXXXXX udisksd [784]: The disk contains an unclean file system (0, 0).
     XXXXXXXX udisksd [784]: Metadata kept in Windows cache, refused to mount.
     XXXXXXXX udisksd [784]: Falling back to read-only mount because the NTFS partition is in
     XXXXXXXX udisksd [784]: unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting.)
     XXXXXXXX ntfs-3g [30100]: Version 2017.3.23 external FUSE 29
     XXXXXXXX ntfs-3g [30100]: Mounted / dev / sdc2 (read-only, label "", NTFS 3.1)
     XXXXXXXX ntfs-3g [30100]: Cmdline options: rw, nodev, nosuid, uid = 1000, gid = 985, uhelper = udisks2
     XXXXXXXX ntfs-3g [30100]: mount options: rw, nodev, nosuid, uhelper = udisks2, allow_other, nonempty, relatime, ro, default_permissions, fsname = / dev / sdc2, blkdev, blksize = 4096
     XXXXXXXX ntfs-3g [30100]: Global ownership and permissions enforced, configuration type 7
     XXXXXXXX udisksd [784]: Mounted / dev / sdc2 at / run / media / XXXX / XXXXXXX on behalf of uid 1000

    I get this here with ntfs3g installed:

    XXXXXXXX ntfs-3g [30100]: Could not load plugin /usr/lib/ntfs-3g/ntfs-plugin-80000017.so: file or directory not found
    ntfs-3g [30100]: Hint /usr/lib/ntfs-3g/ntfs-plugin-80000017.so: Can not open the shared object file: file or directory not found

    folder /usr/lib/ntfs-3g is empty …

  • But only using GNOME/nautilus i do not have the error message under XFCE4 …

    B.T.W. rw mounting works fine on both with a clean ntfs :)

  • @karasu said in Latest Antergos Install mouting NTFS partitions read only:


    do not work in most cases, better boot into windows and clean from there…

  • @joekamprad said in Latest Antergos Install mouting NTFS partitions read only:

    do not work in most cases, better boot into windows and clean from there…

    It always worked here… 😕

  • @karasu but not on suspended, or unclean mounted ntfs windows system partitions or yes?

  • Hi,

    I haven’t tried on suspended systems… but on dirty ones (when windows being closed by brute force, for instance, switching off the computer), works perfectly.

  • May related to my hardware or something, i can do it on hard powered off and unclean works sometimes sometimes it say something like not permitted… but on suspended never…

    But i don’t mind on windows ;) i carry it only for sparrings

partitions12 ntfs10 mouting1 Posts 12Views 1222
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.