• Gnome Videos (Totem) Issue


    Hi everyone!

    After the update to Gnome 3.28, the Totem Video player is once again not functioning correctly. Playback is stuttering and flickering. Buttons and timeline aren’t working. No matter if i use gnome with wayland or xorg. Every other player I have installed performs without any errors. I prefer this player because of it’s pre-indexing features via the channel option. No matter what i want to play, the content in the folder is indexed in the background, while i start the first file in the folder. I use two NAS in my Home-Network by the way. My question now is does anyone know a bugfix or an alternative(pre-indexing, NAS) player?

    Regards and Kudos to the whole Antergos-Team! Keep goin!!

  • what exactly do you mean by “pre-indexing” ?

  • Thanks judd for the links, but the general playback is not the problem.

    @joekamprad

    I hope the picture can make it clear.

    ![0_1524259403176_Bildschirmfoto von 2018-04-20 23-16-14.png](Uploading 100%)

    When I start a file from my NAS and the playback is running, this file and every other file in this folder is indexed automatically. The blue bar indicates the current position what am I watching. The grey bar indicates the current indexing progress. The black part of the timeline is currently not indexed. When everything is grey I can jump freely within the files without any interrruption. This happens within seconds. So everytime i access my NAS-System everyting is up-to-date…

  • This post is deleted!
  • this little colour distortions in the time designation at the under left and right is since the update…

  • so you are talking about cache preloading data from files ?

    Mplayer is able to do so and VLC too…

    But the problem you got is not an official BUG, as i do not have this here and also i can not see any problems with totem at the moment, here and at Arch.

    May related to a problem between totem and playing from NAS (i do not have a NAS here)
    But i find this:

    https://bugs.launchpad.net/ubuntu/+source/clutter-1.0/+bug/1698270
    https://bugzilla.gnome.org/show_bug.cgi?id=778766#c2

  • No, not the cache preloading I suppose, because with Mplayer and VLC I can’t jump around in the timeline, when playing something via the NAS. I can start a video and it will play of course. But when I want to jump from the position five minutes, four seconds to the position twentythree minutes, fifteen seconds for example, VLC, Mplayer etc. are freezing or it takes about ten to twenty seconds before the playback continues. Every other player I’ve tested doesn’t generate a correct index of the video it seems…
    The errors I described are also happening when I want to play a local video file with totem on a harddisk or SSD. Here I can use other players(VLC, Mplayer, etc.) of course. Don’t know what’s causing this. Many parts of the Installation of Gnome are on version 3.28, Totem is still 3.26…

    As a workaround I’ve installed Kodi on my Notebooks and Desktop-PC’s. Everything works fine here so the problem is solved I would say.

    But I hope a future update will fix the issues with totem.

  • may totem is doing the indexing of the NAS files over tracker?

  • After a while of searching I found the error at the redhat-bugzilla. It seems it’s a amd gpu thing. Meaning a bug in cogl, mesa is causing the whole thing. When I start totem via console with following command:

    allow_rgb10_configs=false totem
    

    everything runs fine again.

    Under [link text]https://bugzilla.redhat.com/show_bug.cgi?id=1560481(link url) things were narrowed down to the above command.

    In the meantime the patch for mesa was fully integrated in mesa under fedora on 04-24! I hope it comes soon for arch/antergos! ;-)

  • With the update to mesa 18.0.3-4 the problem is gone. Solved I would say!

  • Great!
    Mark as solved then please!

gnome322 videos8 totem8 Posts 13Views 1125
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.