• Screen Tearing on KDE


    Screen tearing on Nvidia hardware seems to be a problem for a lot of people. I’ve found a solution that used to work. (simply go into the Nvidia server settings and force the composition pipeline). But that option is no longer under Advanced where it used to be.

    There is a way to do this in Terminal, and it does work:

    nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
    

    However, when I do this, it turns off (i.e. disables) one of my monitors. Reenabling the monitor in System Settings removes the fix for screen tearing.

    I’ve also had some success in other distros with the built in compositor in KDE. I usually turn on Full Screen repaints, and/or use OpenGL 3.1. However, this doesn’t seem to work for whatever reason in Antergos (it did in both Neon and Kubuntu, but those had other problems afterwards).

    I have the same problem in other DEs, but I seem to be able to download older Nvidia drivers and/or use a different display manager. I did try the older drivers on Antergos (340.xx vs 390.xx) but that didn’t work either. It still installed the new version of the nvidia X server settings which has the Force Composition Pipeline option removed.

    Does anyone know how to fix this. The tearing happens mostly when I scroll on web pages or move windows around on the desktops. I don’t play games. And youtube and other video sites do just fine it seems without any tearing at all.

  • Have you tried to use Xrender instead of OpenGL (in the KDE compositor)?

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

  • you can add the nvidia line also inside xserver configuration:
    /etc/X11/xorg.conf.d/20-nvidia.conf

    Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        Option "NoLogo" "true"
    EndSection
    
    Section "Screen"
        Identifier      "nvidia"
        Option          "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }
        Option          "TripleBuffer"                  "on"
        Option          "AllowIndirectGLXProtocol"      "off"
    EndSection
    

    And to solve multimonitor setup you can use nvidia-settings also or xrandr / arandr

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @bryanpwo Xrender solves the problem with the dragging of windows, but not the scrolling. The tearing while scrolling seems a bit worse actually.

  • @joekamprad That didn’t work at all. I had to create the file, as it didn’t exist, but even once I did (just copy and pasting what you had above), nothing happened after a restart. The tearing is still there. It’s the scrolling that I can’t stand. It just makes it so hard to read.

    Thanks for trying though. 🙂

  • This method helps me on all KDE distributions. I’m writing through an translator so the name of the settings can be different. Use it only when using a proprietary Nvidia driver.
    Settings-monitor (may be other name)- Providing Effects- Preventing discontinuities (vsync) - Are posing on Reuse.
    Then enter the following two commands:

    sudo sh -c 'echo "export __GL_YIELD=2USLEEP2" >> /etc/profile'
    
    sudo sh -c 'echo "export KWIN_TRIPLE_BUFFER=1" >> /etc/profile'
    

    alt text

    Russian fan club of Antergos

  • If tuxnot’s option doesn’t work, could you give us your hardware specs, so maybe one of us can give you the specific solution?

    KDE/XFCE/i3-WM

    Everybody is a genius, but if you judge a fish by its ability to climb a tree, it will live its whole life believing its stupid.

compton4 compiz3 screen tearing2 compositor1 Posts 7Views 561
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.