• Boot goes to GRUB prompt after install


    I’ve installed Antergos on a dual-boot (w/ Windows 8 ) system, Windows on one SSD and Antergos on a second SSD. The installer completed & appeared to run smoothly, but when I reboot, instead of the GRUB menu, I get a GRUB prompt. I’ve tried reinstalling GRUB using the directions on the Arch wiki, but when I do I get the following output:

    [[email protected] ~]$ sudo mount /dev/sdb1 /mnt
    [[email protected] ~]$ sudo mount /dev/sda2 /mnt/boot/efi
    [[email protected] ~]$ sudo arch-chroot /mnt
    [[email protected] /]# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=antergos
    Installing for x86_64-efi platform.
    EFI variables are not supported on this system.
    EFI variables are not supported on this system.
    Installation finished. No error reported.
    

    I’m positive that this machine supports UEFI. What could be the problem?

  • @coledot
    Hi,
    could you show the output of command

    lspci -fm
    

    and the contents of /etc/fstab?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • There seems to be a mismatch of EFI and BIOS legacy.
    Are you sure both systems are installed using UEFI?

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • @manuel

    lspci -fm

    Sorry, I meant

    lsblk -fm
    

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

  • Boot you PC with Antergos installation USB (or DVD) and follow these instructions:
    How To Fix Grub With EFI Boot?
    par Johannes Kamprad | Oct 19, 2017

    They saved my time yesterday.
    Also there is a thing not mentioned:
    It’s only with your BIOS setup you can rearrange the order of your Partition/OS load in UEFI.
    (go to advanced boot settings in BIOS)
    There are also tutorials on the net
    How To Get Ubuntu To Boot Before Windows Using The EFI Boot Manager
    that suggest to use efibootmgr tool to deal with UEFI. I don’t know if this program is shipped with Antergros or not.

  • "EFI variables are not supported on this system"
    I did get this message myself before following Antegros wiki.
    That means you are using instructions that aren’t appropriate or something in your partitions is not appropriate.

  • @manuel

    [[email protected] ~]$ lsblk -fm
    NAME   FSTYPE      LABEL       UUID                                 MOUNTPOINT                    SIZE OWNER GROUP MODE
    loop0  squashfs                                                     /run/archiso/sfs/root-image   1.8G root  disk  brw-rw----
    sda                                                                                             447.1G root  disk  brw-rw----
    ├─sda1 ntfs        Recovery    1C5287EE5287CB4A                                                   300M root  disk  brw-rw----
    ├─sda2 vfat                    2A88-2F04                                                           99M root  disk  brw-rw----
    ├─sda3                                                                                            128M root  disk  brw-rw----
    └─sda4 ntfs        unison      64A0965FA096380E                                                 446.6G root  disk  brw-rw----
    sdb                                                                                             447.1G root  disk  brw-rw----
    ├─sdb1 ext4        os          20384eaa-6056-4481-9160-bcc426e10afb                              19.1G root  disk  brw-rw----
    ├─sdb2 crypto_LUKS             27fe35fa-84da-4b10-b160-694e2d4b1b68                               3.8G root  disk  brw-rw----
    └─sdb3 crypto_LUKS             86aa5e3e-0f2d-41b8-b9ea-e70bff020188                             424.2G root  disk  brw-rw----
    sdd    iso9660     ANTERGOS    2018-04-02-09-52-24-00                                             7.3G root  disk  brw-rw----
    ├─sdd1 iso9660     ANTERGOS    2018-04-02-09-52-24-00               /run/archiso/bootmnt          1.9G root  disk  brw-rw----
    └─sdd2 vfat        ARCHISO_EFI C01B-D77E                                                           64M root  disk  brw-rw----
    

    @ben_h

    I tried the instructions on that wiki page, but end up with the same results.

  • I got it working.

    I was suspicious when I did a ls /sys/firmware and did not find an efi directory. It turns out I had to change around some settings in my BIOS, per steps 1-3 on this page: http://trackballer.com/2014/01/13/enabling-uefi-secure-boot-with-a-gigabyte-bios/ (IOW, stop before enabling secure boot).

    I’ve no idea why setting the BIOS to expect Windows 8 and to disable CSM support (w/e that is) gets grub-install to work, but there you go.

    Thanks for the help.

  • @coledot
    Machine vendors sometimes make their own quirks into BIOS/UEFI, and make life a bit tricky for Linux users. Some vendors (like e.g. HP) make UEFI boot against the standard and support only Windows boot (which can be worked around fortunately).
    But that’s just life. 😉

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL.

boot249 grub104 goes11 prompt5 Posts 9Views 222
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.