• Weird colors


    Hey all!
    I just want to report an issue i experienced after upgrading the system, the colors are totally messed up like bellow

    0_1524081545174_Screenshot_1.png

    I first noticed it while creating a new portergos release and thought i broken something, but after updating my Antergos the same problem appeared.

    The issue appearded using i3 and openbox, xfce4 is working fine.

    I tried downgrading xfce4-whiskermenu-plugin as suggested somewhere in the forum, but that didn’t solve the problem.
    Finally i downgraded xorg-server-common xf86-input-libinput xorg-server and the colors are fine.

    BUT i must add that for some reason all transparency configs aren’t working like panels, terminals etc, and IT SEEMS to me that the weird colors are happening only when some transparency is being used.

    Here goes updated packages that may have caused the issue (/var/log/pacman.log).
    https://pastebin.com/SXr1HBPz

  • EDIT1: I just updated all packages and the bug is there again, but then i downgraded only xorg-server and the cololors are fine. Still no transparency though.

    EDIT2: while running compton on terminal i get error “glx_init(): No GLX extension.” I hoppe i can fix it soon, i love transparency everywhere :)

  • no issue here with i3 compton latest and packages - but nvidia drivers used…

  • Downgrade llvm-libs

  • EDIT3: Ok i’mn just too lazy to fix compton so i just replaced it by the good and old xcompmgr

    So as far as i see my system is working as expected now.

    Cheers!

  • @joekamprad said in Weird colors:

    no issue here with i3 compton latest and packages - but nvidia drivers used…

    Ok i have onboard RADEON here.

    @judd rad said

    Downgrade llvm-libs

    Didn’t work.

    EDIT4: now i have errors when trying to run games from playonlinux (maybe other errors too) like bellow:

    The error is for both 32 bits and 64 bits
    0_1524086505043_Screenshot_2.png

  • I am sorry

  • I hope this is my last update!!! :P

    EDIT5: I updated my entire system and reinstalled mesa dependencies, there was a lot of them to install (WHY??? hehehe)
    With that playonlinux and my games are working again!

    And the pink weird color is triggered by compton, so now i have my system fully up to date and i’m using xcompgr

    Thank you all for your time and sorry for all this posts, the bug “Can’t edit posts” is still here :(
    Now i’ll make a new portergos iso using xcompmgr instead of compon.

  • moderators private talk here ;)

  • @joekamprad said in Weird colors:

    moderators private talk here ;)

    😀

weird19 colors8 Posts 10Views 496
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.