• Strange DKMS error with root on ZFS

    This one seems to explain itself, really.

    (1/6) Install DKMS modules
    ==> dkms install zfs/0.7.8 -k 4.15.15-1-ARCH
    configure: error: 
    	*** Please make sure the kmod spl devel <kernel> package for your
    	*** distribution is installed then try again.  If that fails you
    	*** can specify the location of the spl objects with the
    	*** '--with-spl-obj=PATH' option.  Failed to find spl_config.h in
    	*** any of the following:
    Error!  Build of zavl.ko failed for: 4.15.15-1-ARCH (x86_64)
    [[email protected] /]# find . -name spl_config.h

    Anyone have ideas as to why this might be happening?

  • I’ve sort’ve solved this, but not entirely. It seems SPL is not being installed by dkms, which causes the ZFS install to fail when doing updates.

    I have to do a dkms remove on both spl and zfs, otherwise one or the other throws an error about being installed, when they’re clearly not. Then I dkms install SPL, then ZFS, then remake the init image.

    I’m still not sure why SPL isn’t building automatically like it should.

  • @ranko-kohime said in Strange DKMS error with root on ZFS:

    I’m still not sure why SPL isn’t building automatically like it should.

    *Antergos uses dkms to manage the ZFS-, and needed SPL-kernel modules.

    At the moment there is no way to tell pacman which modules to build first.

    Most of the time, pacman tries to build the ZFS module before building the SPL module, so it fails.*

    Source: https://antergos.com/wiki/miscellaneous/zfs-under-antergos/

error340 root27 strange17 dkms8 Posts 4Views 365
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.