• A problem at starting just after fresh install


    I have Antergos on my laptop and everything works fine. But I installed it on a friend’s computer and I got in trouble.

    Just after the boot screen and the Antergos menu, I can read “start version 238” and the line beginning with
    clean [xxx/xxx]
    (the output of fsck I guess, saying that everything’s fine).

    Then, instead of starting LightDM, I see the cursor flickering… and that’s it.

    I tried with LightDM, SDDM and GDM (systemctl enable xxdm), but nothing changes : the cursor flickers. I have access to tty{2…6} and can log in it, but I don’t know what I can do with it to investigate more.

    There’s no problem to start and use the liveUSB.

    I have an Intel graphical chipset and the machine is quite old (2008) but powerful enough for sorting pictures and reading mails…

    Of course, the computer is old enough to have no UEFI.

    Who has an idea ?

  • @askkenneth
    Hard to say, but often some kernel boot parameter regarding graphics settings (like disabling a graphics driver that comes by default) helps.
    Which graphics card/driver it has?
    Command lspci might help.

    System info to URL: (lspci; lsblk -fm; sudo blkid; sudo fdisk -l) | curl -F [email protected] https://ptpb.pw/?u=1
    System journal to URL: journalctl -b -0 | curl -F [email protected] https://ptpb.pw/?u=1

  • lspci says that’s it’s an Intel integrated GPU…

  • @askkenneth
    So maybe you could try kernel boot parameter

    modprobe.blacklist=i915
    

    System info to URL: (lspci; lsblk -fm; sudo blkid; sudo fdisk -l) | curl -F [email protected] https://ptpb.pw/?u=1
    System journal to URL: journalctl -b -0 | curl -F [email protected] https://ptpb.pw/?u=1

  • Thanks, I’ll try that. does “i915” correspond to the name of the GPU ?

  • @askkenneth
    No, but the intel driver.

    System info to URL: (lspci; lsblk -fm; sudo blkid; sudo fdisk -l) | curl -F [email protected] https://ptpb.pw/?u=1
    System journal to URL: journalctl -b -0 | curl -F [email protected] https://ptpb.pw/?u=1

  • Arch wiki pages have very good info about graphics stuff and boot problems. Most of that info applies to Antergos as well.

    System info to URL: (lspci; lsblk -fm; sudo blkid; sudo fdisk -l) | curl -F [email protected] https://ptpb.pw/?u=1
    System journal to URL: journalctl -b -0 | curl -F [email protected] https://ptpb.pw/?u=1

  • lsmod | grep i915

    System info to URL: (lspci; lsblk -fm; sudo blkid; sudo fdisk -l) | curl -F [email protected] https://ptpb.pw/?u=1
    System journal to URL: journalctl -b -0 | curl -F [email protected] https://ptpb.pw/?u=1

  • I didn’t find the command

    modprobe.blacklist=i915
    

    But i tried :

    modprobe -b i915
    

    Nothing changes…

  • Well, I blacklisted the driver such that

    lsmod | grep i915

    returns nothing.
    But I’m still stuck at the same point.

  • @askkenneth

    A sit looks like a problem with grapühics you should take a look into X.logs:

    XSESSION
    Your session log is located in your /home directory:

    ~/.xsession-errors
    ~/.xsession-errors.old
    

    XORG (X11)
    You can find your Xorg logs here:

    /var/log/Xorg.0.log
    /var/log/Xorg.0.log.old
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hi @joekamprad, thanks for your answer.

    ~/.xsession-errors
    

    is empty, and here’s my Xorg.0.log :

    [    21.494] 
    X.Org X Server 1.19.6
    Release Date: 2017-12-20
    [    21.494] X Protocol Version 11, Revision 0
    [    21.494] Build Operating System: Linux 4.15.6-1-ARCH x86_64 
    [    21.494] Current Operating System: Linux michel-ordi 4.15.15-1-ARCH #1 SMP PREEMPT Sat Mar 31 23:59:25 UTC 2018 x86_64
    [    21.494] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=70f3b755-5557-4bf7-b8f1-68c95c71ce36 rw quiet resume=UUID=6f5199b0-9d46-4dcd-b8d7-266793f23cec
    [    21.494] Build Date: 12 April 2018  05:31:07AM
    [    21.494]  
    [    21.494] Current version of pixman: 0.34.0
    [    21.494] 	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    [    21.494] Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    21.494] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 12 23:29:46 2018
    [    21.494] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [    21.494] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [    21.495] (==) No Layout section.  Using the first Screen section.
    [    21.495] (==) No screen section available. Using defaults.
    [    21.495] (**) |-->Screen "Default Screen Section" (0)
    [    21.495] (**) |   |-->Monitor "<default monitor>"
    [    21.495] (==) No monitor specified for screen "Default Screen Section".
    	Using a default monitor configuration.
    [    21.495] (**) Option "DontZap" "false"
    [    21.495] (==) Automatically adding devices
    [    21.495] (==) Automatically enabling devices
    [    21.495] (==) Automatically adding GPU devices
    [    21.495] (==) Automatically binding GPU devices
    [    21.495] (==) Max clients allowed: 256, resource mask: 0x1fffff
    [    21.495] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
    [    21.495] 	Entry deleted from font path.
    [    21.495] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
    [    21.495] 	Entry deleted from font path.
    [    21.495] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
    [    21.495] 	Entry deleted from font path.
    [    21.495] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
    [    21.495] 	Entry deleted from font path.
    [    21.495] (==) FontPath set to:
    	/usr/share/fonts/misc/,
    	/usr/share/fonts/TTF/
    [    21.495] (==) ModulePath set to "/usr/lib/xorg/modules"
    [    21.495] (II) The server relies on udev to provide the list of input devices.
    	If no devices become available, reconfigure udev or disable AutoAddDevices.
    [    21.495] (II) Loader magic: 0x561c8d103d60
    [    21.495] (II) Module ABI versions:
    [    21.495] 	X.Org ANSI C Emulation: 0.4
    [    21.495] 	X.Org Video Driver: 23.0
    [    21.495] 	X.Org XInput driver : 24.1
    [    21.495] 	X.Org Server Extension : 10.0
    [    21.496] (++) using VT number 7
    
    [    21.496] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
    [    21.497] (II) xfree86: Adding drm device (/dev/dri/card0)
    [    21.510] (--) PCI:*(0:0:2:0) 8086:29b2:1019:2636 rev 2, Mem @ 0xfea80000/524288, 0xd0000000/268435456, 0xfe900000/1048576, I/O @ 0x0000ec00/8, BIOS @ 0x????????/131072
    [    21.510] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    [    21.510] (II) LoadModule: "glx"
    [    21.510] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [    21.512] (II) Module glx: vendor="X.Org Foundation"
    [    21.512] 	compiled for 1.19.6, module version = 1.0.0
    [    21.512] 	ABI class: X.Org Server Extension, version 10.0
    [    21.512] (==) Matched intel as autoconfigured driver 0
    [    21.512] (==) Matched intel as autoconfigured driver 1
    [    21.512] (==) Matched modesetting as autoconfigured driver 2
    [    21.512] (==) Matched fbdev as autoconfigured driver 3
    [    21.512] (==) Matched vesa as autoconfigured driver 4
    [    21.512] (==) Assigned the driver to the xf86ConfigLayout
    [    21.512] (II) LoadModule: "intel"
    [    21.513] (WW) Warning, couldn't open module intel
    [    21.513] (II) UnloadModule: "intel"
    [    21.513] (II) Unloading intel
    [    21.513] (EE) Failed to load module "intel" (module does not exist, 0)
    [    21.513] (II) LoadModule: "modesetting"
    [    21.513] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
    [    21.513] (II) Module modesetting: vendor="X.Org Foundation"
    [    21.513] 	compiled for 1.19.6, module version = 1.19.6
    [    21.513] 	Module class: X.Org Video Driver
    [    21.513] 	ABI class: X.Org Video Driver, version 23.0
    [    21.513] (II) LoadModule: "fbdev"
    [    21.513] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [    21.513] (II) Module fbdev: vendor="X.Org Foundation"
    [    21.513] 	compiled for 1.19.5, module version = 0.4.4
    [    21.513] 	Module class: X.Org Video Driver
    [    21.513] 	ABI class: X.Org Video Driver, version 23.0
    [    21.513] (II) LoadModule: "vesa"
    [    21.513] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [    21.513] (II) Module vesa: vendor="X.Org Foundation"
    [    21.513] 	compiled for 1.19.6, module version = 2.4.0
    [    21.513] 	Module class: X.Org Video Driver
    [    21.514] 	ABI class: X.Org Video Driver, version 23.0
    [    21.514] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [    21.514] (II) FBDEV: driver for framebuffer: fbdev
    [    21.514] (II) VESA: driver for VESA chipsets: vesa
    [    21.522] (II) modeset(0): using drv /dev/dri/card0
    [    21.522] (WW) Falling back to old probe method for fbdev
    [    21.522] (II) Loading sub module "fbdevhw"
    [    21.522] (II) LoadModule: "fbdevhw"
    [    21.522] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [    21.522] (II) Module fbdevhw: vendor="X.Org Foundation"
    [    21.522] 	compiled for 1.19.6, module version = 0.0.2
    [    21.522] 	ABI class: X.Org Video Driver, version 23.0
    [    21.522] (II) modeset(0): Creating default Display subsection in Screen section
    	"Default Screen Section" for depth/fbbpp 24/32
    [    21.522] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
    [    21.522] (==) modeset(0): RGB weight 888
    [    21.522] (==) modeset(0): Default visual is TrueColor
    [    21.522] (II) Loading sub module "glamoregl"
    [    21.522] (II) LoadModule: "glamoregl"
    [    21.522] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
    [    21.523] (II) Module glamoregl: vendor="X.Org Foundation"
    [    21.523] 	compiled for 1.19.6, module version = 1.0.0
    [    21.523] 	ABI class: X.Org ANSI C Emulation, version 0.4
    [    21.523] (II) glamor: OpenGL accelerated X.org driver based.
    [    21.532] (II) glamor: EGL version 1.4 (DRI2):
    [    21.540] (II) modeset(0): glamor initialized
    [    21.596] (II) modeset(0): Output VGA-1 has no monitor section
    [    21.644] (II) modeset(0): EDID for output VGA-1
    [    21.644] (II) modeset(0): Manufacturer: PHL  Model: c056  Serial#: 7191
    [    21.644] (II) modeset(0): Year: 2010  Week: 20
    [    21.644] (II) modeset(0): EDID Version: 1.3
    [    21.644] (II) modeset(0): Analog Display Input,  Input Voltage Level: 0.700/0.700 V
    [    21.644] (II) modeset(0): Sync:  Separate  Composite
    [    21.644] (II) modeset(0): Max Image Size [cm]: horiz.: 48  vert.: 27
    [    21.644] (II) modeset(0): Gamma: 2.20
    [    21.644] (II) modeset(0): DPMS capabilities: Off; RGB/Color Display
    [    21.644] (II) modeset(0): Default color space is primary color space
    [    21.644] (II) modeset(0): First detailed timing is preferred mode
    [    21.644] (II) modeset(0): redX: 0.648 redY: 0.339   greenX: 0.282 greenY: 0.603
    [    21.644] (II) modeset(0): blueX: 0.143 blueY: 0.070   whiteX: 0.313 whiteY: 0.329
    [    21.644] (II) modeset(0): Supported established timings:
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): [email protected]
    [    21.644] (II) modeset(0): Manufacturer's mask: 0
    [    21.644] (II) modeset(0): Supported standard timings:
    [    21.644] (II) modeset(0): #0: hsize: 1280  vsize 960  refresh: 60  vid: 16513
    [    21.644] (II) modeset(0): #1: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
    [    21.644] (II) modeset(0): #2: hsize: 1440  vsize 900  refresh: 60  vid: 149
    [    21.644] (II) modeset(0): #3: hsize: 1600  vsize 1200  refresh: 60  vid: 16553
    [    21.644] (II) modeset(0): #4: hsize: 1680  vsize 1050  refresh: 60  vid: 179
    [    21.644] (II) modeset(0): #5: hsize: 1920  vsize 1080  refresh: 60  vid: 49361
    [    21.644] (II) modeset(0): #6: hsize: 1152  vsize 864  refresh: 75  vid: 20337
    [    21.644] (II) modeset(0): Supported detailed timing:
    [    21.644] (II) modeset(0): clock: 148.5 MHz   Image Size:  477 x 268 mm
    [    21.644] (II) modeset(0): h_active: 1920  h_sync: 2008  h_sync_end 2052 h_blank_end 2200 h_border: 0
    [    21.644] (II) modeset(0): v_active: 1080  v_sync: 1084  v_sync_end 1089 v_blanking: 1125 v_border: 0
    [    21.644] (II) modeset(0): Serial No: AU11020007191
    [    21.644] (II) modeset(0): Ranges: V min: 56 V max: 76 Hz, H min: 30 H max: 83 kHz, PixClock max 175 MHz
    [    21.644] (II) modeset(0): Monitor name: Philips 221EL
    [    21.644] (II) modeset(0): EDID (in hex):
    [    21.644] (II) modeset(0): 	00ffffffffffff00410c56c0171c0000
    [    21.644] (II) modeset(0): 	141401036c301b782e3585a656489a24
    [    21.644] (II) modeset(0): 	125054af6f00814081809500a940b300
    [    21.644] (II) modeset(0): 	d1c0714f0101023a801871382d40582c
    [    21.644] (II) modeset(0): 	4500dd0c1100001e000000ff00415531
    [    21.644] (II) modeset(0): 	31303230303037313931000000fd0038
    [    21.644] (II) modeset(0): 	4c1e5311000a202020202020000000fc
    [    21.644] (II) modeset(0): 	005068696c69707320323231454c00a3
    [    21.644] (II) modeset(0): Printing probed modes for output VGA-1
    [    21.644] (II) modeset(0): Modeline "1920x1080"x60.0  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync (67.5 kHz eP)
    [    21.644] (II) modeset(0): Modeline "1600x1200"x60.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz e)
    [    21.644] (II) modeset(0): Modeline "1680x1050"x60.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz e)
    [    21.644] (II) modeset(0): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz e)
    [    21.644] (II) modeset(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
    [    21.644] (II) modeset(0): Modeline "1440x900"x59.9  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz e)
    [    21.644] (II) modeset(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz e)
    [    21.644] (II) modeset(0): Modeline "1152x864"x75.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz e)
    [    21.644] (II) modeset(0): Modeline "1024x768"x75.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz e)
    [    21.644] (II) modeset(0): Modeline "1024x768"x70.1   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz e)
    [    21.644] (II) modeset(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
    [    21.644] (II) modeset(0): Modeline "832x624"x74.6   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz e)
    [    21.644] (II) modeset(0): Modeline "800x600"x75.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz e)
    [    21.644] (II) modeset(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
    [    21.644] (II) modeset(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz e)
    [    21.644] (II) modeset(0): Modeline "640x480"x75.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz e)
    [    21.644] (II) modeset(0): Modeline "640x480"x72.8   31.50  640 664 704 832  480 489 492 520 -hsync -vsync (37.9 kHz e)
    [    21.644] (II) modeset(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
    [    21.644] (II) modeset(0): Modeline "720x400"x70.1   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz e)
    [    21.644] (II) modeset(0): Output VGA-1 connected
    [    21.644] (II) modeset(0): Using exact sizes for initial modes
    [    21.644] (II) modeset(0): Output VGA-1 using initial mode 1920x1080 +0+0
    [    21.644] (==) modeset(0): Using gamma correction (1.0, 1.0, 1.0)
    [    21.644] (==) modeset(0): DPI set to (96, 96)
    [    21.644] (II) Loading sub module "fb"
    [    21.644] (II) LoadModule: "fb"
    [    21.644] (II) Loading /usr/lib/xorg/modules/libfb.so
    [    21.645] (II) Module fb: vendor="X.Org Foundation"
    [    21.645] 	compiled for 1.19.6, module version = 1.0.0
    [    21.645] 	ABI class: X.Org ANSI C Emulation, version 0.4
    [    21.645] (II) UnloadModule: "fbdev"
    [    21.645] (II) Unloading fbdev
    [    21.645] (II) UnloadSubModule: "fbdevhw"
    [    21.645] (II) Unloading fbdevhw
    [    21.645] (II) UnloadModule: "vesa"
    [    21.645] (II) Unloading vesa
    [    21.645] (==) Depth 24 pixmap format is 32 bpp
    [    21.645] Require OpenGL version 2.1 or later.
    [    21.645] (EE) modeset(0): Failed to initialize glamor at ScreenInit() time.
    [    21.645] (EE) 
    Fatal server error:
    [    21.645] (EE) AddScreen/ScreenInit failed for driver 0
    [    21.645] (EE) 
    [    21.645] (EE) 
    Please consult the The X.Org Foundation support 
    	 at http://wiki.x.org
     for help. 
    [    21.645] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [    21.645] (EE) 
    [    21.664] (EE) Server terminated with error (1). Closing log file.
    

    It looks a lot like a problem with the driver. But I don’t have the solution…

  • Could Wayland be the solution ?

  • @askkenneth i do not think that wayland will solve anything here…

    But may you need the intel driver instead of falling back on the modesetting driver…

    1. read

    https://wiki.archlinux.org/index.php/intel_graphics

    1. install
    pacman -Syu xf86-video-intel
    
    1. create the conf file:
    sudo nano /etc/X11/xorg.conf.d/20-intel.conf
    

    with this inside

    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
    EndSection
    
    1. reboot

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad
    It works, that was the solution.
    Thank-you so much 🙂

  • you are welcome!

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

fresh29 starting18 Posts 16Views 163
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.